aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-05-21 15:25:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-05-21 15:25:40 +0000
commitcb28a089d6411df0d0b1b66fd0e0c7c1ccd16121 (patch)
treec451cdd06b2182a3eb38fdda83d6a100556578cf
parentb6a8134ab481959cf0483e4b2e646a781f2e778d (diff)
downloadports-cb28a089d6411df0d0b1b66fd0e0c7c1ccd16121.tar.gz
ports-cb28a089d6411df0d0b1b66fd0e0c7c1ccd16121.zip
Remove GH_COMMIT support.
Differential Revision: https://reviews.freebsd.org/D2606 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=386936
-rw-r--r--CHANGES5
-rw-r--r--Mk/bsd.port.mk6
-rw-r--r--Mk/bsd.sanity.mk2
-rw-r--r--Mk/bsd.sites.mk27
4 files changed, 10 insertions, 30 deletions
diff --git a/CHANGES b/CHANGES
index 52781bd1a697..19442d133e9b 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,11 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20150521:
+AUTHOR: mat@FreeBSD.org
+
+ GH_COMMIT support has been removed, see the 20150319 for more informations.
+
20150419:
AUTHOR: tijl@FreeBSD.org
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bd17be75731e..a0a0a4b696b2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1316,7 +1316,7 @@ _SUF2= ,${PORTEPOCH}
PKGVERSION= ${PORTVERSION:C/[-_,]/./g}${_SUF1}${_SUF2}
PKGNAME= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}-${PKGVERSION}
DISTVERSIONFULL= ${DISTVERSIONPREFIX}${DISTVERSION:C/:(.)/\1/g}${DISTVERSIONSUFFIX}
-.if defined(USE_GITHUB) && !defined(GH_COMMIT) && empty(MASTER_SITES:MGHC)
+.if defined(USE_GITHUB) && empty(MASTER_SITES:MGHC)
# Only add in DISTVERSIONFULL if GH_TAGNAME if set by port. Otherwise
# GH_TAGNAME defaults to DISTVERSIONFULL; Avoid adding DISTVERSIONFULL in twice.
. if defined(GH_TAGNAME)
@@ -1555,11 +1555,7 @@ CONFIGURE_ENV+= PKG_CONFIG_SYSROOT_DIR="${X_SYSROOT}"
WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
.if !defined(IGNORE_MASTER_SITE_GITHUB) && defined(USE_GITHUB)
-. if defined(GH_COMMIT)
-WRKSRC?= ${WRKDIR}/${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}
-. else
WRKSRC?= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME_EXTRACT}
-. endif
.endif
.if defined(NO_WRKSUBDIR)
WRKSRC?= ${WRKDIR}
diff --git a/Mk/bsd.sanity.mk b/Mk/bsd.sanity.mk
index 167c14796c83..cc427233bf4f 100644
--- a/Mk/bsd.sanity.mk
+++ b/Mk/bsd.sanity.mk
@@ -64,7 +64,7 @@ DEV_ERROR+= "USE_ZOPE=yes is unsupported, please use USES=zope instead"
.endif
.if defined(USE_GITHUB) && defined(GH_COMMIT)
-DEV_WARNING+= "GH_COMMIT is deprecated, please convert GHL-\>GH in MASTER_SITES and set GH_TAGNAME to tag or commit hash and remove GH_COMMIT"
+DEV_ERROR+= "GH_COMMIT is unsupported, please convert GHL-\>GH in MASTER_SITES and set GH_TAGNAME to tag or commit hash and remove GH_COMMIT"
.endif
.if defined(USE_GNOME) && ${USE_GNOME:Mgnomehack}
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index 937396921a3b..3a6ec1c855b2 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -509,13 +509,6 @@ MASTER_SITE_GENTOO+= \
# possible to do GH_TAGNAME= GIT_HASH to do a snapshot.
# default: ${DISTVERSION}
#
-# GH_COMMIT - first 7 digits of the commit that generated GH_TAGNAME
-# (man git-describe(1))
-# if this is not set, archive corresponding to tag is fetched
-# default: not set
-# This is a deprecated option. Just set the hash in GH_TAGNAME
-# instead.
-#
.if defined(USE_GITHUB)
. if defined(GH_TAGNAME) && ${GH_TAGNAME} == master
IGNORE?= Using master as GH_TAGNAME is invalid. \
@@ -526,32 +519,20 @@ IGNORE?= Using master as GH_TAGNAME is invalid. \
# comment #15 for explanation as to why and how to deal with it if it breaks.
MASTER_SITE_GITHUB+= https://codeload.github.com/%SUBDIR%
MASTER_SITE_GITHUB_CLOUD+= http://cloud.github.com/downloads/%SUBDIR%
-MASTER_SITE_GITHUB_LEGACY+= https://codeload.github.com/%SUBDIR%
-
-. if defined(GH_COMMIT)
-. if !defined(MASTER_SITES) || !${MASTER_SITES:MGHL}
-MASTER_SITES+= GHL
-. endif
-. else
-. if !defined(MASTER_SITES) || !${MASTER_SITES:MGH} && !${MASTER_SITES:MGHC}
+
+. if !defined(MASTER_SITES) || !${MASTER_SITES:MGH} && !${MASTER_SITES:MGHC}
MASTER_SITES+= GH
-. endif
. endif
GH_ACCOUNT?= ${PORTNAME}
GH_PROJECT?= ${PORTNAME}
-. if defined(GH_COMMIT)
-# Use the old style for safety for now.
-GH_TAGNAME?= ${DISTVERSION}
-. else
# Use full PREFIX/SUFFIX and converted DISTVERSION
GH_TAGNAME?= ${DISTVERSIONFULL}
# This new scheme rerolls distfiles. Also ensure they are renamed to avoid
# conflicts. Use _GITHUB_REV in case github changes their zipping or structure
# which has happened before.
_GITHUB_REV= 0
-. if ${MASTER_SITES:MGH}
+. if ${MASTER_SITES:MGH}
DISTNAME:= ${DISTNAME}_GH${_GITHUB_REV}
-. endif
. endif
. if defined(GH_TAGNAME)
GH_TAGNAME_SANITIZED= ${GH_TAGNAME:S,/,-,}
@@ -1301,7 +1282,6 @@ MASTER_SITE_KERNEL_ORG+= \
MASTER_SITES_ABBREVS= CPAN:PERL_CPAN \
GH:GITHUB \
GHC:GITHUB_CLOUD \
- GHL:GITHUB_LEGACY \
LODEV:LIBREOFFICE_DEV \
NL:NETLIB \
RG:RUBYGEMS \
@@ -1320,7 +1300,6 @@ MASTER_SITES_SUBDIRS= APACHE_COMMONS_BINARIES:${PORTNAME:S,commons-,,} \
GIMP:${PORTNAME}/${PORTVERSION:R}/ \
GITHUB:${GH_ACCOUNT}/${GH_PROJECT}/tar.gz/${GH_TAGNAME}?dummy=/ \
GITHUB_CLOUD:${GH_ACCOUNT}/${GH_PROJECT}/ \
- GITHUB_LEGACY:${GH_ACCOUNT}/${GH_PROJECT}/legacy.tar.gz/${GH_TAGNAME}?dummy=/ \
GNOME:sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/} \
GNU:${PORTNAME} \
GNUPG:${PORTNAME} \