aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2018-01-11 17:34:22 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2018-01-11 17:34:22 +0000
commitcb314738e8ff6b1a70f03d5385d66f47c7506571 (patch)
treeceb09f0486b552ede3e5eb18b4f8f098edbe97aa
parent37ea47b83a851f42a018b51d0af68bab558c77a5 (diff)
downloadports-cb314738e8ff6b1a70f03d5385d66f47c7506571.tar.gz
ports-cb314738e8ff6b1a70f03d5385d66f47c7506571.zip
Notes
-rw-r--r--www/libevhtp/Makefile1
-rw-r--r--www/libevhtp/files/patch-evhtp.c30
2 files changed, 31 insertions, 0 deletions
diff --git a/www/libevhtp/Makefile b/www/libevhtp/Makefile
index 344f7e04cc35..332db0c051fa 100644
--- a/www/libevhtp/Makefile
+++ b/www/libevhtp/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libevhtp
PORTVERSION= 1.2.15
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= ultima@FreeBSD.org
diff --git a/www/libevhtp/files/patch-evhtp.c b/www/libevhtp/files/patch-evhtp.c
new file mode 100644
index 000000000000..0a492d710b2f
--- /dev/null
+++ b/www/libevhtp/files/patch-evhtp.c
@@ -0,0 +1,30 @@
+--- evhtp.c.orig 2017-12-06 22:34:23 UTC
++++ evhtp.c
+@@ -2373,15 +2373,15 @@ htp__connection_writecb_(struct bufferevent * bev, voi
+ return;
+ }
+
+- /* run user-hook for on_write callback before further analysis */
+- htp__hook_connection_write_(conn);
+-
+ /* connection is in a paused state, no further processing yet */
+ if ((conn->flags & EVHTP_CONN_FLAG_PAUSED))
+ {
+ return;
+ }
+
++ /* run user-hook for on_write callback before further analysis */
++ htp__hook_connection_write_(conn);
++
+ if (conn->flags & EVHTP_CONN_FLAG_WAITING)
+ {
+ HTP_FLAG_OFF(conn, EVHTP_CONN_FLAG_WAITING);
+@@ -3043,7 +3043,7 @@ evhtp_connection_pause(evhtp_connection_t * c)
+
+ HTP_FLAG_ON(c, EVHTP_CONN_FLAG_PAUSED);
+
+- bufferevent_disable(c->bev, EV_READ | EV_WRITE);
++ bufferevent_disable(c->bev, EV_READ);
+
+ return;
+ }