aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-03-25 07:23:06 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-03-25 07:23:06 +0000
commitcb3a8e9513ed0b49b44e5e85169b3305c71fcc47 (patch)
tree0892304dc15668bfa6ee5664f57dc336c49c464f
parent119550bc4d9908c86f4b5383c3f1a311a3814932 (diff)
downloadports-cb3a8e9513ed0b49b44e5e85169b3305c71fcc47.tar.gz
ports-cb3a8e9513ed0b49b44e5e85169b3305c71fcc47.zip
Notes
-rw-r--r--converters/p5-Text-Iconv/Makefile13
-rw-r--r--converters/p5-Text-Iconv/files/patch-Makefile.PL25
2 files changed, 36 insertions, 2 deletions
diff --git a/converters/p5-Text-Iconv/Makefile b/converters/p5-Text-Iconv/Makefile
index 68f101eee193..e65f67cfaf3e 100644
--- a/converters/p5-Text-Iconv/Makefile
+++ b/converters/p5-Text-Iconv/Makefile
@@ -13,6 +13,15 @@ COMMENT= Perl interface to iconv() codeset conversion function
USES= perl5 iconv
USE_PERL5= configure
CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}"
+ LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}" \
+ ccflags="${CFLAGS}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} >= 1000043
+ @${REINPLACE_CMD} 's|<iconv.h>|"/usr/include/iconv.h"|' \
+ ${WRKSRC}/Iconv.xs
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/converters/p5-Text-Iconv/files/patch-Makefile.PL b/converters/p5-Text-Iconv/files/patch-Makefile.PL
new file mode 100644
index 000000000000..f68385a8bd35
--- /dev/null
+++ b/converters/p5-Text-Iconv/files/patch-Makefile.PL
@@ -0,0 +1,25 @@
+--- Makefile.PL.orig 2007-10-17 16:06:22.000000000 +0200
++++ Makefile.PL 2014-03-24 21:28:37.147481295 +0100
+@@ -90,6 +90,7 @@
+ AUTHOR => 'Michael Piotrowski <mxp@dynalabs.de>') : ()),
+ 'LIBS' => $config{LIBS},
+ 'DEFINE' => "@DEFINE",
++ 'CCFLAGS' => $config{ccflags},
+ 'INC' => $config{INC},
+ 'dist' => {COMPRESS => 'gzip', SUFFIX => 'gz'},
+ );
+@@ -119,12 +120,12 @@
+ {
+ # It is admittedly a bit simplistic to simply concatenate all
+ # flags, but it seems to work in most cases.
+- $compile = join ' ', $Config{cc}, $incs, $Config{ccflags},
++ $compile = join ' ', $Config{cc}, $incs, $config{ccflags},
+ $Config{ldflags}, $libs;
+ }
+ else
+ {
+- $compile = join ' ', $Config{cc}, $incs, $Config{ccflags}, $libs;
++ $compile = join ' ', $Config{cc}, $incs, $config{ccflags}, $libs;
+ }
+
+ if (exists $config{verbose})