aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2000-07-10 15:33:16 +0000
committerJim Mock <jim@FreeBSD.org>2000-07-10 15:33:16 +0000
commitcbac3e7b85a2a370a7b9d8418c66421db4c6d47d (patch)
treee202892776c92e8e4c968f51b0aa80f10a34eeb4
parent6254a80fa6ab0f4fcf2f7c823ef317051bab41a3 (diff)
downloadports-cbac3e7b85a2a370a7b9d8418c66421db4c6d47d.tar.gz
ports-cbac3e7b85a2a370a7b9d8418c66421db4c6d47d.zip
Notes
-rw-r--r--mail/teapop-devel/Makefile39
-rw-r--r--mail/teapop-devel/distinfo1
-rw-r--r--mail/teapop-devel/pkg-comment1
-rw-r--r--mail/teapop-devel/pkg-descr7
-rw-r--r--mail/teapop-devel/pkg-plist2
-rw-r--r--mail/teapop/Makefile39
-rw-r--r--mail/teapop/distinfo1
-rw-r--r--mail/teapop/pkg-comment1
-rw-r--r--mail/teapop/pkg-descr7
-rw-r--r--mail/teapop/pkg-plist2
10 files changed, 100 insertions, 0 deletions
diff --git a/mail/teapop-devel/Makefile b/mail/teapop-devel/Makefile
new file mode 100644
index 000000000000..e3e2d1adfe7a
--- /dev/null
+++ b/mail/teapop-devel/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: teapop
+# Date created: 18 May 2000
+# Whom: Jim Mock <jim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= teapop
+PORTVERSION= 0.25
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.toontown.org/pub/teapop/ \
+ http://www.toontown.org/pub/teapop/
+DISTNAME= ${PORTNAME}-latest
+
+MAINTAINER= jim@FreeBSD.org
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-flock
+
+.if defined(WITHOUT_APOP)
+CONFIGURE_ARGS+= --disable-apop
+.endif
+
+.if defined(WITHOUT_VPOP)
+CONFIGURE_ARGS+= --disable-vpop
+.endif
+
+.if defined(WITH_PGSQL)
+CONFIGURE_ARGS+= --with-pgsql=${PREFIX}/pgsql
+.endif
+
+MAN8= teapop.8
+
+.include <bsd.port.mk>
diff --git a/mail/teapop-devel/distinfo b/mail/teapop-devel/distinfo
new file mode 100644
index 000000000000..3641e453f46b
--- /dev/null
+++ b/mail/teapop-devel/distinfo
@@ -0,0 +1 @@
+MD5 (teapop-latest.tar.gz) = f862783be16a0542531dc09eacb53b02
diff --git a/mail/teapop-devel/pkg-comment b/mail/teapop-devel/pkg-comment
new file mode 100644
index 000000000000..daca3c48c049
--- /dev/null
+++ b/mail/teapop-devel/pkg-comment
@@ -0,0 +1 @@
+Yet another RFC1939 compliant POP3 server
diff --git a/mail/teapop-devel/pkg-descr b/mail/teapop-devel/pkg-descr
new file mode 100644
index 000000000000..b6155738a302
--- /dev/null
+++ b/mail/teapop-devel/pkg-descr
@@ -0,0 +1,7 @@
+Teapop is yet another RFC1939 compliant POP3 server. It includes
+flexible virtual domain support that distinguishes it from all other
+POP3 servers.
+
+WWW: http://www.toontown.org/teapop/
+
+- jim <jim@FreeBSD.org>
diff --git a/mail/teapop-devel/pkg-plist b/mail/teapop-devel/pkg-plist
new file mode 100644
index 000000000000..285abda1f705
--- /dev/null
+++ b/mail/teapop-devel/pkg-plist
@@ -0,0 +1,2 @@
+libexec/teapop
+etc/teapop.passwd
diff --git a/mail/teapop/Makefile b/mail/teapop/Makefile
new file mode 100644
index 000000000000..e3e2d1adfe7a
--- /dev/null
+++ b/mail/teapop/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: teapop
+# Date created: 18 May 2000
+# Whom: Jim Mock <jim@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= teapop
+PORTVERSION= 0.25
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.toontown.org/pub/teapop/ \
+ http://www.toontown.org/pub/teapop/
+DISTNAME= ${PORTNAME}-latest
+
+MAINTAINER= jim@FreeBSD.org
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-flock
+
+.if defined(WITHOUT_APOP)
+CONFIGURE_ARGS+= --disable-apop
+.endif
+
+.if defined(WITHOUT_VPOP)
+CONFIGURE_ARGS+= --disable-vpop
+.endif
+
+.if defined(WITH_PGSQL)
+CONFIGURE_ARGS+= --with-pgsql=${PREFIX}/pgsql
+.endif
+
+MAN8= teapop.8
+
+.include <bsd.port.mk>
diff --git a/mail/teapop/distinfo b/mail/teapop/distinfo
new file mode 100644
index 000000000000..3641e453f46b
--- /dev/null
+++ b/mail/teapop/distinfo
@@ -0,0 +1 @@
+MD5 (teapop-latest.tar.gz) = f862783be16a0542531dc09eacb53b02
diff --git a/mail/teapop/pkg-comment b/mail/teapop/pkg-comment
new file mode 100644
index 000000000000..daca3c48c049
--- /dev/null
+++ b/mail/teapop/pkg-comment
@@ -0,0 +1 @@
+Yet another RFC1939 compliant POP3 server
diff --git a/mail/teapop/pkg-descr b/mail/teapop/pkg-descr
new file mode 100644
index 000000000000..b6155738a302
--- /dev/null
+++ b/mail/teapop/pkg-descr
@@ -0,0 +1,7 @@
+Teapop is yet another RFC1939 compliant POP3 server. It includes
+flexible virtual domain support that distinguishes it from all other
+POP3 servers.
+
+WWW: http://www.toontown.org/teapop/
+
+- jim <jim@FreeBSD.org>
diff --git a/mail/teapop/pkg-plist b/mail/teapop/pkg-plist
new file mode 100644
index 000000000000..285abda1f705
--- /dev/null
+++ b/mail/teapop/pkg-plist
@@ -0,0 +1,2 @@
+libexec/teapop
+etc/teapop.passwd