aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2020-09-25 19:44:49 +0000
committerNicola Vitale <nivit@FreeBSD.org>2020-09-25 19:44:49 +0000
commitcbbbcbd29cfd6f87f0f32a85339297088a505070 (patch)
treed959223cfece1b8690a36c4f0db276bb6a11cb12
parent01705733ec2174bc61bbe5673206f4e874f777ce (diff)
downloadports-cbbbcbd29cfd6f87f0f32a85339297088a505070.tar.gz
ports-cbbbcbd29cfd6f87f0f32a85339297088a505070.zip
Notes
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/clipmenu/Makefile49
-rw-r--r--deskutils/clipmenu/distinfo3
-rw-r--r--deskutils/clipmenu/pkg-descr4
4 files changed, 57 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index fce52e31b72f..85c765c26a1a 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -31,6 +31,7 @@
SUBDIR += charmtimetracker
SUBDIR += chart
SUBDIR += clipit
+ SUBDIR += clipmenu
SUBDIR += clipnotify
SUBDIR += conkyforecast
SUBDIR += copyq
diff --git a/deskutils/clipmenu/Makefile b/deskutils/clipmenu/Makefile
new file mode 100644
index 000000000000..ed84e4b9fee8
--- /dev/null
+++ b/deskutils/clipmenu/Makefile
@@ -0,0 +1,49 @@
+# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= clipmenu
+DISTVERSION= 6.1.0
+CATEGORIES= deskutils
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Clipboard management using dmenu, rofi or fzf
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= bash:shells/bash \
+ clipnotify:deskutils/clipnotify \
+ xsel:x11/xsel-conrad
+
+USES= xorg
+
+PLIST_FILES= bin/clipctl bin/clipdel bin/clipfsck bin/clipmenu bin/clipmenud
+
+OPTIONS_DEFAULT= DMENU
+OPTIONS_SINGLE= LAUNCHER
+OPTIONS_SINGLE_LAUNCHER= DMENU FZF ROFI
+
+DMENU_DESC= Use dmenu to show clipboard selections
+FZF_DESC= Use fzf to manage clipboard selections
+ROFI_DESC= Use rofi to show clipboard selections
+
+DMENU_RUN_DEPENDS= dmenu:x11/dmenu
+FZF_RUN_DEPENDS= fzf:textproc/fzf
+ROFI_RUN_DEPENDS= rofi:x11/rofi
+
+USE_XORG= x11 xfixes
+
+USE_GITHUB= yes
+GH_ACCOUNT= cdown
+
+post-extract:
+ @${REINPLACE_CMD} -e '3s,dmenu,${SELECTED_OPTIONS:tl},1' ${WRKSRC}/clipmenu
+
+do-build:
+ ${DO_NADA}
+
+do-install:
+ @cd ${WRKSRC} && ${INSTALL_SCRIPT} clipctl clipdel clipfsck clipmenu clipmenud \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/clipmenu/distinfo b/deskutils/clipmenu/distinfo
new file mode 100644
index 000000000000..8710bda7c1c2
--- /dev/null
+++ b/deskutils/clipmenu/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1601050352
+SHA256 (cdown-clipmenu-6.1.0_GH0.tar.gz) = 1b5da22fac3bbee254267f9274746f747019c5f9a1f53cde0ddc1591053d2342
+SIZE (cdown-clipmenu-6.1.0_GH0.tar.gz) = 8711
diff --git a/deskutils/clipmenu/pkg-descr b/deskutils/clipmenu/pkg-descr
new file mode 100644
index 000000000000..e604b9f70ba1
--- /dev/null
+++ b/deskutils/clipmenu/pkg-descr
@@ -0,0 +1,4 @@
+clipmenu is a simple clipboard manager using dmenu (or rofi with
+CM_LAUNCHER=rofi) and xsel.
+
+WWW: https://github.com/cdown/clipmenu