aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-11-05 16:32:57 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-11-05 16:32:57 +0000
commitcbbf190e5e0d3f9bba3451679ffcd5049590b468 (patch)
treec403714eca8432ba36e52643602b08a8b7e62732
parent0c949f02c10957ea1a87aa35ed04ececf833e148 (diff)
downloadports-cbbf190e5e0d3f9bba3451679ffcd5049590b468.tar.gz
ports-cbbf190e5e0d3f9bba3451679ffcd5049590b468.zip
Notes
-rw-r--r--emulators/bsvc/Makefile10
-rw-r--r--emulators/bsvc/files/patch-af21
-rw-r--r--emulators/bsvc/files/patch-src-Makefile.common2
3 files changed, 16 insertions, 17 deletions
diff --git a/emulators/bsvc/Makefile b/emulators/bsvc/Makefile
index 87c1279c1ef0..dc07f39210e4 100644
--- a/emulators/bsvc/Makefile
+++ b/emulators/bsvc/Makefile
@@ -13,12 +13,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An extensible hardware simulation framework with MC68K support
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-MAKE_ENV= PROJECT_BASE=${PREFIX} WRKSRC=${WRKSRC}
-USE_TK_RUN= yes
-MAKE_JOBS_UNSAFE= yes
+MAKE_ENV= PROJECT_BASE=${STAGEDIR}${PREFIX} WRKSRC=${WRKSRC} WISH=${WISH}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+USES+= tk
+MAKE_JOBS_UNSAFE= yes
pre-patch:
@${CP} ${WRKSRC}/Makefile.Linux ${WRKSRC}/Makefile
@@ -39,4 +37,4 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile -exec \
${REINPLACE_CMD} -e 's/make/$(MAKE)/' \{\} \;
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/bsvc/files/patch-af b/emulators/bsvc/files/patch-af
index 7ca220ac5426..68e06e9f09d3 100644
--- a/emulators/bsvc/files/patch-af
+++ b/emulators/bsvc/files/patch-af
@@ -1,34 +1,35 @@
---- UI/Makefile.orig Mon Sep 6 19:43:39 1999
-+++ UI/Makefile Mon Sep 6 21:35:14 1999
+--- UI/Makefile.orig 1998-11-09 04:39:29.000000000 +0100
++++ UI/Makefile 2013-11-05 17:30:19.000000000 +0100
@@ -20,31 +20,31 @@
echo '# export TCL_LIBRARY TK_LIBRARY' >> bsvc
echo 'ARGS=$$*' >> bsvc
echo 'export ARGS' >> bsvc
- echo 'exec $(WISH) -f $(INSTALL_DIR)/UI/bsvc.tk' >> bsvc
-+ echo 'exec $(WISH) -f $(PROJECT_BASE)/lib/bsvc/bsvc.tk' >> bsvc
++ echo 'exec $(WISH) -f $(PREFIX)/lib/bsvc/bsvc.tk' >> bsvc
chmod +x bsvc
bsvc.tk: Makefile
echo '#!$(WISH) -f' > bsvc.tk
- echo 'set Program(InstallDir) $(INSTALL_DIR)' >> bsvc.tk
+- echo 'set Program(InstallDir) $(INSTALL_DIR)' >> bsvc.tk
- echo 'set Program(BitmapDir) $$Program(InstallDir)/UI/bitmaps' >> bsvc.tk
- echo 'set Program(HelpDir) $$Program(InstallDir)/UI/help' >> bsvc.tk
- echo 'set Program(LibDir) $$Program(InstallDir)/UI' >> bsvc.tk
-+ echo 'set Program(BitmapDir) $(PROJECT_BASE)/lib/bsvc/bitmaps' >> bsvc.tk
-+ echo 'set Program(HelpDir) $(PROJECT_BASE)/lib/bsvc/help' >> bsvc.tk
-+ echo 'set Program(LibDir) $(PROJECT_BASE)/lib/bsvc' >> bsvc.tk
++ echo 'set Program(InstallDir) $(PREFIX)' >> bsvc.tk
++ echo 'set Program(BitmapDir) $(PREFIX)/lib/bsvc/bitmaps' >> bsvc.tk
++ echo 'set Program(HelpDir) $(PREFIX)/lib/bsvc/help' >> bsvc.tk
++ echo 'set Program(LibDir) $(PREFIX)/lib/bsvc' >> bsvc.tk
echo 'set Program(WWWBrowser) "$(WWW_BROWSER)"' >> bsvc.tk
echo 'set Program(WWWHomePage) "$(WWW_HOME_PAGE)"' >> bsvc.tk
echo 'set Program(StopIndicator) C:\\BSVC\\bin\\STOP' >> bsvc.tk
echo 'if {$$tcl_version >= 7.5 && $$tcl_platform(platform) == "windows"} {' >> bsvc.tk
- echo ' option readfile $$Program(InstallDir)/UI/bsvc.win 40' >> bsvc.tk
-+ echo ' option readfile $(PROJECT_BASE)/lib/bsvc/bsvc.win 40' >> bsvc.tk
++ echo ' option readfile $(PREFIX)/lib/bsvc/bsvc.win 40' >> bsvc.tk
echo '} else {' >> bsvc.tk
- echo ' option readfile $$Program(InstallDir)/UI/bsvc.ad 40' >> bsvc.tk
-+ echo ' option readfile $(PROJECT_BASE)/lib/bsvc/bsvc.ad 40' >> bsvc.tk
++ echo ' option readfile $(PREFIX)/lib/bsvc/bsvc.ad 40' >> bsvc.tk
echo '}' >> bsvc.tk
- echo 'source $$Program(InstallDir)/UI/main.tk' >> bsvc.tk
-+ echo 'source $(PROJECT_BASE)/lib/bsvc/main.tk' >> bsvc.tk
++ echo 'source $(PREFIX)/lib/bsvc/main.tk' >> bsvc.tk
install: bsvc bsvc.tk
- $(MKDIR) $(INSTALL_DIR)/UI
diff --git a/emulators/bsvc/files/patch-src-Makefile.common b/emulators/bsvc/files/patch-src-Makefile.common
index 1131b6b81fa1..631ac5d72ef5 100644
--- a/emulators/bsvc/files/patch-src-Makefile.common
+++ b/emulators/bsvc/files/patch-src-Makefile.common
@@ -13,7 +13,7 @@
## Name or path and Name of the Tcl/Tk "wish" executable
#WISH = /usr/bin/wish
-WISH = wish
-+WISH = wish8.4
++WISH ?= wish8.4
## Name of WWW Browser and URL of the BSVC Home Page (or blank)
WWW_BROWSER =