aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 03:58:47 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-08 03:58:47 +0000
commitcc48fc8ef51abbb7ad7742307d92ef3cfa31e282 (patch)
tree869558d9313b864b4020b22ef3f8a555b1c4c7d7
parent985da4a37c3269d18ec5f060e2896b011f8e1506 (diff)
downloadports-cc48fc8ef51abbb7ad7742307d92ef3cfa31e282.tar.gz
ports-cc48fc8ef51abbb7ad7742307d92ef3cfa31e282.zip
Notes
-rw-r--r--irc/ninja/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/irc/ninja/Makefile b/irc/ninja/Makefile
index 3171e95d2b10..08bfde8edd6f 100644
--- a/irc/ninja/Makefile
+++ b/irc/ninja/Makefile
@@ -16,15 +16,14 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= IRCLIB="${DATADIR}"
MAKE_JOBS_UNSAFE= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|%%IRCLIB%%|${DATADIR}|g" \
${WRKSRC}/include/config.h.dist
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ninja ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/ninjawserv ${PREFIX}/bin
- @${MKDIR} ${DATADIR}/translation
- ${INSTALL_DATA} ${WRKSRC}/translation/* ${DATADIR}/translation
+ ${INSTALL_PROGRAM} ${WRKSRC}/ninja ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/ninjawserv ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}/translation
+ ${INSTALL_DATA} ${WRKSRC}/translation/* ${STAGEDIR}${DATADIR}/translation
.include <bsd.port.mk>