aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:36:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:36:11 +0000
commitcc570daf104bd7425db9f1ccea172542d8f79fc5 (patch)
tree256acbcb575ad114e852530ad480fcb9ef16b896
parent683a0971e745c042b83c8e0a20de4e2f2faae60d (diff)
downloadports-cc570daf104bd7425db9f1ccea172542d8f79fc5.tar.gz
ports-cc570daf104bd7425db9f1ccea172542d8f79fc5.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libee/Makefile24
-rw-r--r--devel/libee/distinfo2
-rw-r--r--devel/libee/files/patch-Makefile.in11
-rw-r--r--devel/libee/files/patch-include_libee_timestamp.h11
-rw-r--r--devel/libee/pkg-descr11
-rw-r--r--devel/libee/pkg-plist29
7 files changed, 89 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a2c4381abd16..8772c73d300c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -793,6 +793,7 @@
SUBDIR += libdsp
SUBDIR += libdwarf
SUBDIR += libedit
+ SUBDIR += libee
SUBDIR += libelf
SUBDIR += libepp-nicbr
SUBDIR += libestr
diff --git a/devel/libee/Makefile b/devel/libee/Makefile
new file mode 100644
index 000000000000..f960be94a5b9
--- /dev/null
+++ b/devel/libee/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libee
+# Date created: 2011-06-20
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libee
+PORTVERSION= 0.3.1
+CATEGORIES= devel
+MASTER_SITES= http://www.libee.org/files/download/
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= An event expression library inspired by CEE
+
+LIB_DEPENDS= estr:${PORTSDIR}/devel/libestr
+
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBESTR_CFLAGS="-I${LOCALBASE}/include" LIBESTR_LIBS="-L${LOCALBASE}/lib -lestr"
+CONFIGURE_ARGS+= --prefix="${PREFIX}" --disable-testbench
+
+.include <bsd.port.mk>
diff --git a/devel/libee/distinfo b/devel/libee/distinfo
new file mode 100644
index 000000000000..8ebaabb0fb01
--- /dev/null
+++ b/devel/libee/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libee-0.3.1.tar.gz) = 7c665b786cf6501378d0a1a64107c82441df9607fcc5340893aa8b82ff6ceaee
+SIZE (libee-0.3.1.tar.gz) = 350704
diff --git a/devel/libee/files/patch-Makefile.in b/devel/libee/files/patch-Makefile.in
new file mode 100644
index 000000000000..ebc4f178d4ae
--- /dev/null
+++ b/devel/libee/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2011-06-20 14:08:32.835431092 -0500
++++ Makefile.in 2011-06-20 14:08:56.609771691 -0500
+@@ -257,7 +257,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = tests include src
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libee.pc
+ ACLOCAL_AMFLAGS = -I m4
+ all: config.h
diff --git a/devel/libee/files/patch-include_libee_timestamp.h b/devel/libee/files/patch-include_libee_timestamp.h
new file mode 100644
index 000000000000..31c7dcea42a1
--- /dev/null
+++ b/devel/libee/files/patch-include_libee_timestamp.h
@@ -0,0 +1,11 @@
+--- include/libee/timestamp.h.orig 2011-06-21 14:30:23.982105039 -0500
++++ include/libee/timestamp.h 2011-06-21 14:30:49.970716777 -0500
+@@ -29,6 +29,8 @@
+ #ifndef LIBEE_TIMESTAMP_H_INCLUDED
+ #define LIBEE_TIMESTAMP_H_INCLUDED
+
++#include <time.h>
++
+ /**
+ * An object to represent a CEE/XML timestamp.
+ *
diff --git a/devel/libee/pkg-descr b/devel/libee/pkg-descr
new file mode 100644
index 000000000000..a0d9656d6458
--- /dev/null
+++ b/devel/libee/pkg-descr
@@ -0,0 +1,11 @@
+The core idea of libee is to provide a small but hopefully convenient
+API layer above the CEE standard. However, CEE is not finished. At the
+time of this writing, CEE is under heavy development and even some of
+its core data structures (like the data dictionary and taxonomy) have
+not been fully specified. So for the time being, libee should be
+thought of as a useful library that helps you get your events
+normalized. If you program cleanly to libee, chances are not bad that
+only relatively little effort is required to move your app over to be
+CEE compliant (once the standard is out).
+
+WWW: http://www.libee.org/
diff --git a/devel/libee/pkg-plist b/devel/libee/pkg-plist
new file mode 100644
index 000000000000..c37a8711c478
--- /dev/null
+++ b/devel/libee/pkg-plist
@@ -0,0 +1,29 @@
+@comment $FreeBSD$
+include/libee/apache.h
+include/libee/ctx.h
+include/libee/event.h
+include/libee/field.h
+include/libee/fieldbucket.h
+include/libee/fieldset.h
+include/libee/fieldtype.h
+include/libee/int.h
+include/libee/internal.h
+include/libee/libee.h
+include/libee/namelist.h
+include/libee/obj.h
+include/libee/parser.h
+include/libee/primitivetype.h
+include/libee/tag.h
+include/libee/tagbucket.h
+include/libee/tagset.h
+include/libee/timestamp.h
+include/libee/valnode.h
+include/libee/value.h
+include/libee/valuetype.h
+lib/libee.a
+lib/libee.la
+lib/libee.so
+lib/libee.so.0
+libdata/pkgconfig/libee.pc
+sbin/convert
+@dirrm include/libee