aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-11 17:17:46 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-11 17:17:46 +0000
commitccbf063100dda497552c891ec2c6f2c3e2a7be28 (patch)
tree7b7cb14f7ebcc61a1cc4b02de0969d411923d421
parent251f4ca6f14914170f3b0d23731bb82c39775a4a (diff)
downloadports-ccbf063100dda497552c891ec2c6f2c3e2a7be28.tar.gz
ports-ccbf063100dda497552c891ec2c6f2c3e2a7be28.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=326996
-rw-r--r--security/bruteforceblocker/Makefile9
-rw-r--r--security/munge/Makefile2
-rw-r--r--security/p5-Crypt-Anubis/Makefile9
-rw-r--r--security/p5-Crypt-DES_PP/Makefile7
-rw-r--r--security/p5-Crypt-GCrypt/Makefile3
-rw-r--r--security/p5-Crypt-MySQL/Makefile7
-rw-r--r--security/p5-Crypt-OFB/Makefile9
-rw-r--r--security/p5-Crypt-OTP/Makefile9
-rw-r--r--security/p5-Crypt-Rijndael/Makefile9
-rw-r--r--security/p5-Crypt-UnixCrypt_XS/Makefile3
-rw-r--r--security/p5-Digest-Crc32/Makefile7
-rw-r--r--security/p5-Digest-DMAC/Makefile7
-rw-r--r--security/p5-Digest-EMAC/Makefile7
-rw-r--r--security/p5-Digest-Hashcash/Makefile7
-rw-r--r--security/p5-Digest-Nilsimsa/Makefile9
-rw-r--r--security/p5-File-KeePass-Agent/Makefile3
-rw-r--r--security/p5-dicewaregen/Makefile9
-rw-r--r--security/silktools/Makefile3
-rw-r--r--security/tripwire12/Makefile3
19 files changed, 50 insertions, 72 deletions
diff --git a/security/bruteforceblocker/Makefile b/security/bruteforceblocker/Makefile
index 2b69343c7939..ae79a174e243 100644
--- a/security/bruteforceblocker/Makefile
+++ b/security/bruteforceblocker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bruteforceblocker
-# Date created: 20 April 2005
-# Whom: Daniel Gerzo <danger@rulez.sk>
-#
+# Created by: Daniel Gerzo <danger@rulez.sk>
# $FreeBSD$
-#
PORTNAME= bruteforceblocker
PORTVERSION= 1.2.3
@@ -21,7 +17,8 @@ RUN_DEPENDS= p5-Unix-Syslog>=0:${PORTSDIR}/sysutils/p5-Unix-Syslog \
p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
WRKSRC= ${WRKDIR}/${PORTNAME}
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/security/munge/Makefile b/security/munge/Makefile
index 1c71e57d3815..cbc1b1e7d4e8 100644
--- a/security/munge/Makefile
+++ b/security/munge/Makefile
@@ -12,7 +12,7 @@ COMMENT= Authentication service for creating and validating credentials
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
USE_LDCONFIG= yes
USE_RC_SUBR= munged
diff --git a/security/p5-Crypt-Anubis/Makefile b/security/p5-Crypt-Anubis/Makefile
index f86edfcc712d..3a574156a05e 100644
--- a/security/p5-Crypt-Anubis/Makefile
+++ b/security/p5-Crypt-Anubis/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Crypt-Anubis
-# Date created: 31 Oct 2003
-# Whom: Foxfair Hu <foxfair@FreeBSD.org>
-#
+# Created by: Foxfair Hu <foxfair@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Crypt-Anubis
PORTVERSION= 1.0.4
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Crypt::CBC-compliant block cipher
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Anubis.3
diff --git a/security/p5-Crypt-DES_PP/Makefile b/security/p5-Crypt-DES_PP/Makefile
index a8fbdb52f2c3..40fc92783e36 100644
--- a/security/p5-Crypt-DES_PP/Makefile
+++ b/security/p5-Crypt-DES_PP/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-DES_PP
-# Date created: 20 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-DES_PP
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for DES encryption in pure Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::DES_PP.3
diff --git a/security/p5-Crypt-GCrypt/Makefile b/security/p5-Crypt-GCrypt/Makefile
index 04c250775d2a..6d409c71e902 100644
--- a/security/p5-Crypt-GCrypt/Makefile
+++ b/security/p5-Crypt-GCrypt/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS+= GCRYPTLIBPATH=${LOCALBASE}/lib \
GCRYPTINCPATH=${LOCALBASE}/include
diff --git a/security/p5-Crypt-MySQL/Makefile b/security/p5-Crypt-MySQL/Makefile
index 3bff84488a31..ef117a2598cf 100644
--- a/security/p5-Crypt-MySQL/Makefile
+++ b/security/p5-Crypt-MySQL/Makefile
@@ -1,6 +1,4 @@
-# New ports collection Makefile for: p5-Crypt-MySQL
-# Date created: 17 Dec 2006
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Crypt-MySQL
@@ -14,7 +12,8 @@ COMMENT= Perl extension to compare MySQL passwords without libmysqlclient
RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Crypt::MySQL.3
diff --git a/security/p5-Crypt-OFB/Makefile b/security/p5-Crypt-OFB/Makefile
index 0cfc5efc6444..4193ee3708fd 100644
--- a/security/p5-Crypt-OFB/Makefile
+++ b/security/p5-Crypt-OFB/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Crypt-OFB
-# Date created: Nov 2 2003
-# Whom: clsung
-#
+# Created by: clsung
# $FreeBSD$
-#
PORTNAME= Crypt-OFB
PORTVERSION= 0.01
@@ -17,7 +13,8 @@ COMMENT= Encrypt Data using OFB Mode
BUILD_DEPENDS= p5-Crypt-ECB>=0:${PORTSDIR}/security/p5-Crypt-ECB
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::OFB.3
diff --git a/security/p5-Crypt-OTP/Makefile b/security/p5-Crypt-OTP/Makefile
index 04d697d30f03..74bed889fcc2 100644
--- a/security/p5-Crypt-OTP/Makefile
+++ b/security/p5-Crypt-OTP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Crypt::OTP
-# Date created: 30 Dec 2001
-# Whom: Seamus Venasse <svenasse@polaris.ca>
-#
+# Created by: Seamus Venasse <svenasse@polaris.ca>
# $FreeBSD$
-#
PORTNAME= Crypt-OTP
PORTVERSION= 2.00
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl implementation of the One Time Pad (hence, OTP) encryption method
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::OTP.3
diff --git a/security/p5-Crypt-Rijndael/Makefile b/security/p5-Crypt-Rijndael/Makefile
index 2c50a2a3f990..9c15e7b8f788 100644
--- a/security/p5-Crypt-Rijndael/Makefile
+++ b/security/p5-Crypt-Rijndael/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Crypt-Rijndael
-# Date created: Wed Jan 3 16:15:20 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Crypt-Rijndael
PORTVERSION= 1.11
@@ -17,7 +13,8 @@ COMMENT= Perl module that implements the Rijndael cipher
BUILD_DEPENDS= p5-Test-Manifest>1.14:${PORTSDIR}/devel/p5-Test-Manifest
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::Rijndael.3
diff --git a/security/p5-Crypt-UnixCrypt_XS/Makefile b/security/p5-Crypt-UnixCrypt_XS/Makefile
index e743539fea07..a5de7da1e1f6 100644
--- a/security/p5-Crypt-UnixCrypt_XS/Makefile
+++ b/security/p5-Crypt-UnixCrypt_XS/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= brix@FreeBSD.org
COMMENT= Perl XS interface for a portable traditional crypt function
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE= yes
MAN3= Crypt::UnixCrypt_XS.3
diff --git a/security/p5-Digest-Crc32/Makefile b/security/p5-Digest-Crc32/Makefile
index 34fc5c20e52f..123d3f17fb57 100644
--- a/security/p5-Digest-Crc32/Makefile
+++ b/security/p5-Digest-Crc32/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-Crc32
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-Crc32
@@ -12,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ashish@FreeBSD.org
COMMENT= Perl extension for calculating 32-bit CRC checksums
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Crc32.3
diff --git a/security/p5-Digest-DMAC/Makefile b/security/p5-Digest-DMAC/Makefile
index 580331c86a7e..8a1837e51494 100644
--- a/security/p5-Digest-DMAC/Makefile
+++ b/security/p5-Digest-DMAC/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-DMAC
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-DMAC
@@ -16,7 +14,8 @@ BUILD_DEPENDS= p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::DMAC.3
diff --git a/security/p5-Digest-EMAC/Makefile b/security/p5-Digest-EMAC/Makefile
index ec32b1174955..b8f078aff83c 100644
--- a/security/p5-Digest-EMAC/Makefile
+++ b/security/p5-Digest-EMAC/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-EMAC
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-EMAC
@@ -16,7 +14,8 @@ BUILD_DEPENDS= p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC \
p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::EMAC.3
diff --git a/security/p5-Digest-Hashcash/Makefile b/security/p5-Digest-Hashcash/Makefile
index 823062815fa9..17343fb37c90 100644
--- a/security/p5-Digest-Hashcash/Makefile
+++ b/security/p5-Digest-Hashcash/Makefile
@@ -1,6 +1,4 @@
-# Ports collection Makefile for: p5-Digest-Hashcash
-# Date created: 17 Dec 2005
-# Whom: Gabor Kovesdan
+# Created by: Gabor Kovesdan
# $FreeBSD$
PORTNAME= Digest-Hashcash
@@ -14,7 +12,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl extension for Hashcash hash algorithm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Hashcash.3
diff --git a/security/p5-Digest-Nilsimsa/Makefile b/security/p5-Digest-Nilsimsa/Makefile
index c28e5ad07c78..5371f67ebab6 100644
--- a/security/p5-Digest-Nilsimsa/Makefile
+++ b/security/p5-Digest-Nilsimsa/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Digest-Nilsimsa
-# Date created: 13 August 2002
-# Whom: Yen-Ming Lee <leeym@leeym.com>
-#
+# Created by: Yen-Ming Lee <leeym@leeym.com>
# $FreeBSD$
-#
PORTNAME= Digest-Nilsimsa
PORTVERSION= 0.06
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= leeym@FreeBSD.org
COMMENT= Perl version of Nilsimsa code
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Digest::Nilsimsa.3
diff --git a/security/p5-File-KeePass-Agent/Makefile b/security/p5-File-KeePass-Agent/Makefile
index 9604266a48b2..f4f6f26c53c7 100644
--- a/security/p5-File-KeePass-Agent/Makefile
+++ b/security/p5-File-KeePass-Agent/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-File-KeePass>=2.03:${PORTSDIR}/security/p5-File-KeePass \
p5-MIME-Base64>=1.0:${PORTSDIR}/converters/p5-MIME-Base64
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= fkp-agent.1
MAN3= File::KeePass::Agent.3 \
diff --git a/security/p5-dicewaregen/Makefile b/security/p5-dicewaregen/Makefile
index 2a27acb0a6e0..56459fb99041 100644
--- a/security/p5-dicewaregen/Makefile
+++ b/security/p5-dicewaregen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-dicewaregen
-# Date created: 2011.05.22
-# Whom: Aldis Berjoza <aldis@bsdroot.lv>
-#
+# Created by: Aldis Berjoza <aldis@bsdroot.lv>
# $FreeBSD$
-#
PORTNAME= dicewaregen
PORTVERSION= 1.3
@@ -16,7 +12,8 @@ COMMENT= A simple perl script to generate Diceware dictionaries for passwords
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
PLIST_FILES= bin/${PORTNAME}
diff --git a/security/silktools/Makefile b/security/silktools/Makefile
index ed673f97d716..8069296504c7 100644
--- a/security/silktools/Makefile
+++ b/security/silktools/Makefile
@@ -20,7 +20,8 @@ USE_PYTHON= yes
USE_GMAKE= yes
MAKE_ARGS= CC="${CC}" GCC_FLAGS="" CFLAGS_RELEASE=""
USE_LDCONFIG= yes
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
MAN1= mapsid.1 num2dot.1 rwaddrcount.1 rwappend.1 \
rwbag.1 rwbagbuild.1 rwbagcat.1 rwbagtool.1 \
diff --git a/security/tripwire12/Makefile b/security/tripwire12/Makefile
index e192fe409844..67d4c18b0313 100644
--- a/security/tripwire12/Makefile
+++ b/security/tripwire12/Makefile
@@ -15,7 +15,8 @@ MAN5= tw.config.5
MAN8= siggen.8 tripwire.8
NO_CDROM= cannot be redistributed for more than the cost of duplication
NO_PACKAGE= requires local database to be built
-USE_PERL5_BUILD=yes
+USES= perl5
+USE_PERL5= build
TWCONFIG?= ${FILESDIR}/tw.conf.freebsd8