aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2007-11-26 17:45:55 +0000
committerAde Lovett <ade@FreeBSD.org>2007-11-26 17:45:55 +0000
commitccd0fca5ecd3b7a022136828951a9543e831e4c7 (patch)
tree23a432c7392200a0485824ed28d7f75e63b88721
parentd74e33cf2d0f37372b75a4f61eaca7cb76b5ad3e (diff)
downloadports-ccd0fca5ecd3b7a022136828951a9543e831e4c7.tar.gz
ports-ccd0fca5ecd3b7a022136828951a9543e831e4c7.zip
Notes
-rw-r--r--databases/virtuoso/Makefile4
-rw-r--r--databases/virtuoso/files/patch-libsrc-Thread-thread_int.h6
-rw-r--r--security/clamav/Makefile7
-rw-r--r--security/squidclam/Makefile9
-rw-r--r--www/havp/Makefile8
-rw-r--r--x11-drivers/xf86-video-openchrome/Makefile8
-rw-r--r--x11-drivers/xf86-video-openchrome/files/patch-libxvmc_viaXvMCPriv.h6
7 files changed, 17 insertions, 31 deletions
diff --git a/databases/virtuoso/Makefile b/databases/virtuoso/Makefile
index dc08cfe28205..2e4e9e2edb45 100644
--- a/databases/virtuoso/Makefile
+++ b/databases/virtuoso/Makefile
@@ -62,10 +62,6 @@ BUILD_DEPENDS+= ${NETCAT}:${PORTSDIR}/net/netcat
CHECK_PORT= /usr/bin/nc -z localhost $$\1
.endif
-.if ${OSVERSION} < 600000
-BROKEN= Fails to compile: does not find pthread include file
-.endif
-
.if defined(WITH_IMAGEMAGICK)
CONFIGURE_ARGS+=--enable-imagemagick=${LOCALBASE}
LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
diff --git a/databases/virtuoso/files/patch-libsrc-Thread-thread_int.h b/databases/virtuoso/files/patch-libsrc-Thread-thread_int.h
new file mode 100644
index 000000000000..a6125468b640
--- /dev/null
+++ b/databases/virtuoso/files/patch-libsrc-Thread-thread_int.h
@@ -0,0 +1,6 @@
+--- libsrc/Thread/thread_int.h.orig Mon Jan 22 06:28:12 2007
++++ libsrc/Thread/thread_int.h Sun Nov 25 10:31:20 2007
+@@ -36,2 +36,3 @@
+ #include <assert.h>
++#include <pthread.h> /* For FreeBSD 5.x */
+ #define _THREAD_INT_HS
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index e78e3fdba8ac..19e71119c304 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.91.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
@@ -105,12 +106,6 @@ CONFIGURE_ARGS+= --enable-gethostbyname_r
.if ${OSVERSION} >= 601000
PTHREAD_LIBS= -lthr
.endif
-# Maybe the port is broken for
-# FreeBSD 5.2.1 since -lc_r
-# and -pthread have both issues there.
-.if ${OSVERSION} == 502010
-PTHREAD_LIBS= -pthread
-.endif
.if !defined(WITHOUT_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
diff --git a/security/squidclam/Makefile b/security/squidclam/Makefile
index 54362535f83f..9fa9e4806ea0 100644
--- a/security/squidclam/Makefile
+++ b/security/squidclam/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_GMAKE= yes
NO_INSTALL_MANPAGES= yes
+CFLAGS+= ${PTHREAD_LIBS}
PORTDOCS= README Changelog
@@ -30,12 +31,6 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/squidclam %%EXAMPLESDIR%%/squidclam.conf
PLIST_DIRS= %%EXAMPLESDIR%%
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Fails to compile: does not find pthread include file
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
@@ -57,4 +52,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/havp/Makefile b/www/havp/Makefile
index fbe9b87519ac..7de64d1da123 100644
--- a/www/havp/Makefile
+++ b/www/havp/Makefile
@@ -35,12 +35,6 @@ OPTIONS= SSL "Enable SSL proxying (not scanned, only forwarded!)" on \
CLAMAV "Enable libclamav support" on \
TROPHIE "Enable Trend Micro (Trophie) support" off
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Fails to compile: does not find pthread include file
-.endif
-
.if defined(WITH_SSL)
CONFIGURE_ARGS+= --enable-ssl-tunnel
.else
@@ -71,4 +65,4 @@ post-install:
@${CP} ${WRKSRC}/etc/havp/whitelist ${EXAMPLESDIR}/whitelist.sample
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-openchrome/Makefile b/x11-drivers/xf86-video-openchrome/Makefile
index 8ef1027992c3..2e4e98c131e6 100644
--- a/x11-drivers/xf86-video-openchrome/Makefile
+++ b/x11-drivers/xf86-video-openchrome/Makefile
@@ -30,10 +30,4 @@ MAN4= via.4x
pre-configure:
@(cd ${WRKSRC} && ${SH} ./autogen.sh)
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 600000
-BROKEN= Fails to compile: does not find pthread include file
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-openchrome/files/patch-libxvmc_viaXvMCPriv.h b/x11-drivers/xf86-video-openchrome/files/patch-libxvmc_viaXvMCPriv.h
new file mode 100644
index 000000000000..2af32071aa66
--- /dev/null
+++ b/x11-drivers/xf86-video-openchrome/files/patch-libxvmc_viaXvMCPriv.h
@@ -0,0 +1,6 @@
+--- libxvmc/viaXvMCPriv.h.orig Wed Jan 25 15:56:20 2006
++++ libxvmc/viaXvMCPriv.h Sun Nov 25 09:43:03 2007
+@@ -31,2 +31,3 @@
+ #include <stdlib.h>
++#include <pthread.h> /* For FreeBSD 5.x */
+ #include <X11/Xutil.h>