aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-01-06 18:03:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-01-06 18:03:51 +0000
commitccd24e24ed1093d42a46f8dd57ca3e514297339f (patch)
tree830876558d8b075d9b06868e5d12297133df2c23
parent922f268a16a1b0b822c4e5e5a57631f842bb0e5e (diff)
downloadports-ccd24e24ed1093d42a46f8dd57ca3e514297339f.tar.gz
ports-ccd24e24ed1093d42a46f8dd57ca3e514297339f.zip
Notes
-rw-r--r--mail/roundcube-air/Makefile10
-rw-r--r--mail/roundcube-groupvice/Makefile10
-rw-r--r--mail/roundcube-mobilecube/Makefile9
-rw-r--r--mail/roundcube-mvision2/Makefile10
-rw-r--r--mail/roundcube-umich/Makefile10
5 files changed, 5 insertions, 44 deletions
diff --git a/mail/roundcube-air/Makefile b/mail/roundcube-air/Makefile
index 68182e35db25..9f0ceea790ac 100644
--- a/mail/roundcube-air/Makefile
+++ b/mail/roundcube-air/Makefile
@@ -13,18 +13,10 @@ COMMENT= Theme for RoundCube Web Mail
RUN_DEPENDS= roundcube>=0.3:${PORTSDIR}/mail/roundcube
NO_BUILD= yes
+NO_ARCH= yes
WWWDIR?= ${PREFIX}/www/roundcube/skins/air
-# This target is only meant to be used by the port maintainer.
-x-generate-plist: build
- cd ${WRKSRC}; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
-
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
diff --git a/mail/roundcube-groupvice/Makefile b/mail/roundcube-groupvice/Makefile
index 338ba3e8bf06..d92760d80ea5 100644
--- a/mail/roundcube-groupvice/Makefile
+++ b/mail/roundcube-groupvice/Makefile
@@ -13,20 +13,12 @@ COMMENT= Theme for RoundCube Web Mail
RUN_DEPENDS= roundcube>=0.2:${PORTSDIR}/mail/roundcube
NO_BUILD= yes
+NO_ARCH= yes
WWWDIR?= ${PREFIX}/www/roundcube/skins/groupvice
SUB_FILES= pkg-message
-# This target is only meant to be used by the port maintainer.
-x-generate-plist: build
- cd ${WRKSRC}; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
-
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
cd ${WRKSRC} && ${PAX} -r -w . ${STAGEDIR}${WWWDIR}
diff --git a/mail/roundcube-mobilecube/Makefile b/mail/roundcube-mobilecube/Makefile
index 8cf2154b316f..b9802bd17235 100644
--- a/mail/roundcube-mobilecube/Makefile
+++ b/mail/roundcube-mobilecube/Makefile
@@ -18,18 +18,11 @@ THEME_BUILD?= 030110A
USES= zip
NO_BUILD= yes
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/MobileCubeBeta\#${THEME_BUILD}
WWWDIR?= ${PREFIX}/www/roundcube/skins/MobileCube
-# This target is only meant to be used by the port maintainer.
-x-generate-plist: build
- cd ${WRKSRC}/MobileCube; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
post-patch:
${FIND} ${WRKSRC} -type f -name '*.orig' -or -name '.DS_Store' -delete
diff --git a/mail/roundcube-mvision2/Makefile b/mail/roundcube-mvision2/Makefile
index dfd4ee18acf5..7a9327abaf5a 100644
--- a/mail/roundcube-mvision2/Makefile
+++ b/mail/roundcube-mvision2/Makefile
@@ -15,20 +15,12 @@ COMMENT= Theme for RoundCube Web Mail
RUN_DEPENDS= roundcube>=0.2:${PORTSDIR}/mail/roundcube
NO_BUILD= yes
+NO_ARCH= yes
WWWDIR?= ${PREFIX}/www/roundcube/skins/mvision2_en
SUB_FILES= pkg-message
-# This target is only meant to be used by the port maintainer.
-x-generate-plist: build
- cd ${WRKDIR}/mvision2_en; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
-
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
cd ${WRKDIR}/mvision2_en && ${PAX} -r -w . \
diff --git a/mail/roundcube-umich/Makefile b/mail/roundcube-umich/Makefile
index 9fac89364f95..a197355c4182 100644
--- a/mail/roundcube-umich/Makefile
+++ b/mail/roundcube-umich/Makefile
@@ -13,18 +13,10 @@ COMMENT= Theme for RoundCube Web Mail
RUN_DEPENDS= roundcube>=0.2:${PORTSDIR}/mail/roundcube
NO_BUILD= yes
+NO_ARCH= yes
WWWDIR?= ${PREFIX}/www/roundcube/skins/umich
-# This target is only meant to be used by the port maintainer.
-x-generate-plist: build
- cd ${WRKSRC}; \
- ${FIND} . ! -type d ! -name '*.orig' | ${SORT} | \
- ${SED} -e "s,^\.,%%WWWDIR%%," >${.CURDIR}/pkg-plist.tmp ; \
- ${FIND} . -type d | ${SORT} -r | ${SED} \
- -e "s,^\.$$,@dirrmtry %%WWWDIR%%," \
- -e "s,^\.,@dirrm %%WWWDIR%%," >>${.CURDIR}/pkg-plist.tmp
-
post-patch:
${FIND} ${WRKSRC} -type f -name '*.orig' -delete