aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-10-02 04:12:31 +0000
committerCy Schubert <cy@FreeBSD.org>2011-10-02 04:12:31 +0000
commitcce96262c13abb3f2311dc14f5a550205c3ac51f (patch)
treeea5a27f3cec9dcd5538677d2f4f8602f766c6ded
parentb69b152883905dd598e848e8db053123b8800a22 (diff)
downloadports-cce96262c13abb3f2311dc14f5a550205c3ac51f.tar.gz
ports-cce96262c13abb3f2311dc14f5a550205c3ac51f.zip
Notes
-rw-r--r--sysutils/syslog-ng3/Makefile138
-rw-r--r--sysutils/syslog-ng3/distinfo2
-rw-r--r--sysutils/syslog-ng3/files/patch-scl-Makefile.in11
-rw-r--r--sysutils/syslog-ng3/files/pkg-message.in29
-rw-r--r--sysutils/syslog-ng3/files/syslog-ng.conf.sample183
-rw-r--r--sysutils/syslog-ng3/files/syslog-ng.sh.in46
-rw-r--r--sysutils/syslog-ng3/pkg-descr10
-rw-r--r--sysutils/syslog-ng3/pkg-plist62
8 files changed, 0 insertions, 481 deletions
diff --git a/sysutils/syslog-ng3/Makefile b/sysutils/syslog-ng3/Makefile
deleted file mode 100644
index 094889c6703a..000000000000
--- a/sysutils/syslog-ng3/Makefile
+++ /dev/null
@@ -1,138 +0,0 @@
-# New ports collection makefile for: syslog-ng
-# Date created: 10 november 1006
-# Whom: Ivan Lago <ivan.lago@ifom-ieo-campus.it>
-#
-# $FreeBSD$
-#
-
-PORTNAME= syslog-ng
-PORTVERSION= 3.2.4
-CATEGORIES= sysutils
-MASTER_SITES= http://www.balabit.com/downloads/files/syslog-ng/sources/$(PORTVERSION)/source/
-PKGNAMESUFFIX= 3
-DISTFILES= $(PORTNAME)_$(PORTVERSION).tar.gz
-
-MAINTAINER= cy@FreeBSD.org
-COMMENT= A powerful syslogd replacement
-
-CONFLICTS?= syslog-ng-[0-9]* syslog-ng[0124-9]-[0-9]* \
- syslog-ng[0-9]-devel-[0-9]*
-
-OPTIONS= SYS_SSL "Build with OpenSSL support (from system)" off \
- PORTS_SSL "Build with OpenSSL support (from ports)" off \
- TCP_WRAPPERS "Build with TCP Wrappers" off \
- SQL "Build with database (libdbi) support" off \
- SPOOF "Build with spoof source support" off \
- IPV6 "Build with IPV6 support" on \
- PCRE "Build with PCRE support" on
-
-.include <bsd.port.options.mk>
-
-LIB_DEPENDS= evtlog.0:${PORTSDIR}/sysutils/eventlog
-
-MAN1= loggen.1 pdbtool.1 syslog-ng-ctl.1
-MAN5= syslog-ng.conf.5
-MAN8= syslog-ng.8
-
-USE_RC_SUBR= syslog-ng.sh
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-USE_GNOME= glib20
-SUB_FILES= pkg-message
-
-CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
- --enable-dynamic-linking --with-libnet=${LOCALBASE}/bin
-CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
-LDFLAGS+= `${LIBNET_CONFIG} --libs`
-
-.if defined(WITH_SYS_SSL) && defined(WITH_PORTS_SSL)
-BROKEN= SYS_SSL and PORTS_SSL are mutually exclusive
-.endif
-
-.if defined(WITH_SYS_SSL) || defined(WITH_PORTS_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --enable-ssl
-CONFIGURE_ENV+= OPENSSL_CFLAGS="${OPENSSL_CFLAGS}" \
- OPENSSL_LIBS="${OPENSSL_LDFLAGS} -lcrypto -lssl"
-PLIST_FILES+= lib/syslog-ng/libafsocket-tls.la lib/syslog-ng/libafsocket-tls.so
-.else
-CONFIGURE_ARGS+= --disable-ssl
-.endif
-
-.if defined(WITH_PORTS_SSL)
-WITH_OPENSSL_PORT= yes
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_TCP_WRAPPERS)
-CONFIGURE_ARGS+= --enable-tcp-wrapper
-.else
-CONFIGURE_ARGS+= --disable-tcp-wrapper
-.endif
-
-.if defined(WITH_SPOOF)
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet-devel
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet115-config
-CONFIGURE_ARGS+= --enable-spoof-source
-.else
-CONFIGURE_ARGS+= --disable-spoof-source
-.endif
-
-.if defined(WITH_IPV6)
-CONFIGURE_ARGS+= --enable-ipv6
-.else
-CONFIGURE_ARGS+= --disable-ipv6
-.endif
-
-.if defined(WITH_PCRE)
-CONFIGURE_ARGS+= --enable-pcre
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-.else
-CONFIGURE_ARGS+= --disable-pcre
-.endif
-
-.if defined(WITH_SQL)
-LIB_DEPENDS+= dbi.1:${PORTSDIR}/databases/libdbi
-CONFIGURE_ENV+= LIBDBI_LIBS="-ldbi"
-CONFIGURE_ARGS+= --enable-sql
-PLIST_FILES+= lib/syslog-ng/libafsql.la lib/syslog-ng/libafsql.so
-.else
-CONFIGURE_ARGS+= --disable-sql
-.endif
-
-.if ${OSVERSION} >= 900034
-CONFIGURE_ARGS+= --disable-linux-caps
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's:libnet-config:libnet115-config:g' ${WRKSRC}/configure
- @${LN} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.dist
-.if ${OSVERSION} >= 900007
- @${REINPLACE_CMD} \
- -e 's|utmp|utmpx|' -e 's|getutent|getutxent|' \
- -e 's|ut_name|ut_user|' \
- ${WRKSRC}/configure ${WRKSRC}/modules/afuser/afuser.c \
- ${WRKSRC}/lib/utils.c ${WRKSRC}/lib/utils.h
-.endif
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} \
- ${PREFIX}/share/doc/syslog-ng \
- ${PREFIX}/share/doc/syslog-ng/sgml
- ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${PREFIX}/share/doc/syslog-ng
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/syslog-ng
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/syslog-ng
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/syslog-ng
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/syslog-ng
-.endif
- @if [ ! -f ${PREFIX}/etc/syslog-ng.conf.sample ]; then \
- ${INSTALL_DATA} ${FILESDIR}/syslog-ng.conf.sample ${PREFIX}/etc; \
- fi
- @if [ ! -f ${PREFIX}/etc/syslog-ng.conf ]; then \
- ${CP} ${PREFIX}/etc/syslog-ng.conf.sample ${PREFIX}/etc/syslog-ng.conf; \
- fi
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/sysutils/syslog-ng3/distinfo b/sysutils/syslog-ng3/distinfo
deleted file mode 100644
index 7da063ca32a6..000000000000
--- a/sysutils/syslog-ng3/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (syslog-ng_3.2.4.tar.gz) = e7bbd53121b57ba49089a0f95bf10a393e62b27a575c83d08e668c9dc1fe2f15
-SIZE (syslog-ng_3.2.4.tar.gz) = 1435115
diff --git a/sysutils/syslog-ng3/files/patch-scl-Makefile.in b/sysutils/syslog-ng3/files/patch-scl-Makefile.in
deleted file mode 100644
index 567af03179e4..000000000000
--- a/sysutils/syslog-ng3/files/patch-scl-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- scl/Makefile.in.orig 2011-01-15 08:15:10.000000000 -0800
-+++ scl/Makefile.in 2011-01-20 21:16:20.000000000 -0800
-@@ -200,7 +200,7 @@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- SCL_SUBDIRS = system pacct syslogconf
--SCL_CONFIGS = scl.conf modules.conf syslog-ng.conf
-+SCL_CONFIGS = scl.conf modules.conf syslog-ng.conf.dist
- EXTRA_DIST = $(SCL_CONFIGS) $(SCL_SUBDIRS)
- scldir = $(datadir)/include/scl
- all: all-am
diff --git a/sysutils/syslog-ng3/files/pkg-message.in b/sysutils/syslog-ng3/files/pkg-message.in
deleted file mode 100644
index 2b5582660897..000000000000
--- a/sysutils/syslog-ng3/files/pkg-message.in
+++ /dev/null
@@ -1,29 +0,0 @@
-
-syslog-ng is now installed! To replace FreeBSD's standard syslogd
-(/usr/sbin/syslogd), complete these steps:
-
-1. Create a configuration file named %%PREFIX%%/etc/syslog-ng.conf
- (a sample named syslog-ng.conf.sample has been included in
- %%PREFIX%%/etc). Note that this is a change in 2.0.2
- version, previous ones put the config file in
- %%PREFIX%%/etc/syslog-ng/syslog-ng.conf, so if this is an update
- move that file in the right place
-
-2. Configure syslog-ng to start automatically by adding the following
- to /etc/rc.conf:
-
- syslog_ng_enable="YES"
-
-3. Prevent the standard FreeBSD syslogd from starting automatically by
- adding a line to the end of your /etc/rc.conf file that reads:
-
- syslogd_enable="NO"
-
-4. Shut down the standard FreeBSD syslogd:
-
- kill `cat /var/run/syslog.pid`
-
-5. Start syslog-ng:
-
- %%PREFIX%%/etc/rc.d/syslog-ng start
-
diff --git a/sysutils/syslog-ng3/files/syslog-ng.conf.sample b/sysutils/syslog-ng3/files/syslog-ng.conf.sample
deleted file mode 100644
index a58743dad624..000000000000
--- a/sysutils/syslog-ng3/files/syslog-ng.conf.sample
+++ /dev/null
@@ -1,183 +0,0 @@
-@version:3.2
-
-#
-# This sample configuration file is essentially equilivent to the stock
-# FreeBSD /etc/syslog.conf file.
-#
-
-#
-# options
-#
-options { long_hostnames(off); flush_lines(0); };
-
-#
-# sources
-#
-source src { unix-dgram("/var/run/log");
- unix-dgram("/var/run/logpriv" perm(0600));
- udp(); internal(); file("/dev/klog"); };
-
-#
-# destinations
-#
-destination messages { file("/var/log/messages"); };
-destination security { file("/var/log/security"); };
-destination authlog { file("/var/log/auth.log"); };
-destination maillog { file("/var/log/maillog"); };
-destination lpd-errs { file("/var/log/lpd-errs"); };
-destination xferlog { file("/var/log/xferlog"); };
-destination cron { file("/var/log/cron"); };
-destination debuglog { file("/var/log/debug.log"); };
-destination consolelog { file("/var/log/console.log"); };
-destination all { file("/var/log/all.log"); };
-destination newscrit { file("/var/log/news/news.crit"); };
-destination newserr { file("/var/log/news/news.err"); };
-destination newsnotice { file("/var/log/news/news.notice"); };
-destination slip { file("/var/log/slip.log"); };
-destination ppp { file("/var/log/ppp.log"); };
-destination console { file("/dev/console"); };
-destination allusers { usertty("*"); };
-#destination loghost { udp("loghost" port(514)); };
-
-#
-# log facility filters
-#
-filter f_auth { facility(auth); };
-filter f_authpriv { facility(authpriv); };
-filter f_not_authpriv { not facility(authpriv); };
-#filter f_console { facility(console); };
-filter f_cron { facility(cron); };
-filter f_daemon { facility(daemon); };
-filter f_ftp { facility(ftp); };
-filter f_kern { facility(kern); };
-filter f_lpr { facility(lpr); };
-filter f_mail { facility(mail); };
-filter f_news { facility(news); };
-filter f_security { facility(security); };
-filter f_user { facility(user); };
-filter f_uucp { facility(uucp); };
-filter f_local0 { facility(local0); };
-filter f_local1 { facility(local1); };
-filter f_local2 { facility(local2); };
-filter f_local3 { facility(local3); };
-filter f_local4 { facility(local4); };
-filter f_local5 { facility(local5); };
-filter f_local6 { facility(local6); };
-filter f_local7 { facility(local7); };
-
-#
-# log level filters
-#
-filter f_emerg { level(emerg); };
-filter f_alert { level(alert..emerg); };
-filter f_crit { level(crit..emerg); };
-filter f_err { level(err..emerg); };
-filter f_warning { level(warning..emerg); };
-filter f_notice { level(notice..emerg); };
-filter f_info { level(info..emerg); };
-filter f_debug { level(debug..emerg); };
-filter f_is_debug { level(debug); };
-
-#
-# program filters
-#
-filter f_ppp { program("ppp"); };
-filter f_slip { program("startslip"); };
-
-#
-# *.err;kern.warning;auth.notice;mail.crit /dev/console
-#
-log { source(src); filter(f_err); destination(console); };
-log { source(src); filter(f_kern); filter(f_warning); destination(console); };
-log { source(src); filter(f_auth); filter(f_notice); destination(console); };
-log { source(src); filter(f_mail); filter(f_crit); destination(console); };
-
-#
-# *.notice;authpriv.none;kern.debug;lpr.info;mail.crit;news.err /var/log/messages
-#
-log { source(src); filter(f_notice); filter(f_not_authpriv); destination(messages); };
-log { source(src); filter(f_kern); filter(f_debug); destination(messages); };
-log { source(src); filter(f_lpr); filter(f_info); destination(messages); };
-log { source(src); filter(f_mail); filter(f_crit); destination(messages); };
-log { source(src); filter(f_news); filter(f_err); destination(messages); };
-
-#
-# security.* /var/log/security
-#
-log { source(src); filter(f_security); destination(security); };
-
-#
-# auth.info;authpriv.info /var/log/auth.log
-log { source(src); filter(f_auth); filter(f_info); destination(authlog); };
-log { source(src); filter(f_authpriv); filter(f_info); destination(authlog); };
-
-#
-# mail.info /var/log/maillog
-#
-log { source(src); filter(f_mail); filter(f_info); destination(maillog); };
-
-#
-# lpr.info /var/log/lpd-errs
-#
-log { source(src); filter(f_lpr); filter(f_info); destination(lpd-errs); };
-
-#
-# ftp.info /var/log/xferlog
-#
-log { source(src); filter(f_ftp); filter(f_info); destination(xferlog); };
-
-#
-# cron.* /var/log/cron
-#
-log { source(src); filter(f_cron); destination(cron); };
-
-#
-# *.=debug /var/log/debug.log
-#
-log { source(src); filter(f_is_debug); destination(debuglog); };
-
-#
-# *.emerg *
-#
-log { source(src); filter(f_emerg); destination(allusers); };
-
-#
-# uncomment this to log all writes to /dev/console to /var/log/console.log
-# console.info /var/log/console.log
-#
-#log { source(src); filter(f_console); filter(f_info); destination(consolelog); };
-
-#
-# uncomment this to enable logging of all log messages to /var/log/all.log
-# touch /var/log/all.log and chmod it to mode 600 before it will work
-# *.* /var/log/all.log
-#
-#log { source(src); destination(all); };
-
-#
-# uncomment this to enable logging to a remote loghost named loghost
-# *.* @loghost
-#
-#log { source(src); destination(loghost); };
-
-#
-# uncomment these if you're running inn
-# news.crit /var/log/news/news.crit
-# news.err /var/log/news/news.err
-# news.notice /var/log/news/news.notice
-#
-#log { source(src); filter(f_news); filter(f_crit); destination(newscrit); };
-#log { source(src); filter(f_news); filter(f_err); destination(newserr); };
-#log { source(src); filter(f_news); filter(f_notice); destination(newsnotice); };
-
-#
-# !startslip
-# *.* /var/log/slip.log
-#
-log { source(src); filter(f_slip); destination(slip); };
-
-#
-# !ppp
-# *.* /var/log/ppp.log
-#
-log { source(src); filter(f_ppp); destination(ppp); };
diff --git a/sysutils/syslog-ng3/files/syslog-ng.sh.in b/sysutils/syslog-ng3/files/syslog-ng.sh.in
deleted file mode 100644
index 59426164bed7..000000000000
--- a/sysutils/syslog-ng3/files/syslog-ng.sh.in
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD: /tmp/pcvs/ports/sysutils/syslog-ng3/files/Attic/syslog-ng.sh.in,v 1.6 2010-03-27 00:15:06 dougb Exp $
-#
-
-# PROVIDE: syslogd
-# REQUIRE: mountcritremote cleanvar ldconfig
-# BEFORE: SERVERS
-
-#
-# Add the following line to /etc/rc.conf.local or /etc/rc.conf
-# to enable this service:
-#
-#syslog_ng_enable="YES"
-#syslog_ng_config="-u daemon"
-#syslog_ng_pid="/var/run/syslog-ng.pid"
-#
-
-syslog_ng_purgeklog=${syslog_ng_purgeklog-"NO"}
-
-. /etc/rc.subr
-
-name=syslog_ng
-rcvar=`set_rcvar`
-
-command=%%PREFIX%%/sbin/syslog-ng
-required_files=%%PREFIX%%/etc/syslog-ng.conf
-extra_commands=reload
-
-if checkyesno syslog_ng_purgeklog; then
- start_precmd="echo \"Purging klog(9)\" && sysctl -w kern.msgbuf_clear=1 $start_precmd";
-fi
-
-stop_postcmd=stop_postcmd
-
-load_rc_config $name
-
-: ${syslog_ng_enable:="NO"}
-pidfile=${syslog_ng_pid:-"/var/run/syslog.pid"}
-command_args="-p ${pidfile} ${syslog_ng_config}"
-
-stop_postcmd() {
- rm -f $pidfile
-}
-
-run_rc_command "$1"
diff --git a/sysutils/syslog-ng3/pkg-descr b/sysutils/syslog-ng3/pkg-descr
deleted file mode 100644
index 7ad66383cffc..000000000000
--- a/sysutils/syslog-ng3/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-syslog-ng3 (Syslog New Generation) is a powerful replacement for the standard
-syslogd. Features include:
-
- - ability to filter messages based on content using regular expressions
- - forwarding logs on TCP
-
-WWW: http://www.balabit.com/products/syslog_ng/
-
--Vince Valenti
-vince@blue-box.net
diff --git a/sysutils/syslog-ng3/pkg-plist b/sysutils/syslog-ng3/pkg-plist
deleted file mode 100644
index 09704c5898ae..000000000000
--- a/sysutils/syslog-ng3/pkg-plist
+++ /dev/null
@@ -1,62 +0,0 @@
-@unexec %D/etc/rc.d/syslog-ng.sh stop > /dev/null 2>&1 || true
-etc/modules.conf
-etc/scl.conf
-@exec test -f %D/etc/syslog-ng.conf || cp -p %D/etc/syslog-ng.conf.sample %D/etc/syslog-ng.conf
-@unexec if cmp -s %D/etc/syslog-ng.conf %D/etc/syslog-ng.conf.sample; then rm -f %D/etc/syslog-ng.conf; fi
-etc/syslog-ng.conf.dist
-etc/syslog-ng.conf.sample
-bin/update-patterndb
-bin/loggen
-bin/pdbtool
-lib/libsyslog-ng.la
-lib/libsyslog-ng.so
-lib/libsyslog-ng.so.0
-lib/syslog-ng/libaffile.la
-lib/syslog-ng/libaffile.so
-lib/syslog-ng/libafprog.la
-lib/syslog-ng/libafprog.so
-lib/syslog-ng/libafsocket.so
-lib/syslog-ng/libafsocket-notls.la
-lib/syslog-ng/libafsocket-notls.so
-lib/syslog-ng/libafuser.la
-lib/syslog-ng/libafuser.so
-lib/syslog-ng/libbasicfuncs.la
-lib/syslog-ng/libbasicfuncs.so
-lib/syslog-ng/libconfgen.la
-lib/syslog-ng/libconfgen.so
-lib/syslog-ng/libconvertfuncs.la
-lib/syslog-ng/libconvertfuncs.so
-lib/syslog-ng/libcsvparser.la
-lib/syslog-ng/libcsvparser.so
-lib/syslog-ng/libdbparser.la
-lib/syslog-ng/libdbparser.so
-lib/syslog-ng/libdummy.la
-lib/syslog-ng/libdummy.so
-lib/syslog-ng/libsyslogformat.la
-lib/syslog-ng/libsyslogformat.so
-sbin/syslog-ng
-sbin/syslog-ng-ctl
-share/include/scl/pacct/plugin.conf
-share/include/scl/syslogconf/README
-share/include/scl/syslogconf/convert-syslogconf.awk
-share/include/scl/syslogconf/plugin.conf
-share/include/scl/system/generate-system-source.sh
-share/include/scl/system/plugin.conf
-share/xsd/patterndb-1.xsd
-share/xsd/patterndb-2.xsd
-share/xsd/patterndb-3.xsd
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sgml
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/xsd
-@dirrm share/include/scl/system
-@dirrm share/include/scl/syslogconf
-@dirrm share/include/scl/pacct
-@dirrm share/include/scl
-@dirrm share/include
-@dirrm lib/syslog-ng
-@dirrm etc/patterndb.d