aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-11-30 21:48:47 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-11-30 21:48:47 +0000
commitcd4b04ac42ce09662960453ff82e63a8237fbe4a (patch)
tree8f39d8d71918d84fa526fbdc0023c41a32d4524c
parenta82de362b0bdd036d5d2c9bbb29970808ee3252d (diff)
downloadports-cd4b04ac42ce09662960453ff82e63a8237fbe4a.tar.gz
ports-cd4b04ac42ce09662960453ff82e63a8237fbe4a.zip
Notes
-rw-r--r--x11/xfce4-dashboard/Makefile4
-rw-r--r--x11/xfce4-dashboard/distinfo6
-rw-r--r--x11/xfce4-dashboard/files/patch-libxfdashboard_application-database.c20
-rw-r--r--x11/xfce4-dashboard/files/patch-libxfdashboard_applications-menu-model.c11
-rw-r--r--x11/xfce4-dashboard/files/patch-settings_general.c19
-rw-r--r--x11/xfce4-dashboard/pkg-plist5
6 files changed, 29 insertions, 36 deletions
diff --git a/x11/xfce4-dashboard/Makefile b/x11/xfce4-dashboard/Makefile
index 37d9d929adb2..9ccb5ba77ec3 100644
--- a/x11/xfce4-dashboard/Makefile
+++ b/x11/xfce4-dashboard/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dashboard
-PORTVERSION= 0.7.5
+PORTVERSION= 0.7.6
CATEGORIES= x11 xfce
MASTER_SITES= XFCE/apps
PKGNAMEPREFIX= xfce4-
@@ -42,5 +42,7 @@ post-patch:
# default value
${FIND} ${WRKSRC}/data/themes -type f -name 'effects.xml' \
| ${XARGS} ${REINPLACE_CMD} -i "" 's|factor">1.0|factor">0.25|'
+ ${FIND} ${WRKSRC}/data/themes -type f -name '*.theme.in.in' \
+ | ${XARGS} ${REINPLACE_CMD} -e '/Animations=animations.xml/d'
.include <bsd.port.mk>
diff --git a/x11/xfce4-dashboard/distinfo b/x11/xfce4-dashboard/distinfo
index 4c505f597112..b63506d4636f 100644
--- a/x11/xfce4-dashboard/distinfo
+++ b/x11/xfce4-dashboard/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1565615330
-SHA256 (xfce4/xfdashboard-0.7.5.tar.bz2) = 4c673be445c08f7247a03f924281480b71a9a9155f833f946d78e8133fe4a4de
-SIZE (xfce4/xfdashboard-0.7.5.tar.bz2) = 3366413
+TIMESTAMP = 1575051878
+SHA256 (xfce4/xfdashboard-0.7.6.tar.bz2) = 9ed7da8596627dd864b21b301aa5b0efe7c4e465b43534cd04bae3204efca343
+SIZE (xfce4/xfdashboard-0.7.6.tar.bz2) = 3393562
diff --git a/x11/xfce4-dashboard/files/patch-libxfdashboard_application-database.c b/x11/xfce4-dashboard/files/patch-libxfdashboard_application-database.c
deleted file mode 100644
index 5be2424bbb46..000000000000
--- a/x11/xfce4-dashboard/files/patch-libxfdashboard_application-database.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- libxfdashboard/application-database.c.orig 2018-04-25 20:40:40 UTC
-+++ libxfdashboard/application-database.c
-@@ -118,14 +118,11 @@ static void _xfdashboard_application_database_add_hash
- static void _xfdashboard_application_database_on_application_menu_reload_required(XfdashboardApplicationDatabase *self,
- gpointer inUserData)
- {
-- GarconMenu *menu;
-- GError *error;
-+ GarconMenu *menu=GARCON_MENU(inUserData);
-+ GError *error=NULL;
-
- g_return_if_fail(XFDASHBOARD_IS_APPLICATION_DATABASE(self));
-- g_return_if_fail(GARCON_IS_MENU(inUserData));
--
-- menu=GARCON_MENU(inUserData);
-- error=NULL;
-+ g_return_if_fail(GARCON_IS_MENU(menu));
-
- /* Reload application menu. This also emits all necessary signals. */
- XFDASHBOARD_DEBUG(self, APPLICATIONS,
diff --git a/x11/xfce4-dashboard/files/patch-libxfdashboard_applications-menu-model.c b/x11/xfce4-dashboard/files/patch-libxfdashboard_applications-menu-model.c
deleted file mode 100644
index 6f7ec5cf346c..000000000000
--- a/x11/xfce4-dashboard/files/patch-libxfdashboard_applications-menu-model.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- libxfdashboard/applications-menu-model.c.orig 2018-04-25 20:40:40 UTC
-+++ libxfdashboard/applications-menu-model.c
-@@ -440,7 +440,7 @@ static void _xfdashboard_applications_menu_model_fill_
-
- item=_xfdashboard_applications_menu_model_item_new();
- item->sequenceID=inFillData->sequenceID;
-- if(inMenu) item->menuElement=g_object_ref(inMenu);
-+ if(inMenu) item->menuElement=GARCON_MENU_ELEMENT(inMenu);
- if(inParentMenu) item->parentMenu=g_object_ref(inParentMenu);
- if(section) item->section=g_object_ref(section);
- if(title) item->title=g_strdup(title);
diff --git a/x11/xfce4-dashboard/files/patch-settings_general.c b/x11/xfce4-dashboard/files/patch-settings_general.c
new file mode 100644
index 000000000000..41a1fbc43c94
--- /dev/null
+++ b/x11/xfce4-dashboard/files/patch-settings_general.c
@@ -0,0 +1,19 @@
+--- settings/general.c.orig 2019-11-15 13:13:14 UTC
++++ settings/general.c
+@@ -105,7 +105,7 @@ static GParamSpec* XfdashboardSettingsGeneralPropertie
+ #define DEFAULT_ALLOW_SUBWINDOWS TRUE
+
+ #define ENABLE_ANIMATIONS_XFCONF_PROP "/enable-animations"
+-#define DEFAULT_ENABLE_ANIMATIONS TRUE
++#define DEFAULT_ENABLE_ANIMATIONS FALSE
+
+
+ typedef struct _XfdashboardSettingsGeneralNameValuePair XfdashboardSettingsGeneralNameValuePair;
+@@ -638,6 +638,7 @@ static void _xfdashboard_settings_general_set_builder(
+ G_TYPE_BOOLEAN,
+ priv->widgetEnableAnimations,
+ "active");
++ gtk_widget_hide(GTK_WIDGET(priv->widgetEnableAnimations));
+ }
+
+ /* IMPLEMENTATION: GObject */
diff --git a/x11/xfce4-dashboard/pkg-plist b/x11/xfce4-dashboard/pkg-plist
index 23170d33e74b..c5359660e288 100644
--- a/x11/xfce4-dashboard/pkg-plist
+++ b/x11/xfce4-dashboard/pkg-plist
@@ -3,6 +3,7 @@ bin/xfdashboard-settings
etc/xdg/autostart/xfdashboard-autostart.desktop
include/xfdashboard/libxfdashboard/action-button.h
include/xfdashboard/libxfdashboard/actor.h
+include/xfdashboard/libxfdashboard/animation.h
include/xfdashboard/libxfdashboard/application-button.h
include/xfdashboard/libxfdashboard/application-database.h
include/xfdashboard/libxfdashboard/application-tracker.h
@@ -55,12 +56,14 @@ include/xfdashboard/libxfdashboard/stage-interface.h
include/xfdashboard/libxfdashboard/stage.h
include/xfdashboard/libxfdashboard/stylable.h
include/xfdashboard/libxfdashboard/text-box.h
+include/xfdashboard/libxfdashboard/theme-animation.h
include/xfdashboard/libxfdashboard/theme-css.h
include/xfdashboard/libxfdashboard/theme-effects.h
include/xfdashboard/libxfdashboard/theme-layout.h
include/xfdashboard/libxfdashboard/theme.h
include/xfdashboard/libxfdashboard/toggle-button.h
include/xfdashboard/libxfdashboard/tooltip-action.h
+include/xfdashboard/libxfdashboard/transition-group.h
include/xfdashboard/libxfdashboard/types.h
include/xfdashboard/libxfdashboard/utils.h
include/xfdashboard/libxfdashboard/view-manager.h
@@ -83,7 +86,7 @@ include/xfdashboard/libxfdashboard/windows-view.h
include/xfdashboard/libxfdashboard/workspace-selector.h
lib/libxfdashboard.so
lib/libxfdashboard.so.0
-lib/libxfdashboard.so.0.700.5
+lib/libxfdashboard.so.0.700.6
lib/xfdashboard/plugins/clock-view.so
lib/xfdashboard/plugins/gnome-shell-search-provider.so
lib/xfdashboard/plugins/hot-corner.so