aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2018-03-18 20:04:06 +0000
committerThomas Zander <riggs@FreeBSD.org>2018-03-18 20:04:06 +0000
commitcdb5710eacb9be3ee2dcb96eccd2346b5f48e3bd (patch)
tree92795256fab0dae7911e859c9c2759c9b0b7d530
parent3aa0add9f7c95367cb7f1fcc3378bf1c33efa821 (diff)
downloadports-cdb5710eacb9be3ee2dcb96eccd2346b5f48e3bd.tar.gz
ports-cdb5710eacb9be3ee2dcb96eccd2346b5f48e3bd.zip
Notes
-rw-r--r--lang/nim/Makefile2
-rw-r--r--lang/nim/distinfo6
-rw-r--r--lang/nim/files/patch-install.sh12
-rw-r--r--lang/nim/files/patch-koch.nim14
-rw-r--r--lang/nim/pkg-plist32
5 files changed, 37 insertions, 29 deletions
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index e1b0e0c8f103..2a62223d787a 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nim
-PORTVERSION= 0.17.2
+PORTVERSION= 0.18.0
CATEGORIES= lang
MASTER_SITES= https://nim-lang.org/download/
diff --git a/lang/nim/distinfo b/lang/nim/distinfo
index 0e1f850c6925..fb0004a81eee 100644
--- a/lang/nim/distinfo
+++ b/lang/nim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505744032
-SHA256 (nim-0.17.2.tar.xz) = aaff1b5023fc4a5708f1d7d9fd8e2a29f1a7f58bf496532ff1e9d7e7c7ec82bd
-SIZE (nim-0.17.2.tar.xz) = 4083084
+TIMESTAMP = 1521039574
+SHA256 (nim-0.18.0.tar.xz) = 45c74adb35f08dfa9add1112ae17330e5d902ebb4a36e7046caee8b79e6f3bd0
+SIZE (nim-0.18.0.tar.xz) = 4415048
diff --git a/lang/nim/files/patch-install.sh b/lang/nim/files/patch-install.sh
index 9ef931155c7e..a7c4b86d7414 100644
--- a/lang/nim/files/patch-install.sh
+++ b/lang/nim/files/patch-install.sh
@@ -1,5 +1,5 @@
---- install.sh.orig 2017-09-07 18:45:41.000000000 +0000
-+++ install.sh 2017-09-18 14:47:39.284096000 +0000
+--- install.sh.orig 2018-03-14 15:03:07.246974000 +0000
++++ install.sh 2018-03-14 15:08:43.631474000 +0000
@@ -15,48 +15,14 @@
"--help"|"-h"|"help"|"h")
echo "Nim installation script"
@@ -19,7 +19,7 @@
- libdir=/usr/lib/nim
- docdir=/usr/share/nim/doc
- datadir=/usr/share/nim/data
-- nimbleDir="/opt/nimble/pkgs/compiler-0.17.2"
+- nimbleDir="/opt/nimble/pkgs/compiler-0.18.0"
- ;;
- "/usr/local/bin")
- bindir=/usr/local/bin
@@ -27,7 +27,7 @@
- libdir=/usr/local/lib/nim
- docdir=/usr/local/share/nim/doc
- datadir=/usr/local/share/nim/data
-- nimbleDir="/opt/nimble/pkgs/compiler-0.17.2"
+- nimbleDir="/opt/nimble/pkgs/compiler-0.18.0"
- ;;
- "/opt")
- bindir="/opt/nim/bin"
@@ -35,7 +35,7 @@
- libdir="/opt/nim/lib"
- docdir="/opt/nim/doc"
- datadir="/opt/nim/data"
-- nimbleDir="/opt/nimble/pkgs/compiler-0.17.2"
+- nimbleDir="/opt/nimble/pkgs/compiler-0.18.0"
- mkdir -p /opt/nim
- mkdir -p $bindir
- mkdir -p $configdir
@@ -54,7 +54,7 @@
nimbleDir="$1/nim"
mkdir -p $1/nim
mkdir -p $bindir
-@@ -854,13 +820,6 @@
+@@ -866,13 +832,6 @@
else
echo "Nim installation script"
echo "Usage: [sudo] sh install.sh DIR"
diff --git a/lang/nim/files/patch-koch.nim b/lang/nim/files/patch-koch.nim
index 199416d65203..9c1c074e6106 100644
--- a/lang/nim/files/patch-koch.nim
+++ b/lang/nim/files/patch-koch.nim
@@ -1,10 +1,12 @@
---- koch.nim.orig 2017-05-18 14:19:21.268379000 +0000
-+++ koch.nim 2017-05-18 14:21:26.248851000 +0000
-@@ -257,7 +257,6 @@
- let nimgrepExe = "bin/nimgrep".exe
- nimexec "c -o:" & nimgrepExe & " tools/nimgrep.nim"
- when defined(windows): buildVccTool()
+--- koch.nim.orig 2018-03-14 15:15:05.712810000 +0000
++++ koch.nim 2018-03-14 15:15:42.575087000 +0000
+@@ -265,7 +265,8 @@
+
+ #nimexec "c -o:" & ("bin/nimresolve".exe) & " tools/nimresolve.nim"
+
- buildNimble(latest)
++ # Don't build Nimble here. Use the port instead.
++ #buildNimble(latest)
proc nsis(args: string) =
bundleNimbleExe()
diff --git a/lang/nim/pkg-plist b/lang/nim/pkg-plist
index 980b0b2222b6..e4b50a06fac9 100644
--- a/lang/nim/pkg-plist
+++ b/lang/nim/pkg-plist
@@ -4,10 +4,15 @@ etc/nimdoc.cfg
etc/nimdoc.tex.cfg
lib/arch/x86/amd64.S
lib/arch/x86/i386.S
+lib/core/allocators.nim
lib/core/locks.nim
lib/core/macros.nim
+lib/core/refs.nim
lib/core/rlocks.nim
+lib/core/seqs.nim
+lib/core/strs.nim
lib/core/typeinfo.nim
+lib/core/typelayouts.nim
lib/cycle.h
lib/deprecated/core/unsigned.nim
lib/deprecated/pure/actors.nim
@@ -30,6 +35,7 @@ lib/impure/osinfo_win.nim
lib/impure/rdstdin.nim
lib/impure/re.nim
lib/impure/ssl.nim
+lib/js/asyncjs.nim
lib/js/dom.nim
lib/js/jsconsole.nim
lib/js/jsffi.nim
@@ -54,6 +60,7 @@ lib/posix/posix_other_consts.nim
lib/posix/termios.nim
lib/prelude.nim
lib/pure/algorithm.nim
+lib/pure/async.nim
lib/pure/asyncdispatch.nim
lib/pure/asyncdispatch.nim.cfg
lib/pure/asyncfile.nim
@@ -64,8 +71,6 @@ lib/pure/asyncmacro.nim
lib/pure/asyncnet.nim
lib/pure/asyncstreams.nim
lib/pure/base64.nim
-lib/pure/basic2d.nim
-lib/pure/basic3d.nim
lib/pure/bitops.nim
lib/pure/browsers.nim
lib/pure/cgi.nim
@@ -94,6 +99,7 @@ lib/pure/concurrency/threadpool.nim.cfg
lib/pure/cookies.nim
lib/pure/coro.nim
lib/pure/coro.nimcfg
+lib/pure/cstrutils.nim
lib/pure/db_common.nim
lib/pure/distros.nim
lib/pure/dynlib.nim
@@ -102,7 +108,6 @@ lib/pure/endians.nim
lib/pure/events.nim
lib/pure/fenv.nim
lib/pure/future.nim
-lib/pure/gentabs.nim
lib/pure/hashes.nim
lib/pure/htmlgen.nim
lib/pure/htmlparser.nim
@@ -112,12 +117,12 @@ lib/pure/httpserver.nim
lib/pure/includes/asynccommon.nim
lib/pure/includes/osenv.nim
lib/pure/includes/oserr.nim
-lib/pure/ioselectors.nim
lib/pure/ioselects/ioselectors_epoll.nim
lib/pure/ioselects/ioselectors_kqueue.nim
lib/pure/ioselects/ioselectors_poll.nim
lib/pure/ioselects/ioselectors_select.nim
lib/pure/json.nim
+lib/pure/lenientops.nim
lib/pure/lexbase.nim
lib/pure/logging.nim
lib/pure/marshal.nim
@@ -132,7 +137,6 @@ lib/pure/net.nim
lib/pure/nimprof.nim
lib/pure/nimprof.nim.cfg
lib/pure/nimtracker.nim
-lib/pure/numeric.nim
lib/pure/oids.nim
lib/pure/options.nim
lib/pure/os.nim
@@ -147,11 +151,9 @@ lib/pure/parsesql.nim
lib/pure/parseutils.nim
lib/pure/parsexml.nim
lib/pure/pegs.nim
-lib/pure/poly.nim
lib/pure/punycode.nim
lib/pure/random.nim
lib/pure/rationals.nim
-lib/pure/romans.nim
lib/pure/ropes.nim
lib/pure/scgi.nim
lib/pure/securehash.nim
@@ -161,6 +163,7 @@ lib/pure/smtp.nim
lib/pure/smtp.nim.cfg
lib/pure/stats.nim
lib/pure/streams.nim
+lib/pure/strformat.nim
lib/pure/strmisc.nim
lib/pure/strscans.nim
lib/pure/strtabs.nim
@@ -180,6 +183,7 @@ lib/pure/xmldom.nim
lib/pure/xmldomparser.nim
lib/pure/xmlparser.nim
lib/pure/xmltree.nim
+lib/std/sha1.nim
lib/stdlib.nimble
lib/system.nim
lib/system/alloc.nim
@@ -203,6 +207,7 @@ lib/system/gc2.nim
lib/system/gc_common.nim
lib/system/gc_ms.nim
lib/system/gc_regions.nim
+lib/system/genodealloc.nim
lib/system/hti.nim
lib/system/inclrtl.nim
lib/system/jssys.nim
@@ -222,13 +227,9 @@ lib/system/sysstr.nim
lib/system/threads.nim
lib/system/timers.nim
lib/system/widestrs.nim
-lib/upcoming/asyncdispatch.nim
lib/windows/registry.nim
lib/windows/winlean.nim
lib/wrappers/iup.nim
-lib/wrappers/joyent_http_parser.nim
-lib/wrappers/libsvm.nim
-lib/wrappers/libuv.nim
lib/wrappers/linenoise/LICENSE.txt
lib/wrappers/linenoise/README.markdown
lib/wrappers/linenoise/linenoise.c
@@ -238,7 +239,6 @@ lib/wrappers/mysql.nim
lib/wrappers/odbcsql.nim
lib/wrappers/openssl.nim
lib/wrappers/pcre.nim
-lib/wrappers/pdcurses.nim
lib/wrappers/postgres.nim
lib/wrappers/sqlite3.nim
lib/wrappers/tinyc.nim
@@ -263,6 +263,8 @@ nim/compiler/commands.nim
nim/compiler/condsyms.nim
nim/compiler/debuginfo.nim
nim/compiler/depends.nim
+nim/compiler/destroyer.nim
+nim/compiler/dfa.nim
nim/compiler/docgen.nim
nim/compiler/docgen2.nim
nim/compiler/evalffi.nim
@@ -271,6 +273,7 @@ nim/compiler/extccomp.nim
nim/compiler/filter_tmpl.nim
nim/compiler/filters.nim
nim/compiler/forloops.nim
+nim/compiler/gorgeimpl.nim
nim/compiler/guards.nim
nim/compiler/hlo.nim
nim/compiler/idents.nim
@@ -281,6 +284,7 @@ nim/compiler/jsgen.nim
nim/compiler/jstypes.nim
nim/compiler/lambdalifting.nim
nim/compiler/lexer.nim
+nim/compiler/liftlocals.nim
nim/compiler/lists.nim
nim/compiler/llstream.nim
nim/compiler/lookups.nim
@@ -289,6 +293,7 @@ nim/compiler/magicsys.nim
nim/compiler/main.nim
nim/compiler/mapping.txt
nim/compiler/modulegraphs.nim
+nim/compiler/modulepaths.nim
nim/compiler/modules.nim
nim/compiler/msgs.nim
nim/compiler/ndi.nim
@@ -324,6 +329,8 @@ nim/compiler/procfind.nim
nim/compiler/readme.txt
nim/compiler/renderer.nim
nim/compiler/reorder.nim
+nim/compiler/rod.nim
+nim/compiler/rodimpl.nim
nim/compiler/rodread.nim
nim/compiler/rodutils.nim
nim/compiler/rodwrite.nim
@@ -334,7 +341,6 @@ nim/compiler/sem.nim
nim/compiler/semasgn.nim
nim/compiler/semcall.nim
nim/compiler/semdata.nim
-nim/compiler/semdestruct.nim
nim/compiler/semexprs.nim
nim/compiler/semfields.nim
nim/compiler/semfold.nim