aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-07-22 23:23:59 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-07-22 23:23:59 +0000
commitce7d0b1f2e20766f2a2bf8a739f73122e2c86c0c (patch)
tree4340b2026c7c38e24a07317c8ba6bded8fdc03e8
parent55b482bb6d366ae343d8e3cb1dc564c3b7480b2d (diff)
downloadports-ce7d0b1f2e20766f2a2bf8a739f73122e2c86c0c.tar.gz
ports-ce7d0b1f2e20766f2a2bf8a739f73122e2c86c0c.zip
Notes
-rw-r--r--astro/cfitsio/Makefile2
-rw-r--r--audio/lv2core/Makefile3
-rw-r--r--audio/slv2/Makefile4
-rw-r--r--converters/gbase/Makefile4
-rw-r--r--databases/hk_classes/Makefile4
-rw-r--r--databases/sqlite2/Makefile3
-rw-r--r--devel/ace/Makefile3
-rw-r--r--devel/py-fusefs/Makefile2
-rw-r--r--devel/ros/Makefile3
-rw-r--r--devel/rpc2/Makefile2
-rw-r--r--devel/rudiments/Makefile3
-rw-r--r--devel/rvm/Makefile2
-rw-r--r--games/poker-engine/Makefile8
-rw-r--r--games/poker-eval/Makefile3
-rw-r--r--games/py-poker-eval/Makefile2
-rw-r--r--graphics/djview4/Makefile2
-rw-r--r--graphics/fv/Makefile2
-rw-r--r--graphics/pngwriter/Makefile2
-rw-r--r--graphics/sswf/Makefile2
-rw-r--r--graphics/swftools/Makefile2
-rw-r--r--misc/mc-light/Makefile4
-rw-r--r--sysutils/fusefs-libs/Makefile3
-rw-r--r--sysutils/nut22/Makefile3
-rw-r--r--textproc/scim-openvanilla/Makefile4
-rw-r--r--textproc/soothsayer/Makefile4
-rw-r--r--x11-clocks/buici-clock/Makefile2
-rw-r--r--x11-fm/tdfsb/Makefile2
-rw-r--r--x11-wm/skippy-xd/Makefile4
-rw-r--r--x11-wm/skippy/Makefile3
29 files changed, 50 insertions, 37 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index e57434ea2a0d..65056791ebc5 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -15,13 +15,13 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for reading and writing files in FITS data format
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= f2c:${PORTSDIR}/lang/f2c
OPTIONS_DEFINE= DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_prog_FC="f2c"
ALL_TARGET= shared
diff --git a/audio/lv2core/Makefile b/audio/lv2core/Makefile
index ba8226235614..2a3a6a5d738e 100644
--- a/audio/lv2core/Makefile
+++ b/audio/lv2core/Makefile
@@ -16,9 +16,10 @@ COMMENT= LV2 Core Package
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
-USE_GNOME= pkgconfig
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/audio/slv2/Makefile b/audio/slv2/Makefile
index cb744d57bcc1..046c2b8b4f5f 100644
--- a/audio/slv2/Makefile
+++ b/audio/slv2/Makefile
@@ -16,13 +16,13 @@ COMMENT= LV2 Application Support Library
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/lv2.h:${PORTSDIR}/audio/lv2core
+BUILD_DEPENDS= ${LOCALBASE}/include/lv2.h:${PORTSDIR}/audio/lv2core \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
rdf.0:${PORTSDIR}/textproc/redland
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
-USE_GNOME= pkgconfig
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/converters/gbase/Makefile b/converters/gbase/Makefile
index d9c7f0906a45..50ee215a10d6 100644
--- a/converters/gbase/Makefile
+++ b/converters/gbase/Makefile
@@ -16,9 +16,9 @@ COMMENT= A program to convert between the 4 common bases used in programming
LICENSE= ART10
-OPTIONS_DEFINE= GTK2
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-USE_GNOME= pkgconfig
+OPTIONS_DEFINE= GTK2
PLIST_FILES= bin/${PORTNAME}
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index 2167c021cbd0..1852a8cf14b4 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -12,14 +12,14 @@ MASTER_SITES= SF/hk-classes/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Library for rapid development of database applications
-BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
xml2.5:${PORTSDIR}/textproc/libxml2
USE_BZIP2= yes
USE_ICONV= yes
USE_PYTHON= yes
-USE_GNOME= pkgconfig
USE_GETTEXT= yes
CXXFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -largp -lintl
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index c25d91a0467d..7c4386d65f5b 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -15,8 +15,9 @@ MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= An SQL database engine in a C library
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_GMAKE= YES
-USE_GNOME= pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index 696d8f45d988..1d8f036a4f24 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -15,6 +15,8 @@ DISTNAME= ACE-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Adaptive Communication Environment for C++
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
OPTIONS_DEFINE= SSL TRIO X11 FLTK TK QT4
OPTIONS_DEFAULT=SSL
TRIO_DESC= Enable trio support
@@ -26,7 +28,6 @@ CONFLICTS= ace+tao-5*
WRKSRC= ${WRKDIR}/ACE_wrappers
USE_BZIP2= yes
-USE_GNOME= pkgconfig
USE_PERL5_BUILD=yes
USE_GMAKE= yes
MAKE_ENV= LD_LIBRARY_PATH="${WRKSRC}/lib" ACE_ROOT="${WRKSRC}" \
diff --git a/devel/py-fusefs/Makefile b/devel/py-fusefs/Makefile
index f6e78607bada..1d9257bb60e5 100644
--- a/devel/py-fusefs/Makefile
+++ b/devel/py-fusefs/Makefile
@@ -15,11 +15,11 @@ DISTNAME= fuse-python-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FUSE Python bindings
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
-USE_GNOME= pkgconfig
USE_ICONV= yes
PORTDOCS= AUTHORS Changelog FAQ INSTALL README.1st README.historic \
README.new_fusepy_api
diff --git a/devel/ros/Makefile b/devel/ros/Makefile
index bd7b46ea8e19..4463a27e2ec5 100644
--- a/devel/ros/Makefile
+++ b/devel/ros/Makefile
@@ -17,6 +17,8 @@ LICENSE= BSD
STACKNAME= ${PORTNAME:S/ros-//}
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
CFLAGS+= -I${LOCALBASE}/include
LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
gtest:${PORTSDIR}/devel/googletest
@@ -32,7 +34,6 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/yaml/__init__.py:${PORTSDIR}/devel/py-yaml \
gmake:${PORTSDIR}/devel/gmake \
sudo:${PORTSDIR}/security/sudo \
wget:${PORTSDIR}/ftp/wget
-USE_GNOME= pkgconfig
USE_PYTHON= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
diff --git a/devel/rpc2/Makefile b/devel/rpc2/Makefile
index 1d9cd4c59001..35ecdd4c7cf7 100644
--- a/devel/rpc2/Makefile
+++ b/devel/rpc2/Makefile
@@ -16,10 +16,10 @@ MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/rpc2/src/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= An interprocess communication library
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= lwp.2:${PORTSDIR}/devel/lwp
USE_GMAKE= yes
-USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
USE_PERL5= yes
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index 99db803e3ba3..337f7e3216bd 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -15,7 +15,8 @@ COMMENT= A utility C++ class library for daemons, clients, servers and more
LICENSE= LGPL20
-USE_GNOME= pkgconfig
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_OPENSSL= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
diff --git a/devel/rvm/Makefile b/devel/rvm/Makefile
index 47093356a33c..d9b9b82420cc 100644
--- a/devel/rvm/Makefile
+++ b/devel/rvm/Makefile
@@ -16,10 +16,10 @@ MASTER_SITES= ftp://ftp.coda.cs.cmu.edu/pub/rvm/src/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A persistent VM library
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= lwp.2:${PORTSDIR}/devel/lwp
USE_GMAKE= yes
-USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/games/poker-engine/Makefile b/games/poker-engine/Makefile
index 468b331c5a1b..f912adb82fb0 100644
--- a/games/poker-engine/Makefile
+++ b/games/poker-engine/Makefile
@@ -17,13 +17,17 @@ COMMENT= A python library that implements poker rules
BUILD_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
+
+RUN_DEPENDS= ${LOCALBASE}/bin/rsync:${PORTSDIR}/net/rsync \
+ ${PYTHON_SITELIBDIR}/pokereval.py:${PORTSDIR}/games/py-poker-eval \
+ ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
-RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= pkgconfig
USE_PYTHON= 2.5-2.7
USE_GETTEXT= yes
USE_GMAKE= yes
diff --git a/games/poker-eval/Makefile b/games/poker-eval/Makefile
index a58f87a51aea..526ba2ae4c27 100644
--- a/games/poker-eval/Makefile
+++ b/games/poker-eval/Makefile
@@ -18,8 +18,9 @@ COMMENT= A C library to evaluate poker hands
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/games/py-poker-eval/Makefile b/games/py-poker-eval/Makefile
index 03ffa1bdb440..c5a56b3cf8b0 100644
--- a/games/py-poker-eval/Makefile
+++ b/games/py-poker-eval/Makefile
@@ -16,12 +16,12 @@ DISTNAME= py${PORTNAME}-${PORTVERSION:E}.0
MAINTAINER= ports@FreeBSD.org
COMMENT= Python adaptor for the poker-eval toolkit
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= poker-eval.1:${PORTSDIR}/games/poker-eval
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_GNOME= pkgconfig
USE_PYTHON= 2.5-2.7
USE_AUTOTOOLS= aclocal autoconf automake libtool
ACLOCAL_ARGS= -I config
diff --git a/graphics/djview4/Makefile b/graphics/djview4/Makefile
index f6fe5698887a..cbbdb8931fe9 100644
--- a/graphics/djview4/Makefile
+++ b/graphics/djview4/Makefile
@@ -16,10 +16,10 @@ COMMENT= Standalone Djvu viewer and plugin based on Qt4 toolkit
LICENSE= GPLv2
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= djvulibre:${PORTSDIR}/graphics/djvulibre
GNU_CONFIGURE= yes
-USE_GNOME= pkgconfig
USE_QT4= gui network rcc_build uic_build moc_build qmake_build
QT_NONSTANDARD= yes
CONFIGURE_ARGS= --x-includes="${LOCALBASE}/include" \
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index a18539fe939d..8de82e1cb7e5 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -17,11 +17,11 @@ COMMENT= A viewer of hdr/pfm images
LICENSE= GPLv2
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_ZIP= yes
USE_GL= glut
-USE_GNOME= pkgconfig
USE_GMAKE= yes
ALL_TARGET= ${PORTNAME}
MAKE_JOBS_SAFE= yes
diff --git a/graphics/pngwriter/Makefile b/graphics/pngwriter/Makefile
index 9db6905ca1e6..6443e203daae 100644
--- a/graphics/pngwriter/Makefile
+++ b/graphics/pngwriter/Makefile
@@ -15,12 +15,12 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A C++ library for creating PNG images
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_GNOME= pkgconfig
CXXFLAGS+= `pkg-config --cflags freetype2 libpng15` -I${LOCALBASE}/include
PORTDOCS= *
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index ff4d8e04d7db..1b8933fd9cd7 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -15,12 +15,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= A library and script language tool to create Flash movies
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GNOME= pkgconfig
USE_BISON= build
USE_ICONV= yes
USE_AUTOTOOLS= libtool
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index d481db45e899..f61170ddc736 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -17,6 +17,7 @@ COMMENT= SWF manipulation and generation utilities
LICENSE= GPLv2
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.11:${PORTSDIR}/graphics/jpeg \
gif.5:${PORTSDIR}/graphics/giflib \
@@ -26,7 +27,6 @@ LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
OPTIONS_DEFINE= LAME PDF
-USE_GNOME= pkgconfig
USE_GL= glut
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/misc/mc-light/Makefile b/misc/mc-light/Makefile
index b9c804104263..53df20299b3d 100644
--- a/misc/mc-light/Makefile
+++ b/misc/mc-light/Makefile
@@ -15,7 +15,8 @@ DISTNAME= mc-${PORTVERSION:S/.p9/-pre9/}
MAINTAINER= ports@FreeBSD.org
COMMENT= A lightweight Midnight Commander clone
-RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
CONFLICTS= mc-4.7*
@@ -25,7 +26,6 @@ MC_IN_MC_DESC= Allow run mc inside mc (useful for mcedit)
USE_GMAKE= yes
USE_ICONV= yes
-USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-included-slang \
--with-gettext \
diff --git a/sysutils/fusefs-libs/Makefile b/sysutils/fusefs-libs/Makefile
index a6a40c725191..51c98e5a7ec4 100644
--- a/sysutils/fusefs-libs/Makefile
+++ b/sysutils/fusefs-libs/Makefile
@@ -14,10 +14,11 @@ DISTNAME= fuse-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= FUSE allows filesystem implementation in userspace
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= MOUNT_FUSE_PATH=${PREFIX}/sbin
CFLAGS+= ${PTHREAD_CFLAGS}
-USE_GNOME= pkgconfig
USE_LDCONFIG= yes
USE_ICONV= yes
CONFIGURE_ARGS= --disable-kernel-module --prefix=${PREFIX} \
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index ae7701114b41..5f97df6bfabe 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -16,11 +16,12 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Network UPS Tools
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_GNOME= pkgconfig
NO_LATEST_LINK= yes
diff --git a/textproc/scim-openvanilla/Makefile b/textproc/scim-openvanilla/Makefile
index 8e6d54dc5f0f..b048ef24f636 100644
--- a/textproc/scim-openvanilla/Makefile
+++ b/textproc/scim-openvanilla/Makefile
@@ -17,14 +17,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SCIM OpenVanilla input method (IM)/output filter (OF) framework
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim \
- ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
+ ${LOCALBASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
RUN_DEPENDS= scim:${PORTSDIR}/textproc/scim
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libltdl
WRKSRC= ${WRKDIR}/${DISTNAME}/Loaders/SCIM
USE_GMAKE= yes
-USE_GNOME= pkgconfig
USE_GETTEXT= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
diff --git a/textproc/soothsayer/Makefile b/textproc/soothsayer/Makefile
index 1de3aff716c4..723c948d1823 100644
--- a/textproc/soothsayer/Makefile
+++ b/textproc/soothsayer/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= # none known, please fix
MAINTAINER= ports@FreeBSD.org
COMMENT= Intelligent predictive text entry platform
-BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
-USE_GNOME= pkgconfig
USE_SQLITE= 3
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= ac_cv_path_CPPUNIT_CONFIG=no \
diff --git a/x11-clocks/buici-clock/Makefile b/x11-clocks/buici-clock/Makefile
index 474b0dbe732c..e34abf939af3 100644
--- a/x11-clocks/buici-clock/Makefile
+++ b/x11-clocks/buici-clock/Makefile
@@ -16,12 +16,12 @@ COMMENT= Xlib implementation of an attractive, configurable clock
LICENSE= GPLv2 # (or later)
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_XORG= x11 xext
-USE_GNOME= pkgconfig
USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/x11-fm/tdfsb/Makefile b/x11-fm/tdfsb/Makefile
index 57cb7fd96cc3..2b2eea4c5348 100644
--- a/x11-fm/tdfsb/Makefile
+++ b/x11-fm/tdfsb/Makefile
@@ -17,11 +17,11 @@ COMMENT= A 3D filesystem browser
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= smpeg.1:${PORTSDIR}/multimedia/smpeg
USE_GL= glut
USE_SDL= image sdl
-USE_GNOME= pkgconfig
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
diff --git a/x11-wm/skippy-xd/Makefile b/x11-wm/skippy-xd/Makefile
index 73c0ae9b92f8..8b7c1f2d8244 100644
--- a/x11-wm/skippy-xd/Makefile
+++ b/x11-wm/skippy-xd/Makefile
@@ -14,10 +14,10 @@ MASTER_SITES= http://cdn.thegraveyard.org/releases/skippy/
MAINTAINER= ports@FreeBSD.org
COMMENT= A full-screen X11 task-switcher like Apple's Expose
-BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
+BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 \
+ pkg-config>0:${PORTSDIR}/devel/pkg-config
USE_BZIP2= yes
-USE_GNOME= pkgconfig
USE_XORG= x11 xft xcomposite xdamage xfixes xrender xinerama xext xmu
PLIST_FILES= bin/skippy-xd \
%%DATADIR%%/skippy-xd.rc-default
diff --git a/x11-wm/skippy/Makefile b/x11-wm/skippy/Makefile
index 80948b02cf9c..c8b15ec87274 100644
--- a/x11-wm/skippy/Makefile
+++ b/x11-wm/skippy/Makefile
@@ -14,9 +14,10 @@ MASTER_SITES= http://cdn.thegraveyard.org/releases/skippy/
MAINTAINER= ports@FreeBSD.org
COMMENT= A full-screen X11 task-switcher like Apple's Expose
+BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
+
USE_XORG= x11 xext xinerama xft xmu
USE_BZIP2= yes
-USE_GNOME= pkgconfig
USE_EFL= imlib2
PLIST_FILES= bin/skippy \
%%DATADIR%%/skippyrc-default