aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2017-08-29 10:30:33 +0000
committerRenato Botelho <garga@FreeBSD.org>2017-08-29 10:30:33 +0000
commitce8d8102a00ba90a679fc9fdf5e526b3b76447f0 (patch)
tree87fbeddece728fbb37a0cd4abddbdb0c70d3b548
parentd0cdc04b3bccc79ef6c65f233b1e20bbc97e99c0 (diff)
downloadports-ce8d8102a00ba90a679fc9fdf5e526b3b76447f0.tar.gz
ports-ce8d8102a00ba90a679fc9fdf5e526b3b76447f0.zip
Notes
-rw-r--r--security/sudo/Makefile3
-rw-r--r--security/sudo/distinfo6
-rw-r--r--security/sudo/files/patch-src_exec__nopty.c35
-rw-r--r--security/sudo/pkg-plist1
4 files changed, 18 insertions, 27 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index f37bd6212c50..cc06323bff28 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= sudo
-PORTVERSION= 1.8.20p2
-PORTREVISION= 3
+PORTVERSION= 1.8.21
CATEGORIES= security
MASTER_SITES= SUDO
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index fa89c08d437b..930deccab95a 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1497103724
-SHA256 (sudo-1.8.20p2.tar.gz) = bd42ae1059e935f795c69ea97b3de09fe9410a58a74b5d5e6836eb5067a445d9
-SIZE (sudo-1.8.20p2.tar.gz) = 2930769
+TIMESTAMP = 1503887359
+SHA256 (sudo-1.8.21.tar.gz) = 126e9214613e842e19a02658f060186fe6a5927948679d64895b17ed933bb523
+SIZE (sudo-1.8.21.tar.gz) = 2973939
diff --git a/security/sudo/files/patch-src_exec__nopty.c b/security/sudo/files/patch-src_exec__nopty.c
index 188125823925..21799d7b9504 100644
--- a/security/sudo/files/patch-src_exec__nopty.c
+++ b/security/sudo/files/patch-src_exec__nopty.c
@@ -1,26 +1,17 @@
---- src/exec_nopty.c.orig 2017-08-09 17:20:41 UTC
-+++ src/exec_nopty.c
-@@ -201,7 +201,7 @@ exec_nopty(struct command_details *details, struct com
- sudo_warn(U_("unable to set handler for signal %d"), SIGCHLD);
- if (sudo_sigaction(SIGCONT, &sa, NULL) != 0)
- sudo_warn(U_("unable to set handler for signal %d"), SIGCONT);
--#ifdef SIGINFO
-+#if defined(SIGINFO) && !defined(__FreeBSD__)
- if (sudo_sigaction(SIGINFO, &sa, NULL) != 0)
- sudo_warn(U_("unable to set handler for signal %d"), SIGINFO);
- #endif
-@@ -222,6 +222,14 @@ exec_nopty(struct command_details *details, struct com
- sudo_warn(U_("unable to set handler for signal %d"), SIGQUIT);
- if (sudo_sigaction(SIGTSTP, &sa, NULL) != 0)
- sudo_warn(U_("unable to set handler for signal %d"), SIGTSTP);
+--- src/exec_nopty.c.orig 2017-08-28 20:07:24.296708000 -0700
++++ src/exec_nopty.c 2017-08-28 20:17:50.768102000 -0700
+@@ -134,6 +134,14 @@ signal_cb_nopty(int signo, int what, void *v)
+ sudo_ev_loopexit(ec->evbase);
+ }
+ debug_return;
+#if defined(SIGINFO) && defined(__FreeBSD__)
+ /*
-+ * FreeBSD's ^T will generate a SIGINFO to the controlling terminal's
-+ * process group.
++ * FreeBSD's ^T (terminal STATUS) will send a kernel-generated SIGINFO
++ * to the controlling terminal's process group that should not be
++ * forwarded.
+ */
-+ if (sudo_sigaction(SIGINFO, &sa, NULL) != 0)
-+ sudo_warn(U_("unable to set handler for signal %d"), SIGINFO);
++ case SIGINFO:
+#endif
-
- /*
- * The policy plugin's session init must be run before we fork
+ case SIGINT:
+ case SIGQUIT:
+ case SIGTSTP:
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index 4487d39c6649..ded7167a929b 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -55,6 +55,7 @@ sbin/visudo
%%NLS%%share/locale/fi/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/fr/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/fr/LC_MESSAGES/sudoers.mo
+%%NLS%%share/locale/fur/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/gl/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/hr/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/hr/LC_MESSAGES/sudoers.mo