aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2017-08-06 01:07:22 +0000
committerDiane Bruce <db@FreeBSD.org>2017-08-06 01:07:22 +0000
commitced2e5871947af9f89879e366b0ca6867567fdc5 (patch)
tree814ce0c5bfb6165108871752f45bb71ed25ad70e
parent08d630621c5e925670c1cef4ae285a2bb9aea637 (diff)
downloadports-ced2e5871947af9f89879e366b0ca6867567fdc5.tar.gz
ports-ced2e5871947af9f89879e366b0ca6867567fdc5.zip
Notes
-rw-r--r--audio/codec2/Makefile8
-rw-r--r--audio/codec2/distinfo6
-rw-r--r--audio/codec2/files/patch-CMakeLists.txt8
-rw-r--r--audio/codec2/files/patch-codec2.pc.in6
-rw-r--r--audio/codec2/files/patch-src__freedv_api.c6
-rw-r--r--audio/codec2/files/patch-unittest__CMakeLists.txt4
-rw-r--r--audio/codec2/pkg-plist40
7 files changed, 49 insertions, 29 deletions
diff --git a/audio/codec2/Makefile b/audio/codec2/Makefile
index 3125896482ee..284485702874 100644
--- a/audio/codec2/Makefile
+++ b/audio/codec2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= codec2
-PORTVERSION= 0.6
+PORTVERSION= 0.7
CATEGORIES= audio hamradio
MASTER_SITES= http://files.freedv.org/codec2/ \
LOCAL/db
@@ -26,11 +26,11 @@ TEST_SRCFILES= cohpsk_ch cohpsk_demod cohpsk_get_test_bits cohpsk_mod\
cohpsk_put_test_bits fdmdv_channel freedv_rx freedv_tx\
generate_codebook
TEST_UNITTESTFILES= c2validate create_interleaver de extract fdmdv_mem\
- genampdata genlsp genphdata genres lspsync polar2rect\
+ genlsp genres polar2rect\
pre raw2h scalarlsptest speexnoisesup t16_8\
t16_8_short tcohpsk test_cohpsk_ch tfdmdv tfifo\
- tinterp tlspsens tnlp tprede tquant vq_train_jvm\
- vqtrain vqtrainjnd vqtrainph vqtrainsp
+ tnlp tprede vq_train_jvm\
+ vqtrain
SHEBANG_FILES= ${WRKSRC}/octave/fsk_horus_stream.m\
${WRKSRC}/script/menu.sh
diff --git a/audio/codec2/distinfo b/audio/codec2/distinfo
index 1943931fab76..857977fc8478 100644
--- a/audio/codec2/distinfo
+++ b/audio/codec2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494899272
-SHA256 (codec2-0.6.tar.xz) = 57754bf3507a7ac9f9402cae054787a3572bea6a791137cdd5fa35f6c5af1144
-SIZE (codec2-0.6.tar.xz) = 8352824
+TIMESTAMP = 1500555166
+SHA256 (codec2-0.7.tar.xz) = 0695bb93cd985dd39f02f0db35ebc28a98b9b88747318f90774aba5f374eadb2
+SIZE (codec2-0.7.tar.xz) = 8386048
diff --git a/audio/codec2/files/patch-CMakeLists.txt b/audio/codec2/files/patch-CMakeLists.txt
index fb022ede2809..d9293a2ea770 100644
--- a/audio/codec2/files/patch-CMakeLists.txt
+++ b/audio/codec2/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2017-02-15 02:10:02 UTC
+--- CMakeLists.txt.orig 2017-07-18 14:11:40 UTC
+++ CMakeLists.txt
@@ -14,6 +14,7 @@ mark_as_advanced(CLEAR
CMAKE_INSTALL_BINDIR
@@ -8,7 +8,7 @@
)
#
-@@ -166,13 +167,24 @@ if(UNITTEST)
+@@ -164,13 +165,24 @@ if(UNITTEST)
# Find speex library
#
message(STATUS "Looking for Speex DSP library.")
@@ -32,5 +32,5 @@
+ message(FATAL_ERROR "samplerate library not found!")
+ endif()
- add_subdirectory(unittest)
- endif(UNITTEST)
+ #
+ # Samplerate Library
diff --git a/audio/codec2/files/patch-codec2.pc.in b/audio/codec2/files/patch-codec2.pc.in
index 98c512255304..e3ac05d0d4e8 100644
--- a/audio/codec2/files/patch-codec2.pc.in
+++ b/audio/codec2/files/patch-codec2.pc.in
@@ -1,9 +1,9 @@
---- codec2.pc.in.orig 2016-04-13 23:50:56 UTC
+--- codec2.pc.in.orig 2017-04-04 20:42:22 UTC
+++ codec2.pc.in
@@ -1,6 +1,6 @@
prefix=@CMAKE_INSTALL_PREFIX@
--libdir=@CMAKE_INSTALL_LIBDIR@
--includedir=/usr/include/codec2
+-libdir=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@
+-includedir=@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_INCLUDEDIR@/
+libdir=${prefix}/lib
+includedir=${prefix}/include/codec2
diff --git a/audio/codec2/files/patch-src__freedv_api.c b/audio/codec2/files/patch-src__freedv_api.c
index 965799ad88b5..d4a8a77a44ce 100644
--- a/audio/codec2/files/patch-src__freedv_api.c
+++ b/audio/codec2/files/patch-src__freedv_api.c
@@ -1,4 +1,4 @@
---- src/freedv_api.c.orig 2017-02-07 04:36:38 UTC
+--- src/freedv_api.c.orig 2017-03-30 20:09:46 UTC
+++ src/freedv_api.c
@@ -36,7 +36,7 @@
#ifdef __APPLE__
@@ -9,7 +9,7 @@
#endif /* __APPLE__ */
#include "fsk.h"
-@@ -258,7 +258,7 @@ struct freedv *freedv_open(int mode) {
+@@ -260,7 +260,7 @@ struct freedv *freedv_open(int mode) {
f->n_codec_bits = codec2_bits_per_frame(f->codec2);
nbit = f->n_codec_bits;
nbyte = (nbit + 7) / 8;
@@ -18,7 +18,7 @@
f->n_speech_samples = 2*codec2_samples_per_frame(f->codec2);
f->n_codec_bits = codec2_bits_per_frame(f->codec2);
nbit = f->n_codec_bits;
-@@ -504,7 +504,7 @@ void freedv_tx(struct freedv *f, short m
+@@ -506,7 +506,7 @@ void freedv_tx(struct freedv *f, short m
if((f->mode == FREEDV_MODE_2400A) || (f->mode == FREEDV_MODE_2400B) || (f->mode == FREEDV_MODE_800XA)){
/* 800XA has two codec frames per modem frame */
diff --git a/audio/codec2/files/patch-unittest__CMakeLists.txt b/audio/codec2/files/patch-unittest__CMakeLists.txt
index 0c27737bfeab..f6d05c389d29 100644
--- a/audio/codec2/files/patch-unittest__CMakeLists.txt
+++ b/audio/codec2/files/patch-unittest__CMakeLists.txt
@@ -1,6 +1,6 @@
---- unittest/CMakeLists.txt.orig 2017-01-30 20:52:36 UTC
+--- unittest/CMakeLists.txt.orig 2017-06-12 01:04:28 UTC
+++ unittest/CMakeLists.txt
-@@ -118,7 +118,10 @@ add_executable(tnewamp1 tnewamp1.c ../sr
+@@ -91,7 +91,10 @@ add_executable(tnewamp1 tnewamp1.c ../sr
target_link_libraries(tnewamp1 codec2)
add_executable(tsrc tsrc.c)
diff --git a/audio/codec2/pkg-plist b/audio/codec2/pkg-plist
index 52e7a30b997c..a650251222d8 100644
--- a/audio/codec2/pkg-plist
+++ b/audio/codec2/pkg-plist
@@ -29,8 +29,36 @@ include/codec2/kiss_fft.h
include/codec2/modem_stats.h
include/codec2/varicode.h
lib/libcodec2.so
-lib/libcodec2.so.0.6
+lib/libcodec2.so.0.7
libdata/pkgconfig/codec2.pc
+%%EXAMPLES%%%%DATADIR%%/octave/ofdm_rx.m
+%%EXAMPLES%%%%DATADIR%%/octave/ofdm_tx.m
+%%EXAMPLES%%%%DATADIR%%/octave/plot_specgram.m
+%%EXAMPLES%%%%DATADIR%%/octave/sample_clock_offset.m
+%%EXAMPLES%%%%DATADIR%%/octave/tofdm.m
+%%EXAMPLES%%%%DATADIR%%/octave/vq_pager.m
+%%EXAMPLES%%%%DATADIR%%/octave/HRA_112_112.txt
+%%EXAMPLES%%%%DATADIR%%/octave/HRA_112_56.txt
+%%EXAMPLES%%%%DATADIR%%/octave/HRA_56_28.txt
+%%EXAMPLES%%%%DATADIR%%/octave/HRA_56_56.txt
+%%EXAMPLES%%%%DATADIR%%/octave/bpsk.m
+%%EXAMPLES%%%%DATADIR%%/octave/c2wideband_batch.m
+%%EXAMPLES%%%%DATADIR%%/octave/c2wideband_const.m
+%%EXAMPLES%%%%DATADIR%%/octave/c2wideband_fbf.m
+%%EXAMPLES%%%%DATADIR%%/octave/estsnr.m
+%%EXAMPLES%%%%DATADIR%%/octave/fsk_eme.m
+%%EXAMPLES%%%%DATADIR%%/octave/fsk_lib.m
+%%EXAMPLES%%%%DATADIR%%/octave/gp_interleaver.m
+%%EXAMPLES%%%%DATADIR%%/octave/impulse_noise.m
+%%EXAMPLES%%%%DATADIR%%/octave/kmeans2.m
+%%EXAMPLES%%%%DATADIR%%/octave/kmeans_tests.m
+%%EXAMPLES%%%%DATADIR%%/octave/ldpc_gen_h_file.m
+%%EXAMPLES%%%%DATADIR%%/octave/ldpc_qpsk.m
+%%EXAMPLES%%%%DATADIR%%/octave/ldpc_short.m
+%%EXAMPLES%%%%DATADIR%%/octave/ofdm_dev.m
+%%EXAMPLES%%%%DATADIR%%/octave/ofdm_lib.m
+%%EXAMPLES%%%%DATADIR%%/octave/ofdm_load_const.m
+%%EXAMPLES%%%%DATADIR%%/octave/ofdm_rs.m
%%EXAMPLES%%%%DATADIR%%/octave/2400ab_frame_design.ods
%%EXAMPLES%%%%DATADIR%%/octave/H2064_516_sparse.mat
%%EXAMPLES%%%%DATADIR%%/octave/Mat2Hrows.m
@@ -235,6 +263,7 @@ libdata/pkgconfig/codec2.pc
%%EXAMPLES%%%%DATADIR%%/script/menu.sh
%%EXAMPLES%%%%DATADIR%%/script/playraw.sh
%%EXAMPLES%%%%DATADIR%%/script/raw2wav.sh
+%%EXAMPLES%%%%DATADIR%%/script/separate_all.sh
%%EXAMPLES%%%%DATADIR%%/script/wav2raw.sh
%%EXAMPLES%%%%DATADIR%%/wav/all.wav
%%EXAMPLES%%%%DATADIR%%/wav/cross.wav
@@ -283,12 +312,9 @@ libdata/pkgconfig/codec2.pc
%%TEST%%bin/fdmdv_mem
%%TEST%%bin/freedv_rx
%%TEST%%bin/freedv_tx
-%%TEST%%bin/genampdata
%%TEST%%bin/generate_codebook
%%TEST%%bin/genlsp
-%%TEST%%bin/genphdata
%%TEST%%bin/genres
-%%TEST%%bin/lspsync
%%TEST%%bin/polar2rect
%%TEST%%bin/pre
%%TEST%%bin/raw2h
@@ -300,13 +326,7 @@ libdata/pkgconfig/codec2.pc
%%TEST%%bin/test_cohpsk_ch
%%TEST%%bin/tfdmdv
%%TEST%%bin/tfifo
-%%TEST%%bin/tinterp
-%%TEST%%bin/tlspsens
%%TEST%%bin/tnlp
%%TEST%%bin/tprede
-%%TEST%%bin/tquant
%%TEST%%bin/vq_train_jvm
%%TEST%%bin/vqtrain
-%%TEST%%bin/vqtrainjnd
-%%TEST%%bin/vqtrainph
-%%TEST%%bin/vqtrainsp