aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-21 16:29:18 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-21 16:29:18 +0000
commitd06cdbebe026dc44c66739d1737b8299c2857c4c (patch)
tree1bf4afc02747c873df3fe3df009615803ef26ff6
parent0fe0dc5577969eba42d2fce189054b0c26e37d2e (diff)
downloadports-d06cdbebe026dc44c66739d1737b8299c2857c4c.tar.gz
ports-d06cdbebe026dc44c66739d1737b8299c2857c4c.zip
Notes
-rw-r--r--sysutils/e2fsprogs/Makefile16
-rw-r--r--sysutils/e2fsprogs/files/pkg-message.in8
-rw-r--r--sysutils/e2fsprogs/pkg-deinstall9
3 files changed, 27 insertions, 6 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 163f558416b5..965caacfbd00 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= e2fsprogs
PORTVERSION= 1.35.w20040131
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -29,7 +30,7 @@ INSTALLS_SHLIB= yes
NO_FILTER_SHLIBS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-elf-shlibs --disable-fsck "--with-ldopts=-L${LOCALBASE}/lib"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= CPPFLAGS='-I${WRKSRC}/lib -I${LOCALBASE}/include'
.if defined(DISABLE_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
@@ -37,6 +38,9 @@ PLIST_SUB= NLS="@comment "
MAKE_ARGS+= STATIC_LIBS="../lib/libext2fs.a ../lib/libcom_err.a ../lib/libblkid.a ../lib/libuuid.a ${LOCALBASE}/lib/libintl.a ${LOCALBASE}/lib/libiconv.a"
PLIST_SUB= NLS=""
.endif
+.if ${MACHINE_ARCH} == "alpha"
+CFLAGS+= -mieee
+.endif
CONFLICTS= ossp-uuid-*
@@ -68,13 +72,17 @@ post-patch:
-e 's|group root|group wheel|' \
-e '/Exit status is 0/ N;s/Exit status is 0\n/Exit status is 0/' \
${WRKSRC}/tests/m_*/expect.1
+.if ${MACHINE_ARCH} == "alpha" || ${MACHINE_ARCH} == "sparc64"
+ ${RM} -r ${WRKSRC}/tests/m_large_file
+.endif
-post-configure:
- @${CAT} ${FILESDIR}/pkg-message.in | ${SED} -e "s:%%PREFIX%%:${PREFIX}:" > ${PKGMESSAGE}
+pre-install:
+ ${RM} -f ${PKGMESSAGE}
+ ${SED} -e "s:%%PREFIX%%:${PREFIX}:" ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
post-build:
- cd ${WRKSRC}/tests && ${GMAKE} check
${CC} ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} ${LIBS} -o ${WRKSRC}/fsck_ext2fs ${FILESDIR}/fsck_ext2fs.c
+ cd ${WRKSRC}/tests && ${GMAKE} check
post-install:
${RM} ${PREFIX}/sbin/filefrag
diff --git a/sysutils/e2fsprogs/files/pkg-message.in b/sysutils/e2fsprogs/files/pkg-message.in
index 68ee6cc3e291..3b3c841989fb 100644
--- a/sysutils/e2fsprogs/files/pkg-message.in
+++ b/sysutils/e2fsprogs/files/pkg-message.in
@@ -2,5 +2,9 @@ To have your ext2 and ext3 filesystems fsck'ed correctly without explicitly
invoking the fsck_ext2fs utility installed by this port you will need to
create links for the fsck utilities installed by this port in /sbin, e.g.
-ln %%PREFIX%%/sbin/fsck_ext2fs /sbin/
-ln %%PREFIX%%/sbin/e2fsck.static /sbin/e2fsck
+ln -f %%PREFIX%%/sbin/fsck_ext2fs /sbin/ 2>/dev/null \
+ || install -m755 %%PREFIX%%/sbin/fsck_ext2fs /sbin/
+ln -f %%PREFIX%%/sbin/e2fsck.static /sbin/e2fsck 2>/dev/null \
+ || install -m755 %%PREFIX%%/sbin/e2fsck.static /sbin/e2fsck
+
+IMPORTANT: you also need to repeat the above steps after a port upgrade!
diff --git a/sysutils/e2fsprogs/pkg-deinstall b/sysutils/e2fsprogs/pkg-deinstall
new file mode 100644
index 000000000000..813ca04d43f8
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-deinstall
@@ -0,0 +1,9 @@
+if [ "$2" = "POST-DEINSTALL" ] ; then cat - <<_EOF
+
+If you are deinstalling the e2fsprogs port for good, rather than upgrading it,
+remember to remove the files you have installed into /sbin, example:
+
+rm -f /sbin/fsck_ext2fs /sbin/e2fsck
+
+_EOF
+fi