aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2016-11-16 00:34:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2016-11-16 00:34:23 +0000
commitd0c44e78185cd7af627046ccc68c69e798b7500e (patch)
tree970de9065392f2d5877a4b9fd628a3bad4d90e5f
parentd6c96927f496d42b5d5bcc3acd57ddd8b1676a3e (diff)
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=426198
-rw-r--r--irc/undernet-ircu/Makefile2
-rw-r--r--java/sablevm-classpath/Makefile2
-rw-r--r--lang/ecl/Makefile1
-rw-r--r--lang/maude/Makefile2
-rw-r--r--lang/nim/Makefile3
-rw-r--r--lang/pfe/Makefile5
-rw-r--r--lang/spidermonkey185/Makefile15
7 files changed, 21 insertions, 9 deletions
diff --git a/irc/undernet-ircu/Makefile b/irc/undernet-ircu/Makefile
index 75580f0dfdec..fd0ee28270e1 100644
--- a/irc/undernet-ircu/Makefile
+++ b/irc/undernet-ircu/Makefile
@@ -57,6 +57,8 @@ LEAKDETECT_CONFIGURE_WITH= leak-detect
CONFIGURE_ARGS+= --enable-profile
.endif
+BROKEN_aarch64= Fails to compile: undefined reference to .mcount
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ircd/ircd ${STAGEDIR}${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/ircd/convert-conf \
diff --git a/java/sablevm-classpath/Makefile b/java/sablevm-classpath/Makefile
index 3ca21e7216b6..a5aa7673aa0d 100644
--- a/java/sablevm-classpath/Makefile
+++ b/java/sablevm-classpath/Makefile
@@ -57,6 +57,8 @@ CONFIGURE_ARGS+= --with-compressed-classes=no
PLIST_SUB+= WITHOUT_ZIP="" WITH_ZIP="@comment "
.endif
+BROKEN_aarch64= Fails to configure: Endianess not declared
+
post-patch:
@${CP} -f ${WRKSRC}/resource/java/security/classpath.security \
${WRKSRC}/resource/java/security/SableVM.security
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 021c2d4ac81e..3468ca0afe65 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -14,6 +14,7 @@ LICENSE= LGPL20
LIB_DEPENDS= libgmp.so:math/gmp
+BROKEN_aarch64= Does not compile: error: unknown type name AO_TS_t
BROKEN_powerpc64= Does not build
MAKE_JOBS_UNSAFE= yes
diff --git a/lang/maude/Makefile b/lang/maude/Makefile
index 4b4065d18fd4..ec26ac0f4bd3 100644
--- a/lang/maude/Makefile
+++ b/lang/maude/Makefile
@@ -35,6 +35,8 @@ FULL_MAUDE_DESC= Install full-maude${FULL_MAUDE_VER}
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
+BROKEN_aarch64= Fails to link: missing sbrk
+
.include <bsd.port.options.mk>
.if ${OSVERSION} >= 1000000
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 40c1c306b370..e81f3aa86835 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -11,7 +11,10 @@ COMMENT= Nim programming language
LICENSE= MIT
+BROKEN_aarch64= Does not compile: crt1.c: undefined reference to main
+BROKEN_mips64= Does not build: build.sh: clang: not found
BROKEN_powerpc64= Does not build
+BROKEN_sparc64= Does not build: build.sh: clang: not found
OPTIONS_DEFINE= DOCS
diff --git a/lang/pfe/Makefile b/lang/pfe/Makefile
index b29e125aa1c6..4263483672e3 100644
--- a/lang/pfe/Makefile
+++ b/lang/pfe/Makefile
@@ -10,8 +10,9 @@ MASTER_SITES= SF
MAINTAINER= johans@FreeBSD.org
COMMENT= Implementation of ANSI Forth
-BROKEN_i386= does not link
-BROKEN_powerpc= does not compile
+BROKEN_aarch64= does not compile: error: implicit declaration of function 'PFE_SBR_COMPILE_EXIT' is invalid in C99
+BROKEN_i386= does not link
+BROKEN_powerpc= does not compile
BROKEN_powerpc64= Does not build
GNU_CONFIGURE= yes
diff --git a/lang/spidermonkey185/Makefile b/lang/spidermonkey185/Makefile
index eb5309d8ecce..ed17c47d6932 100644
--- a/lang/spidermonkey185/Makefile
+++ b/lang/spidermonkey185/Makefile
@@ -11,9 +11,6 @@ DISTNAME= js185-1.0.0
MAINTAINER= koobs@FreeBSD.org
COMMENT= Standalone JavaScript (1.8.5) interpreter from Mozilla
-NOT_FOR_ARCHS= powerpc powerpc64
-NOT_FOR_ARCHS_REASON= PowerPC is not supported; use lang/spidermonkey170
-
BUILD_DEPENDS= zip:archivers/zip \
autoconf-2.13:devel/autoconf213
LIB_DEPENDS= libnspr4.so:devel/nspr
@@ -27,6 +24,14 @@ USE_PERL5= build
WRKSRC= ${WRKDIR}/js-${PORTVERSION}/js/src
+BROKEN_aarch64= Does not compile: error: cacheFlush support is missing on this platform
+BROKEN_armv6= Does not configure: error: compiler does not follow the C++ specification for temporary object destruction order
+BROKEN_mips64= Does not compile: error: const union jsval_layout has no member named word
+BROKEN_sparc64= Does not build: fails to link
+
+NOT_FOR_ARCHS= powerpc powerpc64
+NOT_FOR_ARCHS_REASON= PowerPC is not supported; use lang/spidermonkey170
+
CONFIGURE_ARGS= --with-pthreads \
--with-system-nspr
@@ -67,10 +72,6 @@ UTF8_CFLAGS= -DJS_C_STRINGS_ARE_UTF8
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not build on sparc64: fails to link
-.endif
-
.if ${ARCH} == "amd64"
PLIST_SUB+= AMD64=""
.else