aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-02-09 22:21:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-02-09 22:21:51 +0000
commitd17bee46cc1cb07705c76219163f18e9eecf7699 (patch)
treed5eda1d3a73847528b871077387ef1bd358a539e
parentb9b1ea82cf3798f4fc6eccdcfdfad04ad61693ed (diff)
downloadports-d17bee46cc1cb07705c76219163f18e9eecf7699.tar.gz
ports-d17bee46cc1cb07705c76219163f18e9eecf7699.zip
x11-servers/xwayland-devel: unbreak due to x11@ being slow
===> xwayland-devel-1.20.0.592 depends on package: wayland-protocols>=1.18 - not found [...] Dependency wayland-protocols found: NO found 1.17 but need: '>= 1.18' Run-time dependency wayland-protocols found: NO (tried pkgconfig and cmake) [...] install -m 555 /usr/ports/default/x11-servers/xwayland-devel/work/xserver-1cfdd1a96580733df3625bcea3384ffee3dc92df-1cfdd1a96580733df3625bcea3384ffee3dc92df/_build/hw/xwayland/Xwayland /usr/ports/default/x11-servers/xwayland-devel/work/stage/usr/local/bin install: /usr/ports/default/x11-servers/xwayland-devel/work/xserver-1cfdd1a96580733df3625bcea3384ffee3dc92df-1cfdd1a96580733df3625bcea3384ffee3dc92df/_build/hw/xwayland/Xwayland: No such file or directory *** Error code 71
Notes
Notes: svn path=/head/; revision=525680
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/wayland-protocols-devel/Makefile13
-rw-r--r--graphics/wayland-protocols-devel/distinfo3
-rw-r--r--graphics/wayland-protocols/Makefile7
-rw-r--r--x11-servers/xwayland-devel/Makefile2
5 files changed, 23 insertions, 3 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index c3b345ddbfc6..5955462910eb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1039,6 +1039,7 @@
SUBDIR += waifu2x-ncnn-vulkan
SUBDIR += wayland
SUBDIR += wayland-protocols
+ SUBDIR += wayland-protocols-devel
SUBDIR += waylandpp
SUBDIR += webp
SUBDIR += webp-pixbuf-loader
diff --git a/graphics/wayland-protocols-devel/Makefile b/graphics/wayland-protocols-devel/Makefile
new file mode 100644
index 000000000000..59c5e9154c19
--- /dev/null
+++ b/graphics/wayland-protocols-devel/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTVERSION= 1.18
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= jbeich@FreeBSD.org
+
+CONFLICTS_INSTALL= ${PORTNAME}
+
+MASTERDIR= ${.CURDIR}/../wayland-protocols
+DISTINFO_FILE= ${.CURDIR}/distinfo
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/wayland-protocols-devel/distinfo b/graphics/wayland-protocols-devel/distinfo
new file mode 100644
index 000000000000..84150bda4018
--- /dev/null
+++ b/graphics/wayland-protocols-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1564045285
+SHA256 (wayland-protocols-1.18.tar.xz) = 3d73b7e7661763dc09d7d9107678400101ecff2b5b1e531674abfa81e04874b3
+SIZE (wayland-protocols-1.18.tar.xz) = 108344
diff --git a/graphics/wayland-protocols/Makefile b/graphics/wayland-protocols/Makefile
index 49a913df6bac..be25d81b4d0b 100644
--- a/graphics/wayland-protocols/Makefile
+++ b/graphics/wayland-protocols/Makefile
@@ -1,11 +1,12 @@
# $FreeBSD$
PORTNAME= wayland-protocols
-PORTVERSION= 1.17
+PORTVERSION?= 1.17
+PORTREVISION?= 0
CATEGORIES= graphics wayland
MASTER_SITES= https://wayland.freedesktop.org/releases/
-MAINTAINER= x11@FreeBSD.org
+MAINTAINER?= x11@FreeBSD.org
COMMENT= Wayland protocols
LICENSE= MIT
@@ -13,6 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= wayland-scanner:graphics/wayland
+CONFLICTS_INSTALL?= ${PORTNAME}-devel
+
USES= tar:xz
NO_ARCH= yes
GNU_CONFIGURE= yes
diff --git a/x11-servers/xwayland-devel/Makefile b/x11-servers/xwayland-devel/Makefile
index b11c83ad52f4..6ebe06161683 100644
--- a/x11-servers/xwayland-devel/Makefile
+++ b/x11-servers/xwayland-devel/Makefile
@@ -20,7 +20,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/mesa-dri \
- wayland-protocols>=1.18:graphics/wayland-protocols
+ wayland-protocols-devel>=1.18:graphics/wayland-protocols-devel
LIB_DEPENDS= libdrm.so:graphics/libdrm \
libepoxy.so:graphics/libepoxy \
libwayland-client.so:graphics/wayland