aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-18 16:31:09 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-18 16:31:09 +0000
commitd1a02bc3c780c0d21a16d017f25a87cbe74faf7d (patch)
tree9811b50c1625633bb075eead4e0d5b849f49876a
parentddd1452c7ac62d47428dca3c83407ebd87dc30cc (diff)
downloadports-d1a02bc3c780c0d21a16d017f25a87cbe74faf7d.tar.gz
ports-d1a02bc3c780c0d21a16d017f25a87cbe74faf7d.zip
Notes
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/wzdftpd/Makefile39
-rw-r--r--ftp/wzdftpd/distinfo1
-rw-r--r--ftp/wzdftpd/files/patch-configure20
-rw-r--r--ftp/wzdftpd/files/patch-src::Makefile.in35
-rw-r--r--ftp/wzdftpd/patch-Makefile.am12
-rw-r--r--ftp/wzdftpd/pkg-descr22
-rw-r--r--ftp/wzdftpd/pkg-message1
-rw-r--r--ftp/wzdftpd/pkg-plist42
9 files changed, 173 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 4e7151f64008..fa5f8425a790 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -79,6 +79,7 @@
SUBDIR += wput
SUBDIR += wu-ftpd
SUBDIR += wu-ftpd+ipv6
+ SUBDIR += wzdftpd
SUBDIR += xrmftp
SUBDIR += yafc
SUBDIR += yale-tftpd
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
new file mode 100644
index 000000000000..597260b66f4c
--- /dev/null
+++ b/ftp/wzdftpd/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: wzdftpd
+# Date created: 2003-10-22
+# Whom: Roman Bogorodskiy
+#
+# $FreeBSD$
+#
+
+PORTNAME= wzdftpd
+PORTVERSION= 0.1
+CATEGORIES= ftp ipv6
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= Modular FTP server configurable online using SITE commands
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --enable-ssl
+.endif
+
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+DOCS= AUTHORS Permissions.ReadMeFirst README TLS.ReadMeFirst \
+ src/CHANGELOG src/DOCS_XFERLOG_FORMAT src/KNOWN_BUGS src/TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/wzdftpd/distinfo b/ftp/wzdftpd/distinfo
new file mode 100644
index 000000000000..a527b62785da
--- /dev/null
+++ b/ftp/wzdftpd/distinfo
@@ -0,0 +1 @@
+MD5 (wzdftpd-0.1.tar.gz) = ec3ada2fbea5384d5e92eb23bb102e88
diff --git a/ftp/wzdftpd/files/patch-configure b/ftp/wzdftpd/files/patch-configure
new file mode 100644
index 000000000000..96ceef111788
--- /dev/null
+++ b/ftp/wzdftpd/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Fri Oct 24 13:24:16 2003
++++ configure Thu Dec 18 18:30:49 2003
+@@ -4359,7 +4359,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ # Double quotes because CPP needs to be expanded
+- for CPP in "$CC -E" "$CC -E -traditional-cpp" "/lib/cpp"
++ for CPP in "$CC -E" "$CC -E -traditional-cpp" "/usr/bin/cpp"
+ do
+ ac_preproc_ok=false
+ for ac_c_preproc_warn_flag in '' yes
+@@ -5376,7 +5376,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ # Double quotes because CXXCPP needs to be expanded
+- for CXXCPP in "$CXX -E" "/lib/cpp"
++ for CXXCPP in "$CXX -E" "/usr/bin/cpp"
+ do
+ ac_preproc_ok=false
+ for ac_cxx_preproc_warn_flag in '' yes
diff --git a/ftp/wzdftpd/files/patch-src::Makefile.in b/ftp/wzdftpd/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..d3d3627d51bc
--- /dev/null
+++ b/ftp/wzdftpd/files/patch-src::Makefile.in
@@ -0,0 +1,35 @@
+--- src/Makefile.in.orig Fri Oct 24 13:24:15 2003
++++ src/Makefile.in Thu Dec 18 18:44:27 2003
+@@ -253,13 +253,12 @@
+ dist_pkgdata_DATA = file_ginfo.txt file_help.txt file_swho.txt \
+ file_user.txt file_group.txt file_rules.txt \
+ file_users.txt file_who.txt file_groups.txt \
+- file_vfs.txt \
+- users
++ file_vfs.txt
+
+
+
+ #sysconfdir = ${prefix}/etc/wzdftpd
+-dist_sysconf_DATA = wzd.cfg wzd.pem
++dist_sysconf_DATA = wzd.cfg
+
+ # them while "make clean", use CLEANFILES
+ CLEANFILES = wzd_init_lex.c wzd_cookie_lex.c
+@@ -504,6 +503,7 @@
+ echo " $(dist_pkgdataDATA_INSTALL) $$d$$p $(DESTDIR)$(pkgdatadir)/$$f"; \
+ $(dist_pkgdataDATA_INSTALL) $$d$$p $(DESTDIR)$(pkgdatadir)/$$f; \
+ done
++ $(dist_pkgdataDATA_INSTALL) $(srcdir)/users $(DESTDIR)$(pkgdatadir)/users.sample
+
+ uninstall-dist_pkgdataDATA:
+ @$(NORMAL_UNINSTALL)
+@@ -520,7 +520,7 @@
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+ echo " $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f"; \
+- $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f; \
++ $(dist_sysconfDATA_INSTALL) $$d$$p $(DESTDIR)$(sysconfdir)/$$f.sample; \
+ done
+
+ uninstall-dist_sysconfDATA:
diff --git a/ftp/wzdftpd/patch-Makefile.am b/ftp/wzdftpd/patch-Makefile.am
new file mode 100644
index 000000000000..5f0f883beab0
--- /dev/null
+++ b/ftp/wzdftpd/patch-Makefile.am
@@ -0,0 +1,12 @@
+--- src/Makefile.am.orig Tue Nov 4 15:49:35 2003
++++ src/Makefile.am Tue Nov 4 15:51:07 2003
+@@ -93,7 +93,7 @@
+
+ #sysconfdir = ${prefix}/etc/wzdftpd
+
+-dist_sysconf_DATA = wzd.cfg wzd.pem
++dist_sysconf_DATA = wzd.cfg
+
+ install-data-hook:
+ ${INSTALL_PROGRAM} -m 775 -d @datadir@/wzdftpd/logs || true
+
diff --git a/ftp/wzdftpd/pkg-descr b/ftp/wzdftpd/pkg-descr
new file mode 100644
index 000000000000..cbc7ed8fbd4d
--- /dev/null
+++ b/ftp/wzdftpd/pkg-descr
@@ -0,0 +1,22 @@
+wzdftpd is a ftp server designed to be modular and entirely configurable online
+using SITE commands.
+
+wzdftpd offers the following features:
+- Simple configuration file, supporting inclusions
+- Online administration, using SITE commands
+- Backends to store users/groups in different structures
+- Modules: internal, using shared librairies, or external
+ (scripts/applications)
+- Users are virtual: you do not need to create users in system
+- SSL/TLS support
+- Server is designed to run as a non-privileged user to enforce security
+- Server can detect ip changes (dynamic ips) and set ip and passive ip
+ accordingly
+- Cross devices operations (copy/move) (though can be slow)
+- Logging support (compatible with the wu-ftpd standard)
+- Designed for high performances: coded with C, multithreaded
+
+WWW: http://www.wzdftpd.net/
+
+- Roman Bogorodskiy
+bogorodskiy@inbox.ru
diff --git a/ftp/wzdftpd/pkg-message b/ftp/wzdftpd/pkg-message
new file mode 100644
index 000000000000..52207e6aa788
--- /dev/null
+++ b/ftp/wzdftpd/pkg-message
@@ -0,0 +1 @@
+Sample file can be found at PREFIX/wzd.cfg.sample
diff --git a/ftp/wzdftpd/pkg-plist b/ftp/wzdftpd/pkg-plist
new file mode 100644
index 000000000000..86fa75193fb1
--- /dev/null
+++ b/ftp/wzdftpd/pkg-plist
@@ -0,0 +1,42 @@
+@comment $FreeBSD$
+bin/siteconfig
+bin/siteuptime
+bin/sitewho
+etc/wzd.cfg.sample
+etc/init.d/wzdftpd
+lib/libwzd.a
+lib/libwzd.so
+lib/libwzd.la
+sbin/wzdftpd
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/Permissions.ReadMeFirst
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TLS.ReadMeFirst
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/DOCS_XFERLOG_FORMAT
+%%PORTDOCS%%%%DOCSDIR%%/KNOWN_BUGS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%DATADIR%%/file_ginfo.txt
+%%DATADIR%%/file_help.txt
+%%DATADIR%%/file_swho.txt
+%%DATADIR%%/file_user.txt
+%%DATADIR%%/file_group.txt
+%%DATADIR%%/file_rules.txt
+%%DATADIR%%/file_users.txt
+%%DATADIR%%/file_vfs.txt
+%%DATADIR%%/file_who.txt
+%%DATADIR%%/file_groups.txt
+%%DATADIR%%/users.sample
+%%DATADIR%%/backends/libwzdplaintext.a
+%%DATADIR%%/backends/libwzdplaintext.so
+%%DATADIR%%/backends/libwzdplaintext.la
+%%DATADIR%%/modules/libwzd_sfv.la
+%%DATADIR%%/modules/libwzd_sfv.a
+%%DATADIR%%/modules/libwzd_test.la
+%%DATADIR%%/modules/libwzd_test.a
+%%DATADIR%%/modules/libwzd_test.so
+%%DATADIR%%/modules/libwzd_sfv.so
+@dirrm %%DATADIR%%/modules/
+@dirrm %%DATADIR%%/backends/
+@dirrm %%DATADIR%%/