aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-20 19:52:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-20 20:08:36 +0000
commitd1ba638adb7df0daa566390706929336aebe211b (patch)
tree3555a4ccd472b51f6f994cd3b0197380554cd4c6
parentd83edee081cf2bf254dbd94ae5b3a78bf6bc5268 (diff)
downloadports-d1ba638adb7df0daa566390706929336aebe211b.tar.gz
ports-d1ba638adb7df0daa566390706929336aebe211b.zip
-rw-r--r--math/moab/Makefile19
-rw-r--r--math/moab/distinfo6
-rw-r--r--math/moab/files/patch-CMakeLists.txt43
-rw-r--r--math/moab/files/patch-src_io_WriteNCDF.cpp20
-rw-r--r--math/moab/pkg-plist15
5 files changed, 82 insertions, 21 deletions
diff --git a/math/moab/Makefile b/math/moab/Makefile
index e19c83e9f646..bce64266e692 100644
--- a/math/moab/Makefile
+++ b/math/moab/Makefile
@@ -1,6 +1,5 @@
PORTNAME= moab
-DISTVERSION= 5.2.1
-PORTREVISION= 3
+DISTVERSION= 5.3.1
CATEGORIES= math
MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
@@ -14,23 +13,31 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libopenblas.so:math/openblas
-USES= cmake:noninja compiler:c++11-lang eigen:3 fortran
+USES= cmake compiler:c++11-lang eigen:3 fortran
USE_LDCONFIG= yes
CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so \
- -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so
+ -DLAPACK_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so \
+ -DFREEBSD_STAGEDIR:STRING=${STAGEDIR}
BB_ACCOUNT= fathomteam
BB_PROJECT= ${PORTNAME}
-BB_COMMIT= 7bde9dfb84a8
+BB_COMMIT= 65880ffe833d
WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
OPTIONS_DEFINE= MPI
-OPTIONS_DEFAULT= MPI
+OPTIONS_DEFAULT= #MPI
OPTIONS_SUB= yes
MPI_CMAKE_BOOL= ENABLE_MPI
MPI_LIB_DEPENDS= libmpi.so:net/openmpi
+MPI_BROKEN= Build fails, see https://bitbucket.org/fathomteam/moab/issues/158/531-fails-to-build-with-openmpi-undefined
+
+post-install:
+ # docs are just readmes
+ @${RM} -r ${STAGEDIR}${DOCSDIR}
+ # examples are installed into a wrong location, maybe fix them later?
+ @${RM} -r ${STAGEDIR}${PREFIX}/share/examples
.include <bsd.port.mk>
diff --git a/math/moab/distinfo b/math/moab/distinfo
index 39744e75e6d8..31a92c3013aa 100644
--- a/math/moab/distinfo
+++ b/math/moab/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1602803796
-SHA256 (moab-5.2.1.tar.gz) = e5f5b3dfb49e5182c69cadd67caf33708a9d54f9e97f21b641325f56e90f9939
-SIZE (moab-5.2.1.tar.gz) = 14226554
+TIMESTAMP = 1653069812
+SHA256 (moab-5.3.1.tar.gz) = 4471b7b0124b47dba8bd83891d8a595fc403e41ffa0da731a3330cf1eed47026
+SIZE (moab-5.3.1.tar.gz) = 17561771
diff --git a/math/moab/files/patch-CMakeLists.txt b/math/moab/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..32dc03a0a7bc
--- /dev/null
+++ b/math/moab/files/patch-CMakeLists.txt
@@ -0,0 +1,43 @@
+- workaround for https://bitbucket.org/fathomteam/moab/issues/148/530-cmake-error-at-cmake_installcmake-68
+
+--- CMakeLists.txt.orig 2021-11-12 00:54:52 UTC
++++ CMakeLists.txt
+@@ -618,7 +618,7 @@ endif(CLANG_TIDY_EXE)
+ CONFIGURE_FILE(config/MOABConfig.cmake.h.in "${PROJECT_BINARY_DIR}/src/moab/MOABConfig.h" @ONLY)
+
+ CONFIGURE_FILE(config/MOABConfig.cmake.cmake "${PROJECT_BINARY_DIR}/MOABConfig.cmake" @ONLY)
+-CONFIGURE_FILE(moab.make.cmake "${PROJECT_BINARY_DIR}/lib/moab.make" @ONLY)
++CONFIGURE_FILE(moab.make.cmake "lib/moab.make" @ONLY)
+ if ( MOAB_HAVE_FBIGEOM )
+ CONFIGURE_FILE(itaps/fbigeom/FBiGeom-Defs.inc.in "${PROJECT_BINARY_DIR}/lib/FBiGeom-Defs.inc" @ONLY)
+ install(
+@@ -636,23 +636,24 @@ if ( MOAB_HAVE_IMESH )
+ endif ( MOAB_HAVE_IMESH )
+ INSTALL(
+ FILES "${PROJECT_BINARY_DIR}/lib/moab.make"
+- DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ DESTINATION lib
+ )
++message(STATUS "YURI DESTDIR=${FREEBSD_STAGEDIR}")
+ INSTALL(
+ CODE
+- "file(APPEND ${CMAKE_INSTALL_FULL_LIBDIR}/moab.make MOAB_LIBDIR=${CMAKE_INSTALL_FULL_LIBDIR}\\n )"
++ "file(APPEND ${FREEBSD_STAGEDIR}${CMAKE_INSTALL_FULL_LIBDIR}/moab.make MOAB_LIBDIR=${CMAKE_INSTALL_FULL_LIBDIR}\\n )"
+ )
+ INSTALL(
+ CODE
+- "file(APPEND ${CMAKE_INSTALL_FULL_LIBDIR}/moab.make MOAB_INCLUDES=-I${CMAKE_INSTALL_FULL_INCLUDEDIR}\\n )"
++ "file(APPEND ${FREEBSD_STAGEDIR}${CMAKE_INSTALL_FULL_LIBDIR}/moab.make MOAB_INCLUDES=-I${CMAKE_INSTALL_FULL_INCLUDEDIR}\\n )"
+ )
+ INSTALL(
+ FILES "${PROJECT_BINARY_DIR}/MOABConfig.cmake"
+- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/MOAB/
++ DESTINATION lib/cmake/MOAB/
+ )
+ INSTALL(
+ FILES "${PROJECT_SOURCE_DIR}/config/ResolveCompilerPaths.cmake"
+- DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/MOAB
++ DESTINATION lib/cmake/MOAB
+ )
+
+ ADD_CUSTOM_TARGET(
diff --git a/math/moab/files/patch-src_io_WriteNCDF.cpp b/math/moab/files/patch-src_io_WriteNCDF.cpp
index 8c91cad073bb..bba6c59dcfd1 100644
--- a/math/moab/files/patch-src_io_WriteNCDF.cpp
+++ b/math/moab/files/patch-src_io_WriteNCDF.cpp
@@ -1,13 +1,15 @@
---- src/io/WriteNCDF.cpp.orig 2018-11-23 06:26:09 UTC
+- workaround for https://bitbucket.org/fathomteam/moab/issues/157/please-do-not-convert-null-to-char-this
+
+--- src/io/WriteNCDF.cpp.orig 2021-11-12 00:54:52 UTC
+++ src/io/WriteNCDF.cpp
-@@ -161,8 +161,8 @@ void WriteNCDF::time_and_date(char* time
- strftime(date_string, TIME_STR_LEN, "%m/%d/%Y", local_time);
+@@ -160,8 +160,8 @@ void WriteNCDF::time_and_date( char* time_string, char
+ strftime( date_string, TIME_STR_LEN, "%m/%d/%Y", local_time );
- // Terminate with NULL character
-- time_string[10] = (char)NULL;
-- date_string[10] = (char)NULL;
-+ time_string[10] = (char)0;
-+ date_string[10] = (char)0;
+ // Terminate with NULL character
+- time_string[10] = (char)NULL;
+- date_string[10] = (char)NULL;
++ time_string[10] = (char)0;
++ date_string[10] = (char)0;
}
- ErrorCode WriteNCDF::write_file(const char *exodus_file_name,
+ ErrorCode WriteNCDF::write_file( const char* exodus_file_name, const bool overwrite, const FileOptions& opts,
diff --git a/math/moab/pkg-plist b/math/moab/pkg-plist
index 8c20faa3342b..820d40b77a4d 100644
--- a/math/moab/pkg-plist
+++ b/math/moab/pkg-plist
@@ -4,6 +4,7 @@ bin/mbdepth
bin/mbgsets
bin/mbhonodes
bin/mbmem
+bin/mbmerge
bin/mbquality
bin/mbsize
bin/mbskin
@@ -11,6 +12,7 @@ bin/mbslavepart
bin/mbsurfplot
bin/mbtagprop
bin/mbumr
+bin/spheredecomp
%%MPI%%include/Coupler.hpp
%%MPI%%include/ElemUtil.hpp
include/MBCN.h
@@ -38,6 +40,8 @@ include/moab/CartVect.hpp
include/moab/Compiler.hpp
include/moab/Core.hpp
include/moab/CpuTimer.hpp
+include/moab/DiscreteGeometry/DGMSolver.hpp
+include/moab/DiscreteGeometry/HiReconstruction.hpp
include/moab/DualTool.hpp
include/moab/ElemEvaluator.hpp
include/moab/EntityHandle.hpp
@@ -76,10 +80,10 @@ include/moab/NestedRefine.hpp
include/moab/NestedRefineTemplates.hpp
include/moab/OrientedBox.hpp
include/moab/OrientedBoxTreeTool.hpp
-include/moab/ParCommGraph.hpp
%%MPI%%include/moab/ParallelComm.hpp
%%MPI%%include/moab/ParallelData.hpp
%%MPI%%include/moab/ParallelMergeMesh.hpp
+include/moab/PartitionerBase.hpp
%%MPI%%include/moab/ProcConfig.hpp
include/moab/ProgOptions.hpp
include/moab/Range.hpp
@@ -105,6 +109,7 @@ include/moab/WriteUtilIface.hpp
include/moab/WriterIface.hpp
%%MPI%%include/moab/gs.hpp
include/moab/iMOAB.h
+include/moab/imoab_protos.h
include/moab/mhdf_public.h
include/moab/point_locater/element_maps/linear_hex_map.hpp
include/moab/point_locater/element_maps/linear_tet_map.hpp
@@ -118,6 +123,8 @@ include/moab/point_locater/tree/common_tree.hpp
include/moab/point_locater/tree/element_tree.hpp
include/moab/verdict.h
include/moab/verdict/VerdictWrapper.hpp
+include/moab/win32_config.h
+include/moab_export.h
%%MPI%%include/moab_mpi.h
%%MPI%%include/moab_mpi_config.h
lib/cmake/MOAB/MOABConfig.cmake
@@ -127,9 +134,11 @@ lib/cmake/MOAB/ResolveCompilerPaths.cmake
lib/iMesh-Defs.inc
lib/libMOAB.so
lib/libMOAB.so.5
-lib/libMOAB.so.5.1.0
+lib/libMOAB.so.5.3.1
lib/libiMesh.so
lib/libiMesh.so.5
-lib/libiMesh.so.5.1.0
+lib/libiMesh.so.5.3.1
%%MPI%%lib/libmbcoupler.so
lib/moab.make
+libdata/pkgconfig/MOAB.pc
+share/man/man1/mbconvert.1.gz