aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2009-04-23 17:06:44 +0000
committerJohan van Selst <johans@FreeBSD.org>2009-04-23 17:06:44 +0000
commitd1d269d44145ecc026b3c81459e0652fcd6844fe (patch)
tree307678e1eb236b7de14d1eaedcbb0b6aa8e0a69d
parent271ee243cdd9b79bd45a24daca5bbc0778dbd9f3 (diff)
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/libdmtx/Makefile25
-rw-r--r--graphics/libdmtx/distinfo3
-rw-r--r--graphics/libdmtx/pkg-descr17
-rw-r--r--graphics/libdmtx/pkg-plist8
5 files changed, 54 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index c8aada4f00ab..168fbbb90cde 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -396,6 +396,7 @@
SUBDIR += libboard
SUBDIR += libcaca
SUBDIR += libdrm
+ SUBDIR += libdmtx
SUBDIR += libemf
SUBDIR += libexif
SUBDIR += libexif-gtk
diff --git a/graphics/libdmtx/Makefile b/graphics/libdmtx/Makefile
new file mode 100644
index 000000000000..6b6fc7f2d030
--- /dev/null
+++ b/graphics/libdmtx/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libdmtx
+# Date created: 16 April 2009
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdmtx
+PORTVERSION= 0.7.0
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= johans@stack.nl
+COMMENT= Software for reading and writing Data Matrix barcodes
+
+LIB_DEPENDS= MagickWand.2:${PORTSDIR}/graphics/ImageMagick
+
+MAN1= dmtxread.1 dmtxwrite.1 dmtxquery.1
+MAN3= libdmtx.3
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/libdmtx/distinfo b/graphics/libdmtx/distinfo
new file mode 100644
index 000000000000..0c204f0d268d
--- /dev/null
+++ b/graphics/libdmtx/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdmtx-0.7.0.tar.bz2) = 1423cd0c190817e7e8c28802d8d1f4d9
+SHA256 (libdmtx-0.7.0.tar.bz2) = 4255c57e7415ca223bbdae3c7ca03721f4c091db6817a4110b0a63beeebe8003
+SIZE (libdmtx-0.7.0.tar.bz2) = 1152170
diff --git a/graphics/libdmtx/pkg-descr b/graphics/libdmtx/pkg-descr
new file mode 100644
index 000000000000..b07a84715fc5
--- /dev/null
+++ b/graphics/libdmtx/pkg-descr
@@ -0,0 +1,17 @@
+libdmtx - software for reading and writing Data Matrix barcodes
+
+libdmtx is open source software for reading and writing Data Matrix
+barcodes on Linux, Unix, OS X, Windows, and certain mobile devices. At
+its core libdmtx is a shared library, allowing C/C++ programs to use its
+capabilities without restrictions or overhead. The included utility
+programs, dmtxread and dmtxwrite, serve as the official interface to
+libdmtx from the command line, and also provide a good reference for
+programmers who wish to write their own programs that interact with
+libdmtx.
+
+Data Matrix barcodes are two-dimensional symbols that hold a dense
+pattern of data with built-in error correction. The Data Matrix
+symbology (sometimes casually referred to as "DataMatrix") was invented
+and released into the public domain by RVSI Acuity CiMatrix.
+
+WWW: http://www.libdmtx.org/
diff --git a/graphics/libdmtx/pkg-plist b/graphics/libdmtx/pkg-plist
new file mode 100644
index 000000000000..8ec62c24aef0
--- /dev/null
+++ b/graphics/libdmtx/pkg-plist
@@ -0,0 +1,8 @@
+bin/dmtxquery
+bin/dmtxread
+bin/dmtxwrite
+include/dmtx.h
+lib/libdmtx.so
+lib/libdmtx.so.0
+lib/libdmtx.la
+lib/libdmtx.a