aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2012-04-19 15:00:56 +0000
committerCy Schubert <cy@FreeBSD.org>2012-04-19 15:00:56 +0000
commitd24d703110b3a77e2c09488feafecf53e2c1dd86 (patch)
tree1b9e8a468acd7220a1f9e1ae906226cadc1f65e6
parent7d350400c40a6f0e2368140c3c582a1dc33f48b9 (diff)
downloadports-d24d703110b3a77e2c09488feafecf53e2c1dd86.tar.gz
ports-d24d703110b3a77e2c09488feafecf53e2c1dd86.zip
Notes
-rw-r--r--sysutils/cfengine3-legacy/Makefile11
-rw-r--r--sysutils/cfengine3/Makefile11
2 files changed, 8 insertions, 14 deletions
diff --git a/sysutils/cfengine3-legacy/Makefile b/sysutils/cfengine3-legacy/Makefile
index f14e892a59fc..7212ce1c5f81 100644
--- a/sysutils/cfengine3-legacy/Makefile
+++ b/sysutils/cfengine3-legacy/Makefile
@@ -28,10 +28,12 @@ DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--htmldir=${DOCSDIR}/html \
--mandir=${PREFIX}/man \
+ --with-pcre=${LOCALBASE} \
--enable-fhs
-OPTIONS= PCRE "Enable Perl-compatible regular expressions" on \
- TOKYOCABINET "Enable TokyoCabinet support" on \
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+
+OPTIONS= TOKYOCABINET "Enable TokyoCabinet support" on \
QDBM "Enable QDBM support" off \
PGSQL "Enable PostgreSQL connector" off \
MYSQL "Enable MySQL connector" off
@@ -46,11 +48,6 @@ BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
BROKEN= TOKYOCABINET or QDBM must be defined
.endif
-.if defined(WITH_PCRE)
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
-CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
-.endif
-
.if defined(WITH_TOKYOCABINET)
CONFIGURE_ARGS+= --with-tokyocabinet=${LOCALBASE}
LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet
diff --git a/sysutils/cfengine3/Makefile b/sysutils/cfengine3/Makefile
index f14e892a59fc..7212ce1c5f81 100644
--- a/sysutils/cfengine3/Makefile
+++ b/sysutils/cfengine3/Makefile
@@ -28,10 +28,12 @@ DOCSDIR= ${PREFIX}/share/doc/cfengine
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--htmldir=${DOCSDIR}/html \
--mandir=${PREFIX}/man \
+ --with-pcre=${LOCALBASE} \
--enable-fhs
-OPTIONS= PCRE "Enable Perl-compatible regular expressions" on \
- TOKYOCABINET "Enable TokyoCabinet support" on \
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+
+OPTIONS= TOKYOCABINET "Enable TokyoCabinet support" on \
QDBM "Enable QDBM support" off \
PGSQL "Enable PostgreSQL connector" off \
MYSQL "Enable MySQL connector" off
@@ -46,11 +48,6 @@ BROKEN= TOKYOCABINET and QDBM are mutuallly exclusive
BROKEN= TOKYOCABINET or QDBM must be defined
.endif
-.if defined(WITH_PCRE)
-LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
-CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
-.endif
-
.if defined(WITH_TOKYOCABINET)
CONFIGURE_ARGS+= --with-tokyocabinet=${LOCALBASE}
LIB_DEPENDS+= tokyocabinet.9:${PORTSDIR}/databases/tokyocabinet