aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Hibbits <jhibbits@FreeBSD.org>2018-01-10 03:51:12 +0000
committerJustin Hibbits <jhibbits@FreeBSD.org>2018-01-10 03:51:12 +0000
commitd2ac3fee9c894bb6f10ab489a4b165f974fc1b03 (patch)
treee13cc3f904795bbe7a6dacae4aa13cd171a89fc2
parent7059d3ac07195518b2f7f78082f640d8c8f2430c (diff)
Notes
-rw-r--r--lang/luajit/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index 68ba24986a40..940f05536427 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -14,11 +14,16 @@ COMMENT= Just-In-Time Compiler for Lua
WRKSRC= ${WRKDIR}/LuaJIT-${DISTVERSION}
USES= gmake
USE_LDCONFIG= yes
+MAKE_ARGS= CC=${CC}
PLIST_SUB+= VERSION=${DISTVERSION}
+BROKEN_powerpc64= Not ported to powerpc64 upstream
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
-ONLY_FOR_ARCHS_REASON= Requires newer gcc/clang to compile.
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*} || ${ARCH:Mmips*} || ${ARCH:Msparc*}
+USE_GCC=yes
+.endif
post-install:
${LN} -sf ${PORTNAME}-${DISTVERSION} \