aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Lehey <grog@FreeBSD.org>2019-04-07 05:52:50 +0000
committerGreg Lehey <grog@FreeBSD.org>2019-04-07 05:52:50 +0000
commitd32182965978a28acaa52b2deeb0afb77ce6256a (patch)
tree9d2e53010e5a1c3db77b261392b47982de78ffee
parentc1ddf9643f8dabd03b36c100b818a2818651e35d (diff)
downloadports-d32182965978a28acaa52b2deeb0afb77ce6256a.tar.gz
ports-d32182965978a28acaa52b2deeb0afb77ce6256a.zip
Notes
-rw-r--r--graphics/enblend/Makefile23
-rw-r--r--graphics/enblend/distinfo5
-rw-r--r--graphics/enblend/files/patch-include_vigra__ext_impexalpha.hxx57
-rw-r--r--graphics/enblend/files/patch-src_filespec.cc40
4 files changed, 12 insertions, 113 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index 0c6260eecae8..31dc02c9971f 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= enblend
-PORTVERSION= 4.1.4
-PORTREVISION= 23
+PORTVERSION= 4.2
CATEGORIES= graphics
-MASTER_SITES= SF/enblend/enblend-enfuse/enblend-enfuse-${PORTVERSION:R}
+MASTER_SITES= SF/enblend/enblend-enfuse/enblend-enfuse-${PORTVERSION}
DISTNAME= enblend-enfuse-${PORTVERSION}
MAINTAINER= grog@FreeBSD.org
@@ -14,25 +13,21 @@ COMMENT= Tool for image blending with multiresolution splines
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: libvigraimpex is required to compile Enblend
+
BUILD_DEPENDS= help2man:misc/help2man \
- openexr>=1.0:graphics/openexr
+ ${LOCALBASE}/include/boost/version.hpp:devel/boost-libs
LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libtiff.so:graphics/tiff \
- libboost_filesystem.so:devel/boost-libs \
libvigraimpex.so:graphics/vigra \
libgsl.so:math/gsl \
+ libIlmImf.so:graphics/openexr \
libpng.so:graphics/png
-RUN_DEPENDS= openexr>=1.0:graphics/openexr
-
-BROKEN_powerpc64= fails to configure: libvigraimpex is required to compile Enblend
-USES= compiler:features gmake jpeg localbase makeinfo
-CONFIGURE_ARGS= --with-boost-filesystem
+USES= compiler:features gmake jpeg localbase pkgconfig
-USE_GL= glew glut
GNU_CONFIGURE= yes
-INFO= enfuse enblend
PLIST_FILES= bin/enblend bin/enfuse man/man1/enblend.1.gz man/man1/enfuse.1.gz
PORTDOCS= AUTHORS NEWS README
@@ -49,8 +44,8 @@ USE_GCC= yes
CXXFLAGS+= -Wno-c++11-extensions
.endif
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/doc/*.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+post-patch:
+ @${REINPLACE_CMD} -e '/a LaTeX/d' ${WRKSRC}/configure
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/enblend/distinfo b/graphics/enblend/distinfo
index 1a9ae9048c8a..e8cc95041fdd 100644
--- a/graphics/enblend/distinfo
+++ b/graphics/enblend/distinfo
@@ -1,2 +1,3 @@
-SHA256 (enblend-enfuse-4.1.4.tar.gz) = 85f6c3506065c05425631d45677a3d84a9c6f31c501a5fa9c730891003e80808
-SIZE (enblend-enfuse-4.1.4.tar.gz) = 881787
+TIMESTAMP = 1551167762
+SHA256 (enblend-enfuse-4.2.tar.gz) = 8703e324939ebd70d76afd350e56800f5ea2c053a040a5f5218b2a1a4300bd48
+SIZE (enblend-enfuse-4.2.tar.gz) = 777747
diff --git a/graphics/enblend/files/patch-include_vigra__ext_impexalpha.hxx b/graphics/enblend/files/patch-include_vigra__ext_impexalpha.hxx
deleted file mode 100644
index b42521771007..000000000000
--- a/graphics/enblend/files/patch-include_vigra__ext_impexalpha.hxx
+++ /dev/null
@@ -1,57 +0,0 @@
-# HG changeset patch
-# User Chris <cspiel@users.sourceforge.net>
-# Date 1453651551 -3600
-# Node ID 467a73754dbb0e269f1b515bc2ef6664ab328bfa
-# Parent 6aec0cc8d22a6fa617f983e676df68d75ffabbcf
-Fix issue #1537368: Unconditional usage of std::auto_ptr<>
-in "vigra_ext" code.
-
-diff -r 6aec0cc8d22a -r 467a73754dbb include/vigra_ext/impexalpha.hxx
---- include/vigra_ext/impexalpha.hxx.orig 2015-08-07 14:45:05 UTC
-+++ include/vigra_ext/impexalpha.hxx
-@@ -26,6 +26,9 @@
- #include <vigra/imageinfo.hxx>
- #include <vigra/impex.hxx>
-
-+#ifndef VIGRA_UNIQUE_PTR
-+#define VIGRA_UNIQUE_PTR std::auto_ptr
-+#endif
-
- namespace vigra_ext
- {
-@@ -194,7 +197,7 @@ namespace vigra_ext
- AlphaIterator alpha_iterator, AlphaAccessor alpha_accessor,
- vigra::VigraTrueType)
- {
-- std::auto_ptr<vigra::Decoder> decoder(vigra::decoder(import_info));
-+ VIGRA_UNIQUE_PTR<vigra::Decoder> decoder(vigra::decoder(import_info));
-
- switch (pixel_t_of_string(decoder->getPixelType()))
- {
-@@ -249,7 +252,7 @@ namespace vigra_ext
- AlphaIterator alpha_iterator, AlphaAccessor alpha_accessor,
- vigra::VigraFalseType)
- {
-- std::auto_ptr<vigra::Decoder> decoder(vigra::decoder(import_info));
-+ VIGRA_UNIQUE_PTR<vigra::Decoder> decoder(vigra::decoder(import_info));
-
- switch (pixel_t_of_string(decoder->getPixelType()))
- {
-@@ -467,7 +470,7 @@ namespace vigra_ext
- vigra::VigraTrueType)
- {
- const std::string pixel_type(export_info.getPixelType());
-- std::auto_ptr<vigra::Encoder> encoder(vigra::encoder(export_info));
-+ VIGRA_UNIQUE_PTR<vigra::Encoder> encoder(vigra::encoder(export_info));
-
- encoder->setPixelType(pixel_type);
-
-@@ -525,7 +528,7 @@ namespace vigra_ext
- vigra::VigraFalseType)
- {
- const std::string pixel_type(export_info.getPixelType());
-- std::auto_ptr<vigra::Encoder> encoder(vigra::encoder(export_info));
-+ VIGRA_UNIQUE_PTR<vigra::Encoder> encoder(vigra::encoder(export_info));
-
- encoder->setPixelType(pixel_type);
-
diff --git a/graphics/enblend/files/patch-src_filespec.cc b/graphics/enblend/files/patch-src_filespec.cc
deleted file mode 100644
index 1992187bfc72..000000000000
--- a/graphics/enblend/files/patch-src_filespec.cc
+++ /dev/null
@@ -1,40 +0,0 @@
-# HG changeset patch
-# User Chris <cspiel@users.sourceforge.net>
-# Date 1455528030 -3600
-# Node ID 73e6f16de80a94175db61f82ad10d4cd96790e85
-# Parent 596efbff27a8271a4c20184163e72b5914e334bf
-Fix issue #1537368 (additional patch): Get rid of `boost::assign::map_list_of'.
-
-diff -r 596efbff27a8 -r 73e6f16de80a src/filespec.cc
---- src/filespec.cc.orig 2015-08-07 14:45:02 UTC
-+++ src/filespec.cc
-@@ -37,7 +37,6 @@
- #include <cctype>
-
- #include <boost/algorithm/string/case_conv.hpp>
--#include <boost/assign/list_of.hpp>
-
- #include <vigra/imageinfo.hxx>
-
-@@ -412,17 +411,12 @@ class Globbing
- public:
- Globbing() : algorithm_name_("literal"), algorithm_(NULL)
- {
-- installed_algorithms_ =
-- boost::assign::map_list_of
-- ("literal", MAKE_ALGORITHM(new LiteralGlobbingAlgorithm))
-- ("wildcard", MAKE_ALGORITHM(new WildcardGlobbingAlgorithm))
--#ifndef _WIN32
-- ("shell", MAKE_ALGORITHM(new ShellGlobbingAlgorithm))
--#endif
-- ;
--
-+ installed_algorithms_["literal"] = MAKE_ALGORITHM(new LiteralGlobbingAlgorithm);
-+ installed_algorithms_["wildcard"] = MAKE_ALGORITHM(new WildcardGlobbingAlgorithm);
- setup_alias("literal", "none");
-+
- #ifndef _WIN32
-+ installed_algorithms_["shell"] = MAKE_ALGORITHM(new ShellGlobbingAlgorithm);
- setup_alias("shell", "sh");
- #endif
- }