aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-12-20 05:18:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-12-20 05:18:17 +0000
commitd419cf37c4938fc3ecc2a5b0a35f7f9afc9d0c56 (patch)
tree893f7c26679afe0328132ed9169c4ca391c04961
parent8938e155bd0757664bc2a8b9fc25d8cdbd47b2aa (diff)
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/cpuid2cpuflags/Makefile28
-rw-r--r--sysutils/cpuid2cpuflags/distinfo3
-rw-r--r--sysutils/cpuid2cpuflags/pkg-descr15
4 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b02e0447273d..7d2bda7b76bd 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -204,6 +204,7 @@
SUBDIR += cpu-x
SUBDIR += cpuburn
SUBDIR += cpuid
+ SUBDIR += cpuid2cpuflags
SUBDIR += cpulimit
SUBDIR += cpupdate
SUBDIR += cramfs
diff --git a/sysutils/cpuid2cpuflags/Makefile b/sysutils/cpuid2cpuflags/Makefile
new file mode 100644
index 000000000000..7544a13fed23
--- /dev/null
+++ b/sysutils/cpuid2cpuflags/Makefile
@@ -0,0 +1,28 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cpuid2cpuflags
+PORTVERSION= 8
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Tool to generate CPU_FLAGS_* for your CPU
+
+LICENSE= BSD2CLAUSE
+
+USES= autoreconf
+USE_GITHUB= yes
+GH_ACCOUNT= mgorny
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/cpuid2cpuflags/distinfo b/sysutils/cpuid2cpuflags/distinfo
new file mode 100644
index 000000000000..98d8735337bc
--- /dev/null
+++ b/sysutils/cpuid2cpuflags/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568752858
+SHA256 (mgorny-cpuid2cpuflags-v8_GH0.tar.gz) = c768a3a8e8028b35e9695fceef2cdbc9f8c5e2dcfd43349d9326884fb25d1faf
+SIZE (mgorny-cpuid2cpuflags-v8_GH0.tar.gz) = 10065
diff --git a/sysutils/cpuid2cpuflags/pkg-descr b/sysutils/cpuid2cpuflags/pkg-descr
new file mode 100644
index 000000000000..2f344c208957
--- /dev/null
+++ b/sysutils/cpuid2cpuflags/pkg-descr
@@ -0,0 +1,15 @@
+The program attempts to obtain the identification and capabilities
+of the currently used CPU, and print the matching set of CPU_FLAGS_*
+flags for Gentoo Linux, but it could be useful for FreeBSD as well.
+
+The output format is compatible both with Portage (package.use) and
+Paludis (use.conf/options.conf).
+
+On x86 platforms, the program issues the CPUID instruction to obtain
+processor capabilities.
+
+On ARM platforms, the userspace processes are not allowed to obtain
+processor information directly. Instead, the program is relying on
+kernel identification of the CPU provided via the system interfaces.
+
+WWW: https://github.com/mgorny/cpuid2cpuflags