aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-01-03 09:55:22 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-01-03 13:58:07 +0000
commitd4a2cc3cca9e7f618cc55b1b9db0eb97cd41e8b2 (patch)
tree64c19ec8f3399b02a93c5987bfa6532026b9d11d
parent84b4a1778c4e021f47f11c2b62dd681da8c4bb31 (diff)
downloadports-d4a2cc3cca9e7f618cc55b1b9db0eb97cd41e8b2.tar.gz
ports-d4a2cc3cca9e7f618cc55b1b9db0eb97cd41e8b2.zip
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-redis-namespace110/Makefile22
-rw-r--r--databases/rubygem-redis-namespace110/distinfo3
-rw-r--r--databases/rubygem-redis-namespace110/pkg-descr3
-rw-r--r--devel/Makefile2
-rw-r--r--devel/rubygem-gitlab-sdk/Makefile21
-rw-r--r--devel/rubygem-gitlab-sdk/distinfo3
-rw-r--r--devel/rubygem-gitlab-sdk/pkg-descr1
-rw-r--r--devel/rubygem-sidekiq-cron-rails70/Makefile22
-rw-r--r--devel/rubygem-sidekiq-cron-rails70/distinfo3
-rw-r--r--devel/rubygem-sidekiq-cron-rails70/pkg-descr9
11 files changed, 90 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7b2c7f7e04a1..70340ca09254 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -988,6 +988,7 @@
SUBDIR += rubygem-redis-cluster-client
SUBDIR += rubygem-redis-clustering
SUBDIR += rubygem-redis-namespace
+ SUBDIR += rubygem-redis-namespace110
SUBDIR += rubygem-redis-namespace19
SUBDIR += rubygem-redis4
SUBDIR += rubygem-scenic61
diff --git a/databases/rubygem-redis-namespace110/Makefile b/databases/rubygem-redis-namespace110/Makefile
new file mode 100644
index 000000000000..0aca292d3ab9
--- /dev/null
+++ b/databases/rubygem-redis-namespace110/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= redis-namespace
+PORTVERSION= 1.10.0
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 110
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby client class for Redis with namespace support
+WWW= https://github.com/resque/redis-namespace
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-redis>=4:databases/rubygem-redis
+
+USES= gem
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^1\.10\.
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-redis-namespace110/distinfo b/databases/rubygem-redis-namespace110/distinfo
new file mode 100644
index 000000000000..7d1bd17eab1c
--- /dev/null
+++ b/databases/rubygem-redis-namespace110/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703587662
+SHA256 (rubygem/redis-namespace-1.10.0.gem) = 2c1c6ea7c6c5e343e75b9bee3aa4c265e364a5b9966507397467af2bb3758d94
+SIZE (rubygem/redis-namespace-1.10.0.gem) = 19456
diff --git a/databases/rubygem-redis-namespace110/pkg-descr b/databases/rubygem-redis-namespace110/pkg-descr
new file mode 100644
index 000000000000..017c90780e16
--- /dev/null
+++ b/databases/rubygem-redis-namespace110/pkg-descr
@@ -0,0 +1,3 @@
+Adds a Redis::Namespace class which can be used to namespace calls to Redis.
+This is useful when using a single instance of Redis with multiple, different
+applications.
diff --git a/devel/Makefile b/devel/Makefile
index e3705ef46ff8..2b5f45834bd5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6916,6 +6916,7 @@
SUBDIR += rubygem-gitlab-labkit
SUBDIR += rubygem-gitlab-license
SUBDIR += rubygem-gitlab-pygments.rb
+ SUBDIR += rubygem-gitlab-sdk
SUBDIR += rubygem-gitlab_chronic_duration
SUBDIR += rubygem-gitlab_git
SUBDIR += rubygem-gitlab_meta
@@ -7382,6 +7383,7 @@
SUBDIR += rubygem-sidekiq
SUBDIR += rubygem-sidekiq-bulk
SUBDIR += rubygem-sidekiq-cron
+ SUBDIR += rubygem-sidekiq-cron-rails70
SUBDIR += rubygem-sidekiq-cron18
SUBDIR += rubygem-sidekiq-scheduler
SUBDIR += rubygem-sidekiq-unique-jobs
diff --git a/devel/rubygem-gitlab-sdk/Makefile b/devel/rubygem-gitlab-sdk/Makefile
new file mode 100644
index 000000000000..0771e4c5f5cb
--- /dev/null
+++ b/devel/rubygem-gitlab-sdk/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= gitlab-sdk
+PORTVERSION= 0.2.5
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= Client side Ruby SDK for GitLab Application services
+WWW= https://gitlab.com/gitlab-org/analytics-section/product-analytics/gl-application-sdk-rb
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-activesupport70>=3.0:devel/rubygem-activesupport70 \
+ rubygem-rake>=13.0<14:devel/rubygem-rake \
+ rubygem-snowplow-tracker>=0.8.0<0.9:devel/rubygem-snowplow-tracker
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-gitlab-sdk/distinfo b/devel/rubygem-gitlab-sdk/distinfo
new file mode 100644
index 000000000000..eac2b300c648
--- /dev/null
+++ b/devel/rubygem-gitlab-sdk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1703589193
+SHA256 (rubygem/gitlab-sdk-0.2.5.gem) = e2a7d088b9d5f4e2e07a2673104eada02171dfe987920885b40983437606cf57
+SIZE (rubygem/gitlab-sdk-0.2.5.gem) = 7680
diff --git a/devel/rubygem-gitlab-sdk/pkg-descr b/devel/rubygem-gitlab-sdk/pkg-descr
new file mode 100644
index 000000000000..8b3f4d878135
--- /dev/null
+++ b/devel/rubygem-gitlab-sdk/pkg-descr
@@ -0,0 +1 @@
+Client side Ruby SDK for GitLab Application services
diff --git a/devel/rubygem-sidekiq-cron-rails70/Makefile b/devel/rubygem-sidekiq-cron-rails70/Makefile
new file mode 100644
index 000000000000..545e641f4d30
--- /dev/null
+++ b/devel/rubygem-sidekiq-cron-rails70/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= sidekiq-cron
+PORTVERSION= 1.12.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails70
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Enables to set jobs to be run in specified time (using CRON notation)
+WWW= https://github.com/sidekiq-cron/sidekiq-cron
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-fugit>=1.8<2:devel/rubygem-fugit \
+ rubygem-globalid-rails70>=1.0.1:databases/rubygem-globalid-rails70 \
+ rubygem-sidekiq>=6:devel/rubygem-sidekiq
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-sidekiq-cron-rails70/distinfo b/devel/rubygem-sidekiq-cron-rails70/distinfo
new file mode 100644
index 000000000000..e1a55ac8baab
--- /dev/null
+++ b/devel/rubygem-sidekiq-cron-rails70/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1702543774
+SHA256 (rubygem/sidekiq-cron-1.12.0.gem) = 6663080a454088bd88773a0da3ae91e554b8a2e8b06cfc629529a83fd1a3096c
+SIZE (rubygem/sidekiq-cron-1.12.0.gem) = 23040
diff --git a/devel/rubygem-sidekiq-cron-rails70/pkg-descr b/devel/rubygem-sidekiq-cron-rails70/pkg-descr
new file mode 100644
index 000000000000..1763659ffead
--- /dev/null
+++ b/devel/rubygem-sidekiq-cron-rails70/pkg-descr
@@ -0,0 +1,9 @@
+Sidekiq-Cron is a scheduling add-on for Sidekiq.
+
+It runs a thread alongside Sidekiq workers to schedule jobs at specified times
+(using cron notation * * * * * parsed by Rufus-Scheduler).
+
+It also checks for new jobs to schedule every 10 seconds and doesn't schedule
+the same job multiple times when more than one Sidekiq worker is running.
+
+Scheduling jobs are added only when at least one Sidekiq process is running.