aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-05-18 10:15:44 +0000
commitd500c1cc50f23b0489994e29a3a20f32a3cb441d (patch)
tree7c1e12df7a7d8fba86936f85270c40cc1e388312
parent23e6a2b3da60fd03fb9e392af59450056c09f9a5 (diff)
downloadports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.tar.gz
ports-d500c1cc50f23b0489994e29a3a20f32a3cb441d.zip
Notes
-rw-r--r--audio/denemo/Makefile8
-rw-r--r--audio/extace/Makefile8
-rw-r--r--devel/arm-elf-gcc295/Makefile8
-rw-r--r--devel/libzvbi/Makefile4
-rw-r--r--devel/p5-Devel-Peek/Makefile8
-rw-r--r--devel/p5-File-Lock/Makefile8
-rw-r--r--editors/e93/Makefile8
-rw-r--r--editors/ved/Makefile8
-rw-r--r--games/acm/Makefile4
-rw-r--r--games/criticalmass/Makefile8
-rw-r--r--japanese/oleo/Makefile8
-rw-r--r--japanese/vfxdvi300/Makefile8
-rw-r--r--java/shujit/Makefile8
-rw-r--r--lang/gcc27/Makefile4
-rw-r--r--lang/ici/Makefile8
-rw-r--r--lang/nickle/Makefile8
-rw-r--r--math/oleo/Makefile8
-rw-r--r--multimedia/xmps/Makefile8
-rw-r--r--net-mgmt/sting/Makefile8
-rw-r--r--net/slirp/Makefile8
-rw-r--r--net/sting/Makefile8
-rw-r--r--net/tcpview/Makefile8
-rw-r--r--sysutils/xw/Makefile8
-rw-r--r--www/mod_geoip/Makefile8
-rw-r--r--www/p5-Apache-Peek/Makefile8
-rw-r--r--x11-toolkits/xview/Makefile8
26 files changed, 173 insertions, 23 deletions
diff --git a/audio/denemo/Makefile b/audio/denemo/Makefile
index 2ccfa92e1736..1175c1ea37b1 100644
--- a/audio/denemo/Makefile
+++ b/audio/denemo/Makefile
@@ -18,6 +18,12 @@ LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
intl.4:${PORTSDIR}/devel/gettext \
xml.5:${PORTSDIR}/textproc/libxml
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GNU_CONFIGURE= yes
PLIST= ${WRKDIR}/pkg-plist
SHARED= denemo.conf denemo.keymaprc english.keymaprc french.keymaprc
@@ -54,4 +60,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/extace/Makefile b/audio/extace/Makefile
index 4e4ec08b781d..d9e0fd052a77 100644
--- a/audio/extace/Makefile
+++ b/audio/extace/Makefile
@@ -16,6 +16,12 @@ COMMENT= An Audio Visualization plugin for the X Window System
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gtk12 imlib esound
USE_REINPLACE= yes
@@ -28,4 +34,4 @@ post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
-e "s|DATADIRNAME=lib|DATADIRNAME=share|g" ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/arm-elf-gcc295/Makefile b/devel/arm-elf-gcc295/Makefile
index 620436690891..8cbd63bbd777 100644
--- a/devel/arm-elf-gcc295/Makefile
+++ b/devel/arm-elf-gcc295/Makefile
@@ -24,6 +24,12 @@ BUILD_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
RUN_DEPENDS= ${PKGNAMEPREFIX}as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils \
${PKGNAMEPREFIX}ld:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GCC_REV= ${DISTNAME:S/gcc-//g}
PLIST_SUB+= GCC_REV=${GCC_REV}
USE_PERL5= yes
@@ -63,4 +69,4 @@ post-install:
${PREFIX}/${PKGNAMEPREFIX:S/-$//}/bin/g++
@${RM} ${PREFIX}/lib/libiberty.a
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libzvbi/Makefile b/devel/libzvbi/Makefile
index 10c815a0fced..138277cd59da 100644
--- a/devel/libzvbi/Makefile
+++ b/devel/libzvbi/Makefile
@@ -30,6 +30,10 @@ CONFIGURE_ENV= CC="$(CC) -I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib -L/usr
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
diff --git a/devel/p5-Devel-Peek/Makefile b/devel/p5-Devel-Peek/Makefile
index 2236265e07d7..e319bb6c0a2b 100644
--- a/devel/p5-Devel-Peek/Makefile
+++ b/devel/p5-Devel-Peek/Makefile
@@ -15,9 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= A perl5 data debugging tool for the XS programmer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Devel::Peek.3
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Lock/Makefile b/devel/p5-File-Lock/Makefile
index d5aa456e9011..b92ffdb882c5 100644
--- a/devel/p5-File-Lock/Makefile
+++ b/devel/p5-File-Lock/Makefile
@@ -15,6 +15,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Perl5 module for file locking (flock,fcntl)
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/e93/Makefile b/editors/e93/Makefile
index cea63ac3efa8..1611b98c2623 100644
--- a/editors/e93/Makefile
+++ b/editors/e93/Makefile
@@ -19,6 +19,12 @@ COMMENT= A nifty editor based on Tcl/Tk
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82 \
tk82.1:${PORTSDIR}/x11-toolkits/tk82
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
@@ -50,4 +56,4 @@ do-install:
${INSTALL_DATA} syntaxmaps/c.tcl ${PREFIX}/lib/e93lib/syntaxmaps; \
)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/editors/ved/Makefile b/editors/ved/Makefile
index 0b2b308220f1..eb40293e83f4 100644
--- a/editors/ved/Makefile
+++ b/editors/ved/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= ftp://ftp.fokus.gmd.de/pub/unix/ved/
MAINTAINER= greid@ukug.uk.freebsd.org
COMMENT= A small and fast screen-oriented editor.
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_GMAKE= yes
MAN1= ved.1
@@ -30,4 +36,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/ved/ved.1 ${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/ved/ved.help ${PREFIX}/share
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/acm/Makefile b/games/acm/Makefile
index 9d40ee72dcc7..be838f5bece4 100644
--- a/games/acm/Makefile
+++ b/games/acm/Makefile
@@ -19,6 +19,10 @@ MAN6= acm.6
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
# Include sound support (Use network audio server (nas))
.if defined(WITH_SOUND) || (exists(${PREFIX}/lib/libaudio.a) \
&& !defined(WITHOUT_SOUND))
diff --git a/games/criticalmass/Makefile b/games/criticalmass/Makefile
index 5b7cd60c61e9..64f7e74d2969 100644
--- a/games/criticalmass/Makefile
+++ b/games/criticalmass/Makefile
@@ -19,6 +19,12 @@ LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_BZIP2= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -32,4 +38,4 @@ post-patch:
${REINPLACE_CMD} -e 's#sdl-config#sdl11-config#; s#-lSDL # #;' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's#SDL/#SDL11/#;' ${SDLINCPFILES:S#^#${WRKSRC}/#}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/oleo/Makefile b/japanese/oleo/Makefile
index b5839e01047d..054c1f7b4e26 100644
--- a/japanese/oleo/Makefile
+++ b/japanese/oleo/Makefile
@@ -24,6 +24,12 @@ COMMENT= A Spreadsheet Program + Japanese patches
# xmkmf is for configure script, not for USE_IMAKE.
BUILD_DEPENDS= xmkmf:${PORTSDIR}/devel/imake-4
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
GNU_CONFIGURE=yes
@@ -35,4 +41,4 @@ post-install:
@${INSTALL_DATA} ${WRKDIR}/USING.eucJP ${PREFIX}/share/doc/oleo/ja_JP.EUC/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/vfxdvi300/Makefile b/japanese/vfxdvi300/Makefile
index 7daca4e561af..23361b266300 100644
--- a/japanese/vfxdvi300/Makefile
+++ b/japanese/vfxdvi300/Makefile
@@ -30,6 +30,12 @@ COMMENT= DVI Previewer for X. + Japanese patch + vector font support
LIB_DEPENDS= VFlib2.24:${PORTSDIR}/japanese/vflib
RUN_DEPENDS= ${LOCALBASE}/lib/fonts/pk${RESOLUTION}:${PORTSDIR}/print/pkfonts${RESOLUTION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
NO_WRKSUBDIR= yes
USE_IMAKE= yes
XMKMF= xmkmf
@@ -75,4 +81,4 @@ post-patch:
@(cd ${WRKDIR}; ${SH} ${FILESDIR}/customize.sh ${RESOLUTION})
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/java/shujit/Makefile b/java/shujit/Makefile
index d85bbfe77cdc..d3de2f7e3e27 100644
--- a/java/shujit/Makefile
+++ b/java/shujit/Makefile
@@ -15,6 +15,12 @@ COMMENT= A Just In Time java bytecode compiler
LIB_DEPENDS= gdbm:${PORTSDIR}/databases/gdbm
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}
ONLY_FOR_ARCHS= i386
@@ -42,4 +48,4 @@ post-install:
@${ENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/gcc27/Makefile b/lang/gcc27/Makefile
index d12d3432d3f4..e399f28dadf9 100644
--- a/lang/gcc27/Makefile
+++ b/lang/gcc27/Makefile
@@ -26,6 +26,10 @@ LATEST_LINK= gcc27
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GCC_VER= 2.7.2.3
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= GNUHOST=${CONFIGURE_TARGET} GCC_VER=${GCC_VER}
diff --git a/lang/ici/Makefile b/lang/ici/Makefile
index 9387b5bb2954..a675284f72a3 100644
--- a/lang/ici/Makefile
+++ b/lang/ici/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.zeta.org.au/~atrn/ici/distfiles/
MAINTAINER= atrn@zeta.org.au
COMMENT= An interpretive language with C's overall feel combined with high level data types
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
MAKEFILE= Makefile.bsd
MAN1= ici3.1
MANCOMPRESSED= yes
@@ -53,4 +59,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index a973154ac52e..ecaec8fb0e90 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -13,10 +13,16 @@ MASTER_SITES= http://www.nickle.org/release/
MAINTAINER= chrise@scardini.com
COMMENT= A desk calculator language
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= nickle.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index b19b75d46385..8496c57df252 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -19,6 +19,12 @@ BROKEN= "Does not compile"
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_REINPLACE= yes
USE_AUTOCONF_VER=213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -48,4 +54,4 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} \
${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/multimedia/xmps/Makefile b/multimedia/xmps/Makefile
index ac110808e944..aecf4dd34a6a 100644
--- a/multimedia/xmps/Makefile
+++ b/multimedia/xmps/Makefile
@@ -15,6 +15,12 @@ COMMENT= X MPEG Player System - a media player with a very nice GUI
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
@@ -35,4 +41,4 @@ post-configure:
@${REINPLACE_CMD} -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
${WRKSRC}/libtool
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/sting/Makefile b/net-mgmt/sting/Makefile
index b1258a0b3569..c806e7fccc55 100644
--- a/net-mgmt/sting/Makefile
+++ b/net-mgmt/sting/Makefile
@@ -14,6 +14,12 @@ DISTNAME= sting
MAINTAINER= kbyanc@posi.net
COMMENT= A tool that measures end-to-end TCP connection characteristics
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
do-install:
@@ -22,4 +28,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.sting
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/slirp/Makefile b/net/slirp/Makefile
index 9e36f77163e3..874a74712594 100644
--- a/net/slirp/Makefile
+++ b/net/slirp/Makefile
@@ -17,6 +17,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
COMMENT= A (C)SLIP/PPP emulator for users with shell accounts
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
# serious LP64 issues
ONLY_FOR_ARCHS= i386
@@ -31,4 +37,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/slirp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/slirp.man ${PREFIX}/man/man1/slirp.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/sting/Makefile b/net/sting/Makefile
index b1258a0b3569..c806e7fccc55 100644
--- a/net/sting/Makefile
+++ b/net/sting/Makefile
@@ -14,6 +14,12 @@ DISTNAME= sting
MAINTAINER= kbyanc@posi.net
COMMENT= A tool that measures end-to-end TCP connection characteristics
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
do-install:
@@ -22,4 +28,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.sting
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/tcpview/Makefile b/net/tcpview/Makefile
index edceb69a1fd1..632af7d9e037 100644
--- a/net/tcpview/Makefile
+++ b/net/tcpview/Makefile
@@ -14,6 +14,12 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= A Motif-based TCP/IP protocol analyzer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_BISON= yes
USE_MOTIF= yes
USE_REINPLACE= yes
@@ -28,4 +34,4 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/DOC/Tcpview ${X11BASE}/lib/X11/app-defaults/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/xw/Makefile b/sysutils/xw/Makefile
index 0e8f77617553..71d500bde5cb 100644
--- a/sysutils/xw/Makefile
+++ b/sysutils/xw/Makefile
@@ -13,9 +13,15 @@ MASTER_SITES= http://www.mavetju.org/download/adopted/
MAINTAINER= ports@FreeBSD.Org
COMMENT= X app to list current users logged into the system
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GTK_CONFIG=${X11BASE}/bin/gtk12-config
USE_GNOME= imlib
USE_X_PREFIX= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_geoip/Makefile b/www/mod_geoip/Makefile
index 3c9d88bf625c..50abbe5228b2 100644
--- a/www/mod_geoip/Makefile
+++ b/www/mod_geoip/Makefile
@@ -19,6 +19,12 @@ BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
RUN_DEPENDS= ${APXS}:${APACHE_PORT}
LIB_DEPENDS= GeoIP.3:${PORTSDIR}/net/GeoIP
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
APXS?= ${LOCALBASE}/sbin/apxs
APACHE_PORT?= ${PORTSDIR}/www/apache13
@@ -38,4 +44,4 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-Peek/Makefile b/www/p5-Apache-Peek/Makefile
index fdc9395ad2c8..e1f4cf392198 100644
--- a/www/p5-Apache-Peek/Makefile
+++ b/www/p5-Apache-Peek/Makefile
@@ -18,9 +18,15 @@ COMMENT= A perl5 data debugging tool for the XS programmer
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Apache/src.pm:${PORTSDIR}/www/mod_perl \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/B/Graph.pm:${PORTSDIR}/devel/p5-B-Graph
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
PERL_CONFIGURE= YES
MAN3= Apache::Peek.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/xview/Makefile b/x11-toolkits/xview/Makefile
index 38cecbcf8f9d..979d971704f1 100644
--- a/x11-toolkits/xview/Makefile
+++ b/x11-toolkits/xview/Makefile
@@ -18,6 +18,12 @@ DISTNAME= xview3.2p1-X11R6
MAINTAINER= ports@FreeBSD.org
COMMENT= X Window-System-based Visual/Integrated Environment for Workstations
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_IMAKE= yes
INSTALLS_SHLIB= yes
IMAKEINCLUDE= "-I${X11BASE}/lib/X11/config -I${WRKSRC}/config"
@@ -32,4 +38,4 @@ post-install:
@(cd $(WRKSRC); $(MAKE) -k 'SUBDIRS=doc' install)
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>