aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-05 22:33:16 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-05 22:33:16 +0000
commitd6072e733315f9ec2335f1ce9954cb96471cce29 (patch)
tree152455e644d38efc136ecbd36ce1c87546e83a39
parent77404df76554e636a22269311e6c1cd31ea0048d (diff)
downloadports-d6072e733315f9ec2335f1ce9954cb96471cce29.tar.gz
ports-d6072e733315f9ec2335f1ce9954cb96471cce29.zip
Notes
-rw-r--r--net/py-libdnet/Makefile16
-rw-r--r--net/py-libdnet/pkg-descr2
2 files changed, 13 insertions, 5 deletions
diff --git a/net/py-libdnet/Makefile b/net/py-libdnet/Makefile
index 736869671d92..01bf1965a1eb 100644
--- a/net/py-libdnet/Makefile
+++ b/net/py-libdnet/Makefile
@@ -8,17 +8,18 @@ COMMENT= Python module for libdnet
LIB_DEPENDS= libdnet.so:net/libdnet
+USES= autoreconf libtool python
+
MASTERDIR= ${.CURDIR}/../libdnet
INSTALL_WRKSRC= ${WRKSRC}/python
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${NONEXISTENT}
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/dnet.so \
- %%PYTHON_SITELIBDIR%%/dnet-${PORTVERSION}-py${PYTHON_VER}.egg-info
+PLIST_FILES= ${PYTHON_SITELIBDIR}/dnet.so \
+ ${PYTHON_SITELIBDIR}/dnet-${PORTVERSION}-py${PYTHON_VER}.egg-info
LIBDNET_SLAVE= yes
-USES= python:2.7
-USE_PYTHON= flavors
+USE_PYTHON= cython flavors
CONFIGURE_ARGS= --with-python=${PYTHON_CMD}
.if defined(MAINTAINER_MODE)
@@ -26,4 +27,11 @@ regression-test: install
${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
.endif
+post-patch:
+ ${REINPLACE_CMD} 's|%%CYTHON%%|cython-${PYTHON_VER}|g' \
+ ${WRKSRC}/python/Makefile.am
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/dnet.so
+
.include "${MASTERDIR}/Makefile"
diff --git a/net/py-libdnet/pkg-descr b/net/py-libdnet/pkg-descr
index ec06d83a38b9..b513c9f6ef59 100644
--- a/net/py-libdnet/pkg-descr
+++ b/net/py-libdnet/pkg-descr
@@ -5,4 +5,4 @@ manipulation, network firewalling, network interface lookup and
manipulation, and raw IP packet and Ethernet frame transmission. It is
intended to complement the functionality provided by pcap(3).
-WWW: https://code.google.com/p/libdnet/
+WWW: https://github.com/5u623l20/libdnet/