aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-23 19:43:54 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-23 19:43:54 +0000
commitd65be6ab5538cee61a9a800ba4289ef9fdfb6ef5 (patch)
tree97e21b304d309f172e31a32b344f87941a3c679c
parent20c08e16d1fca95c7037842328dbff6294e31bd4 (diff)
- Move commands from files/pkg-install.in into post-install
- Kill files/ PR: ports/187537 (second half) Submitted by: Johannes Jost Meixner <xmj@chaot.net>
Notes
Notes: svn path=/head/; revision=348883
-rw-r--r--java/linux-sun-jre17/Makefile10
-rw-r--r--java/linux-sun-jre17/files/pkg-install.in19
2 files changed, 5 insertions, 24 deletions
diff --git a/java/linux-sun-jre17/Makefile b/java/linux-sun-jre17/Makefile
index 2f80de05db44..947a1932b9e8 100644
--- a/java/linux-sun-jre17/Makefile
+++ b/java/linux-sun-jre17/Makefile
@@ -18,7 +18,6 @@ PKGNAMESUFFIX= 17
WRKSRC= ${WRKDIR}/jre${DL_JRE_VERSION}
PLIST_SUB+= T=${APP_HOME:S/^${PREFIX}\///} PORTVERSION=${PORTVERSION}
-PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
USE_LINUX= yes
@@ -59,9 +58,10 @@ do-install:
.endfor
post-install:
- @${SED} -e "s:%%JRE_HOME%%:${APP_HOME}:g; \
- s:%%STAGEDIR%%:${STAGEDIR}:g" \
- < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
- @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${MKDIR} ${STAGEDIR}${APP_HOME}/.systemPrefs
+ ${TOUCH} ${STAGEDIR}${APP_HOME}/.systemPrefs/.system.lock
+ ${TOUCH} ${STAGEDIR}${APP_HOME}/.systemPrefs/.systemRootModFile
+ ${CHMOD} 644 ${STAGEDIR}${APP_HOME}/.systemPrefs/.system.lock
+ ${CHMOD} 644 ${STAGEDIR}${APP_HOME}/.systemPrefs/.systemRootModFile
.include <bsd.port.post.mk>
diff --git a/java/linux-sun-jre17/files/pkg-install.in b/java/linux-sun-jre17/files/pkg-install.in
deleted file mode 100644
index ed297521cdca..000000000000
--- a/java/linux-sun-jre17/files/pkg-install.in
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-
-# System preference location
-PREFS_LOCATION=%%JRE_HOME%%
-
-# Set up system preferences during post install
-if [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs" ] ; then
- mkdir -m 755 "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs"
- fi
- if [ ! -f "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.system.lock" ] ; then
- touch "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.system.lock"
- chmod 644 "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.system.lock"
- fi
- if [ ! -f "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.systemRootModFile" ] ; then
- touch "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
- chmod 644 "%%STAGEDIR%%${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
- fi
-fi