aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-10-13 13:06:50 +0000
committerChris Rees <crees@FreeBSD.org>2013-10-13 13:06:50 +0000
commitd68e35bf70846d19a977e28677d0b27dbf913866 (patch)
tree6b353bf0743fb9176cd8844bb84d666748a20675
parent46888a73a164ed5da8f72ce811edd6afd72f01ec (diff)
downloadports-d68e35bf70846d19a977e28677d0b27dbf913866.tar.gz
ports-d68e35bf70846d19a977e28677d0b27dbf913866.zip
Notes
-rw-r--r--ports-mgmt/tinderbox/Makefile2
-rw-r--r--ports-mgmt/tinderbox/files/patch-chroot37
2 files changed, 17 insertions, 22 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index e6c50bd72d45..82d239a6336a 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tinderbox
PORTVERSION= 4.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
diff --git a/ports-mgmt/tinderbox/files/patch-chroot b/ports-mgmt/tinderbox/files/patch-chroot
index 063aa3f621f5..e70c7c954b27 100644
--- a/ports-mgmt/tinderbox/files/patch-chroot
+++ b/ports-mgmt/tinderbox/files/patch-chroot
@@ -363,6 +363,7 @@ diff -u -r1.176 tc_command.sh
}
addPortToBuild () {
+
? .fslckout
? .fslckout-mjFA3F63973
Index: lib/tc_command.sh
@@ -371,40 +372,34 @@ RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/lib/tc_command.sh,v
retrieving revision 1.177
diff -u -r1.177 tc_command.sh
--- lib/tc_command.sh 8 Oct 2013 16:06:48 -0000 1.177
-+++ lib/tc_command.sh 12 Oct 2013 11:27:28 -0000
-@@ -1973,6 +1973,8 @@
- # Need to do this in a subshell so as to only hide the host
- # environment during makefile creation
- (
-+ # Everything is done in chroot, so SRCBASE is relative to /
-+ export SRCBASE=/usr/src
- export PORTBUILD_ARGS="$(echo ${pbargs})"
- buildenvNoHost ${build}
- buildenv ${jail} ${portstree} ${build}
-@@ -2102,6 +2104,8 @@
- if [ -n "${SRCBASE}" ]; then
- save_SRCBASE=${SRCBASE}
- fi
-+ # Everything is done in chroot, so SRCBASE is relative to /
-+ export SRCBASE=/usr/src
++++ lib/tc_command.sh 13 Oct 2013 12:54:19 -0000
+@@ -1418,6 +1418,10 @@
+ # Finalize environment
+ cp /etc/resolv.conf ${BUILD_DIR}/etc || touch ${BUILD_DIR}/etc/resolv.conf
+
++ # This works around the SRCBASE issue... this needs fixing properly
++ mkdir -p ${BUILD_DIR}/${SRCBASE%/*}
++ ln -s ${BUILD_DIR}/usr/src ${BUILD_DIR}/${SRCBASE}
++
+ return 0
+ }
- buildenv ${jail} ${portsTree} ${build}
- buildenvNoHost ${build}
Index: lib/tinderlib.sh
===================================================================
RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/lib/tinderlib.sh,v
retrieving revision 1.85
diff -u -r1.85 tinderlib.sh
--- lib/tinderlib.sh 7 Oct 2013 16:36:54 -0000 1.85
-+++ lib/tinderlib.sh 12 Oct 2013 11:27:29 -0000
-@@ -506,7 +506,9 @@
++++ lib/tinderlib.sh 13 Oct 2013 12:54:19 -0000
+@@ -506,7 +506,10 @@
save_IFS=${IFS}
IFS='
'
- # Do not set SRCBASE here-- we use chroots nowadays so /usr/src is there
++
+ # Allow SRCBASE to be overridden
+ eval "export SRCBASE=${SRCBASE:-`realpath $(tinderLoc jail ${jail})/src`}" \
-+ >/dev/null 2>&1
++ >/dev/null 2>&1
# Set ARCH (needed for cross-building)
export ARCH=$(${tc} getJailArch -j ${jail})