aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Turner <andrew@FreeBSD.org>2021-07-02 09:01:35 +0000
committerAndrew Turner <andrew@FreeBSD.org>2021-07-29 20:03:05 +0000
commitd7df5341dbd50cc83a8bc292eab98d004677ccfd (patch)
treea906296f84573c792bd1bfbd726ad599ed7f684a
parent0b09769aacb58a1e6add6e29c9258780b14026b7 (diff)
downloadports-d7df5341dbd50cc83a8bc292eab98d004677ccfd.tar.gz
ports-d7df5341dbd50cc83a8bc292eab98d004677ccfd.zip
sysutils/edk2: Add fvp support
This is used on the Arm Models (simulators) Reviewed by: manu Approved by: manu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D31277
-rw-r--r--sysutils/edk2/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/edk2/Makefile b/sysutils/edk2/Makefile
index f63ffd7f3cf7..942ad4746e77 100644
--- a/sysutils/edk2/Makefile
+++ b/sysutils/edk2/Makefile
@@ -11,7 +11,7 @@ ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= This port only provides firmware for aarch64 and amd64 machine
PKGNAMESUFFIX= -${FLAVOR:C/_/-/g}
-FLAVORS= macchiatobin rpi3 rpi4 xen_x64
+FLAVORS= fvp macchiatobin rpi3 rpi4 xen_x64
FLAVOR?= macchiatobin
USES= gmake python:3.7+,build
@@ -41,6 +41,16 @@ BINARY_ALIAS= make=${LOCALBASE}/bin/gmake \
g++=${LOCALBASE}/bin/g++${GCC_DEFAULT} \
python3=${PYTHON_CMD} python=${PYTHON_CMD}
+.if ${FLAVOR} == fvp
+PLAT= fvp
+PLAT_ARCH= AARCH64
+PLAT_ARGS= -D X64EMU_ENABLE=FALSE -D CAPSULE_ENABLE=FALSE
+PLAT_TARGET= RELEASE
+PLATFILE= Platform/ARM/VExpressPkg/ArmVExpress-FVP-AArch64.dsc
+PLAT_RESULT= ArmVExpress-FVP-AArch64/${PLAT_TARGET}_GCC5/FV/FVP_AARCH64_EFI.fd
+PLAT_FILENAME= FVP_AARCH64_EFI.fd
+.endif
+
.if ${FLAVOR} == macchiatobin
PLAT= macchiatobin
PLAT_ARCH= AARCH64