aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-05-25 23:54:49 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-05-25 23:54:49 +0000
commitd85e3c566dfff95860d16db79e1a02e07aa746db (patch)
tree47f9cacddca0ce64496ce20cc2f12b8c168f22bf
parent21192ce9a469f0339a6e57a4fc011525e42c8613 (diff)
downloadports-d85e3c566dfff95860d16db79e1a02e07aa746db.tar.gz
ports-d85e3c566dfff95860d16db79e1a02e07aa746db.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/horde4-cache/Makefile43
-rw-r--r--devel/horde4-cache/distinfo2
-rw-r--r--devel/horde4-cache/files/pkg-message.in7
-rw-r--r--devel/horde4-cache/pkg-descr6
-rw-r--r--devel/horde4-cache/pkg-plist16
6 files changed, 75 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 90154b75104c..c9b658897360 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -553,6 +553,7 @@
SUBDIR += horde-chora
SUBDIR += horde-whups
SUBDIR += horde4-autoloader
+ SUBDIR += horde4-cache
SUBDIR += horde4-content
SUBDIR += horde4-date
SUBDIR += horde4-dateparser
diff --git a/devel/horde4-cache/Makefile b/devel/horde4-cache/Makefile
new file mode 100644
index 000000000000..19ea8ab8a9a5
--- /dev/null
+++ b/devel/horde4-cache/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: horde4-cache
+# Date created: Wed May 24, 2011
+# Whom: Beech Rintoul (<beech@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= cache
+PORTVERSION= 1.0.3
+DISTVERSIONPREFIX=
+DISTVERSIONSUFFIX=
+CATEGORIES= devel www
+MASTER_SITES= http://pear.horde.org/get/ \
+ LOCAL/beech
+PKGNAMEPREFIX= horde4-
+DISTNAME= Horde_Cache-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Horde caching API
+
+USE_HORDE= base
+USE_GETTEXT= yes
+CACHEDIR= Cache
+HORDIR= ${HORBAS}${CACHEDIR:S|^|/|:S|/horde||}
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/config && ${TOUCH} ${WRKSRC}/config/placeholder.dist
+
+do-install:
+ @${INSTALL} -d ${HORDIR}/
+ @${CP} ${WRKSRC}/lib/Horde/Cache.php ${HORBAS}/
+ @${CP} -Rp ${WRKSRC}/lib/Horde/Cache/ ${HORDIR}/
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
+
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
+.include <bsd.port.mk>
diff --git a/devel/horde4-cache/distinfo b/devel/horde4-cache/distinfo
new file mode 100644
index 000000000000..9a1f02b9adfc
--- /dev/null
+++ b/devel/horde4-cache/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde_Cache-1.0.3.tgz) = b85536eb4d13977917a80d9ebbb1e9c072d316b27efb164c62a28246ea5d8dfc
+SIZE (Horde_Cache-1.0.3.tgz) = 9812
diff --git a/devel/horde4-cache/files/pkg-message.in b/devel/horde4-cache/files/pkg-message.in
new file mode 100644
index 000000000000..411ae74495b3
--- /dev/null
+++ b/devel/horde4-cache/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+Alarm has been installed in %%HORDIR%%/.
+
+Horde must be configured and the tables created; if not, see
+`pkg_info -Dx horde-base'.
+
+************************************************************************
diff --git a/devel/horde4-cache/pkg-descr b/devel/horde4-cache/pkg-descr
new file mode 100644
index 000000000000..f770a03f4c25
--- /dev/null
+++ b/devel/horde4-cache/pkg-descr
@@ -0,0 +1,6 @@
+Horde cache provides a simple, functional caching API, with the option to store
+the cached data on the filesystem, in one of the PHP opcode cache systems (APC,
+eAcclerator, XCache, or Zend Performance Suite's content cache), memcached, or
+an SQL table.
+
+WWW: http://www.horde.org
diff --git a/devel/horde4-cache/pkg-plist b/devel/horde4-cache/pkg-plist
new file mode 100644
index 000000000000..44d8cb123fda
--- /dev/null
+++ b/devel/horde4-cache/pkg-plist
@@ -0,0 +1,16 @@
+%%HORBAS%%/Cache.php
+%%HORDIR%%/Exception.php
+%%HORDIR%%/Storage/Apc.php
+%%HORDIR%%/Storage/Base.php
+%%HORDIR%%/Storage/Eaccelerator.php
+%%HORDIR%%/Storage/File.php
+%%HORDIR%%/Storage/Memcache.php
+%%HORDIR%%/Storage/Mock.php
+%%HORDIR%%/Storage/Null.php
+%%HORDIR%%/Storage/Session.php
+%%HORDIR%%/Storage/Sql.php
+%%HORDIR%%/Storage/Stack.php
+%%HORDIR%%/Storage/Xcache.php
+@dirrm %%HORDIR%%/Storage
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%