aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEd Schouten <ed@FreeBSD.org>2010-06-28 09:07:31 +0000
committerEd Schouten <ed@FreeBSD.org>2010-06-28 09:07:31 +0000
commitd8ec3cf74ca7f2251cf69d8c76dd92ad5151e8cc (patch)
treed47767ae2d1423adbbbffb0a947e537b0bb79c9a
parentbe762f4e34e3eb5c5d95489e9d276f68546f14d7 (diff)
downloadports-d8ec3cf74ca7f2251cf69d8c76dd92ad5151e8cc.tar.gz
ports-d8ec3cf74ca7f2251cf69d8c76dd92ad5151e8cc.zip
Notes
-rw-r--r--cad/chipmunk/Makefile2
-rw-r--r--cad/chipmunk/files/patch-netcmp-main.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/cad/chipmunk/Makefile b/cad/chipmunk/Makefile
index 7d14ce300ee2..8f298e5c647f 100644
--- a/cad/chipmunk/Makefile
+++ b/cad/chipmunk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= chipmunk
PORTVERSION= 5.64
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad
MASTER_SITES= http://www.cs.berkeley.edu/~lazzaro/chipmunk/pickup/sources/
DISTFILES= psys-1.59.tar.gz log-5.64.tar.gz netcmp-1.13.tar.gz \
diff --git a/cad/chipmunk/files/patch-netcmp-main.c b/cad/chipmunk/files/patch-netcmp-main.c
new file mode 100644
index 000000000000..cb7c66aa3875
--- /dev/null
+++ b/cad/chipmunk/files/patch-netcmp-main.c
@@ -0,0 +1,19 @@
+--- netcmp/main.c
++++ netcmp/main.c
+@@ -122,16 +122,6 @@
+
+ outfyle = NULL;
+ while (outfyle == NULL) {
+- char username[100];
+- char *tmp;
+-
+-#if defined(freebsd)
+- getpwuid(getuid(), username);
+-#else
+- getpw(getuid(), username);
+-#endif
+- tmp = strchr(username,':');
+- if (tmp != NULL) *tmp = '\0';
+ printf(" Enter output file name [info]: ");
+ fgets(command, 81, stdin);
+ TEMP = strchr(command, '\n');