aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-19 07:57:21 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-19 07:57:21 +0000
commitdacf7b325a95a060f2a72e1c3051d02f01d47d0f (patch)
tree6d9bd6692544ef4d9334854722f4a0f0e7560618
parentcb37128c506a36a6cca5c5b3cc500ade93f039eb (diff)
downloadports-dacf7b325a95a060f2a72e1c3051d02f01d47d0f.tar.gz
ports-dacf7b325a95a060f2a72e1c3051d02f01d47d0f.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Filesys-Statvfs_Df/Makefile22
-rw-r--r--devel/p5-Filesys-Statvfs_Df/distinfo3
-rw-r--r--devel/p5-Filesys-Statvfs_Df/files/patch-Statvfs.xs90
-rw-r--r--devel/p5-Filesys-Statvfs_Df/pkg-descr15
-rw-r--r--devel/p5-Filesys-Statvfs_Df/pkg-plist9
6 files changed, 0 insertions, 140 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d6740a55891b..4f34f1f6222c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1012,7 +1012,6 @@
SUBDIR += p5-File-chdir
SUBDIR += p5-File-pushd
SUBDIR += p5-FileHandle-Unget
- SUBDIR += p5-Filesys-Statvfs_Df
SUBDIR += p5-Filesys-Virtual
SUBDIR += p5-Filesys-Virtual-Plain
SUBDIR += p5-Filter
diff --git a/devel/p5-Filesys-Statvfs_Df/Makefile b/devel/p5-Filesys-Statvfs_Df/Makefile
deleted file mode 100644
index a072e4ed8e3b..000000000000
--- a/devel/p5-Filesys-Statvfs_Df/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# New ports collection makefile for: p5-Filesys-Statvfs_Df
-# Date created: Feb 17 2004
-# Whom: Jim Pirzyk
-#
-# $FreeBSD$
-#
-
-PORTNAME= Filesys-Statvfs_Df
-PORTVERSION= 0.68
-CATEGORIES= devel perl5
-MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= Filesys
-PKGNAMEPREFIX= p5-
-
-MAINTAINER= pirzyk@freebsd.org
-COMMENT= Provides an interface between Perl and the statvfs() system call
-
-PERL_CONFIGURE= yes
-
-MAN3= Filesys::Df.3 Filesys::Statvfs.3
-
-.include <bsd.port.mk>
diff --git a/devel/p5-Filesys-Statvfs_Df/distinfo b/devel/p5-Filesys-Statvfs_Df/distinfo
deleted file mode 100644
index dcb105e44859..000000000000
--- a/devel/p5-Filesys-Statvfs_Df/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (Filesys-Statvfs_Df-0.68.tar.gz) = 8425476ff9de21513a0264faadca7d07
-SHA256 (Filesys-Statvfs_Df-0.68.tar.gz) = 0fa49c4c5530ffb951cbff1103eb68d4e9e36eaacbf150b0c3d609e026c226a3
-SIZE (Filesys-Statvfs_Df-0.68.tar.gz) = 6306
diff --git a/devel/p5-Filesys-Statvfs_Df/files/patch-Statvfs.xs b/devel/p5-Filesys-Statvfs_Df/files/patch-Statvfs.xs
deleted file mode 100644
index ae7b88187f74..000000000000
--- a/devel/p5-Filesys-Statvfs_Df/files/patch-Statvfs.xs
+++ /dev/null
@@ -1,90 +0,0 @@
---- Statvfs.xs.orig Wed Nov 22 09:57:31 2000
-+++ Statvfs.xs Tue Feb 17 10:13:35 2004
-@@ -5,12 +5,21 @@
- #include "perl.h"
- #include "XSUB.h"
- #include "config.h"
--#include<sys/statvfs.h>
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+#include <sys/param.h>
-+#include <sys/mount.h>
-+#else
-+#include <sys/statvfs.h>
-+#endif
- #ifdef __cplusplus
- }
- #endif
-
--typedef struct statvfs Statvfs;
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ typedef struct statfs Statvfs;
-+#else
-+ typedef struct statvfs Statvfs;
-+#endif
-
- MODULE = Filesys::Statvfs PACKAGE = Filesys::Statvfs
-
-@@ -20,34 +29,63 @@
- PREINIT:
- Statvfs st;
- Statvfs *st_ptr;
-+ long t;
- PPCODE:
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ if(statfs(dir, &st) == 0) {
-+#else
- if(statvfs(dir, &st) == 0) {
-+#endif
- st_ptr=&st;
- EXTEND(sp, 15);
- PUSHs(sv_2mortal(newSViv(st_ptr->f_bsize)));
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ PUSHs(sv_2mortal(newSViv(0)));
-+#else
- PUSHs(sv_2mortal(newSViv(st_ptr->f_frsize)));
-+#endif
- PUSHs(sv_2mortal(newSViv(st_ptr->f_blocks)));
- PUSHs(sv_2mortal(newSViv(st_ptr->f_bfree)));
- PUSHs(sv_2mortal(newSViv(st_ptr->f_bavail)));
- PUSHs(sv_2mortal(newSViv(st_ptr->f_files)));
- PUSHs(sv_2mortal(newSViv(st_ptr->f_ffree)));
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ PUSHs(sv_2mortal(newSViv(st_ptr->f_ffree)));
-+#else
- PUSHs(sv_2mortal(newSViv(st_ptr->f_favail)));
-+#endif
- #if defined(_AIX__) || defined(_LINUX__)
- PUSHs(sv_2mortal(newSViv(0)));
- #else
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ memcpy (&t, &st_ptr->f_fsid, sizeof (long));
-+ PUSHs(sv_2mortal(newSViv(t)));
-+#else
- PUSHs(sv_2mortal(newSViv(st_ptr->f_fsid)));
- #endif
-+#endif
- #ifdef _LINUX__
- PUSHs(sv_2mortal(newSVpv(NULL, 1)));
- #else
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ PUSHs(sv_2mortal(newSVpv(st_ptr->f_fstypename, 0)));
-+#else
- PUSHs(sv_2mortal(newSVpv(st_ptr->f_basetype, 0)));
- #endif
-+#endif
-+#if defined(__APPLE__ ) || defined(__FreeBSD__)
-+ PUSHs(sv_2mortal(newSViv(st_ptr->f_flags)));
-+ PUSHs(sv_2mortal(newSVpv(st_ptr->f_mntonname, MNAMELEN)));
-+#else
- PUSHs(sv_2mortal(newSViv(st_ptr->f_flag)));
- PUSHs(sv_2mortal(newSViv(st_ptr->f_namemax)));
-+#endif
- #if defined(_DEC__) || defined(_LINUX__)
- PUSHs(sv_2mortal(newSVpv(NULL, 1)));
- #else
-+#if ! defined(__APPLE__ ) && ! defined(__FreeBSD__)
- PUSHs(sv_2mortal(newSVpv(st_ptr->f_fstr, 0)));
-+#endif
- #endif
- #ifdef _HPUX__
- PUSHs(sv_2mortal(newSViv(st_ptr->f_size)));
diff --git a/devel/p5-Filesys-Statvfs_Df/pkg-descr b/devel/p5-Filesys-Statvfs_Df/pkg-descr
deleted file mode 100644
index d331ca1850dd..000000000000
--- a/devel/p5-Filesys-Statvfs_Df/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-Filesys::Statvfs provides an interface between
-Perl and the statvfs() system call.
-
-Filesys::Df uses Filesys::Statvfs to obtain
-filesystem statistics then creates additional
-filesystem information such as percent full,
-user and superuser differentials, etc.
-
-Filesys::Df will also let you specify the
-block size for the values you wish to see.
-The default block size output is 1024 bytes per
-block. So if you want to get the size in bytes
-just take the block size and * it by 1024.
-
-WWW: http://search.cpan.org/dist/Filesys-Statvfs_Statfs_Df/
diff --git a/devel/p5-Filesys-Statvfs_Df/pkg-plist b/devel/p5-Filesys-Statvfs_Df/pkg-plist
deleted file mode 100644
index d67816cfd381..000000000000
--- a/devel/p5-Filesys-Statvfs_Df/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/Filesys/Df.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Filesys/Statvfs.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs/Statvfs.so
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs/Statvfs.bs
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Filesys
-@dirrmtry %%SITE_PERL%%/Filesys