aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBartek Rutkowski <robak@FreeBSD.org>2014-08-15 15:56:52 +0000
committerBartek Rutkowski <robak@FreeBSD.org>2014-08-15 15:56:52 +0000
commitdbe944b71c574c6f523c46cb8031bf5091c0b59d (patch)
treea3b6c47458a21e3bb4fb60804c8c85a40057c67a
parent71a547866800b43fb26e9d75706a9c37490cae56 (diff)
downloadports-dbe944b71c574c6f523c46cb8031bf5091c0b59d.tar.gz
ports-dbe944b71c574c6f523c46cb8031bf5091c0b59d.zip
ysutils/mcollective-shell-agent: NEW PORT - officiall MCollective Shell plugin
Submitted by: Bartek Rutkowski <robak@FreeBSD.org> Approved by: swills (mentor)
Notes
Notes: svn path=/head/; revision=364984
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/mcollective-shell-agent/Makefile35
-rw-r--r--sysutils/mcollective-shell-agent/distinfo2
-rw-r--r--sysutils/mcollective-shell-agent/files/patch-lib-mcollective-agent-shell-job.rb9
-rw-r--r--sysutils/mcollective-shell-agent/pkg-descr8
5 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5de0b725b5db..dbd8666fe0c8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -504,6 +504,7 @@
SUBDIR += mcollective
SUBDIR += mcollective-nrpe-agent
SUBDIR += mcollective-puppet-agent
+ SUBDIR += mcollective-shell-agent
SUBDIR += mcron
SUBDIR += mcweject
SUBDIR += mdcp
diff --git a/sysutils/mcollective-shell-agent/Makefile b/sysutils/mcollective-shell-agent/Makefile
new file mode 100644
index 000000000000..79500b315a6e
--- /dev/null
+++ b/sysutils/mcollective-shell-agent/Makefile
@@ -0,0 +1,35 @@
+# Created by: Bartek Rutkowski <robak@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mcollective-shell-agent
+PORTVERSION= 0.0.1
+CATEGORIES= sysutils
+
+MAINTAINER= robak@FreeBSD.org
+COMMENT= MCollective shell agent plugin
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= mcollective>=2.2.4:${PORTSDIR}/sysutils/mcollective
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 9fb27d5
+
+PLIST_FILES= share/mcollective/agent/shell/job.rb \
+ share/mcollective/agent/shell.rb \
+ share/mcollective/agent/shell.ddl
+PLIST_DIRSTRY= share/mcollective/agent/shell
+
+NO_BUILD= yes
+
+do-install:
+
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PLIST_DIRSTRY}
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/agent/shell/job.rb ${STAGEDIR}${PREFIX}/share/mcollective/agent/shell/
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/agent/shell.rb ${STAGEDIR}${PREFIX}/share/mcollective/agent/
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/agent/shell.ddl ${STAGEDIR}${PREFIX}/share/mcollective/agent/
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-shell-agent/distinfo b/sysutils/mcollective-shell-agent/distinfo
new file mode 100644
index 000000000000..f00b7e79917e
--- /dev/null
+++ b/sysutils/mcollective-shell-agent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mcollective-shell-agent-0.0.1.tar.gz) = c3e899ecf21508587091828f9e18ed232ca615f9f8a899d524f0b96340738d74
+SIZE (mcollective-shell-agent-0.0.1.tar.gz) = 17900
diff --git a/sysutils/mcollective-shell-agent/files/patch-lib-mcollective-agent-shell-job.rb b/sysutils/mcollective-shell-agent/files/patch-lib-mcollective-agent-shell-job.rb
new file mode 100644
index 000000000000..3ccc62cf518d
--- /dev/null
+++ b/sysutils/mcollective-shell-agent/files/patch-lib-mcollective-agent-shell-job.rb
@@ -0,0 +1,9 @@
+# $FreeBSD$
+--- lib/mcollective/agent/shell/job.rb.orig 2014-08-14 12:52:06.644348698 +0200
++++ lib/mcollective/agent/shell/job.rb 2014-08-14 12:52:14.552664032 +0200
+@@ -1,4 +1,5 @@
+ require 'securerandom'
++require 'pathname'
+
+ # The Job class manages the spawning and state tracking for a process as it's
+ # running.
diff --git a/sysutils/mcollective-shell-agent/pkg-descr b/sysutils/mcollective-shell-agent/pkg-descr
new file mode 100644
index 000000000000..53703ed64685
--- /dev/null
+++ b/sysutils/mcollective-shell-agent/pkg-descr
@@ -0,0 +1,8 @@
+The shell agent allows you to start and manage shell commands via mcollective.
+
+It allows the running of long-running processes with a mechanism to check in
+on the output from these long-running processes, which is independent of the
+mcollective daemon process (the daemon can be restarted without interrupting
+the processes)
+
+WWW: https://github.com/puppetlabs/mcollective-shell-agent