aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-02-18 18:24:18 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-02-18 18:24:18 +0000
commitdbf2cd6bf394d04c7651dfce803853b7b1b82ff4 (patch)
tree0283ca1aaef7ccf7d64b9b383ce3877738f608dc
parent70363a1cd52f611d7cc5c9871104ff5d215c75ab (diff)
downloadports-dbf2cd6bf394d04c7651dfce803853b7b1b82ff4.tar.gz
ports-dbf2cd6bf394d04c7651dfce803853b7b1b82ff4.zip
Notes
-rw-r--r--graphics/evolvotron/Makefile26
-rw-r--r--graphics/evolvotron/distinfo6
-rw-r--r--graphics/evolvotron/files/patch-common.pro35
-rw-r--r--graphics/evolvotron/files/patch-evolvotron_match::evolvotron_match.cpp20
-rw-r--r--graphics/evolvotron/files/patch-gcc433
-rw-r--r--graphics/evolvotron/pkg-plist3
6 files changed, 15 insertions, 108 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index 3e2873175b6f..933bf0680014 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -5,44 +5,38 @@
# $FreeBSD$
PORTNAME= evolvotron
-PORTVERSION= 0.4.0
-PORTREVISION= 4
+PORTVERSION= 0.6.1
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rfarmer@predatorlabs.net
COMMENT= Generative software that evolves images/textures/patterns
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT_VER= 3
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui moc_build qmake_build xml
USE_PYTHON= yes
USE_XORG= x11
GNU_CONFIGURE= yes
-MAKE_ENV= QTDIR=${QT_PREFIX} MOC=${MOC}
MAKE_JOBS_UNSAFE= yes
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS} -g -static|' \
- ${WRKSRC}/common.pro
-
-do-configure:
- @cd ${WRKSRC} && ./text_to_markup.py -html < USAGE > evolvotron.html
- @cd ${WRKSRC} && ./text_to_markup.py -qml -s < USAGE > libevolvotron/usage_text.h
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake -spec \
- ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
- VERSION_NUMBER=${PORTVERSION} main.pro
+ ${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 28d ${WRKSRC}/libevolvotron/platform_specific.h
+ ${REINPLACE_CMD} -e 30d ${WRKSRC}/libevolvotron/platform_specific.h
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron/evolvotron ${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_match/evolvotron_match ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_mutate/evolvotron_mutate ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_render/evolvotron_render ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/libevolvotron/libevolvotron.a ${PREFIX}/lib
+ @${INSTALL_DATA} ${WRKSRC}/libfunction/libfunction.a ${PREFIX}/lib
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/evolvotron.html ${DOCSDIR}
diff --git a/graphics/evolvotron/distinfo b/graphics/evolvotron/distinfo
index fdc5118e15ff..2f07419bbc86 100644
--- a/graphics/evolvotron/distinfo
+++ b/graphics/evolvotron/distinfo
@@ -1,3 +1,3 @@
-MD5 (evolvotron-0.4.0.tar.gz) = ab6f3a3247e36ca0024d3837f78bdf6b
-SHA256 (evolvotron-0.4.0.tar.gz) = f846aa85fe443a61afd64d28d491b9afc0f3fbb491f3e27da2d601048d40d1ed
-SIZE (evolvotron-0.4.0.tar.gz) = 131967
+MD5 (evolvotron-0.6.1.tar.gz) = 88ae3cfdef11e7e7f4859b7847cbcaf6
+SHA256 (evolvotron-0.6.1.tar.gz) = 70bf4dc6de69f43385047d3dfb6058c6d5b26957313486bfc452721ff05be503
+SIZE (evolvotron-0.6.1.tar.gz) = 156441
diff --git a/graphics/evolvotron/files/patch-common.pro b/graphics/evolvotron/files/patch-common.pro
deleted file mode 100644
index 3ea0e2718fce..000000000000
--- a/graphics/evolvotron/files/patch-common.pro
+++ /dev/null
@@ -1,35 +0,0 @@
---- common.pro.orig Wed Nov 9 13:50:09 2005
-+++ common.pro Wed Nov 9 13:51:25 2005
-@@ -20,8 +20,6 @@
- # Now leaving these ON for general distribution as they DO have SOME effect
- # (or at least they have in the past... see the README), and should be portable.
- # NB Switching on -funroll-loops causes some versions of gcc to segv
--QMAKE_CXXFLAGS_RELEASE -= -O2
--QMAKE_CXXFLAGS_RELEASE += -O3 -fomit-frame-pointer -ffast-math
-
- ##################
- # Architecture specific optimisations
-@@ -29,23 +27,6 @@
- # (On a different setup you may need to change what is subtracted out of the flags.)
- # NB -march=X implies -mcpu=X... no need to specify both the same
-
--contains(CONFIG_OPTS, p4 ){
-- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
-- QMAKE_CXXFLAGS_RELEASE += -march=pentium4 -mfpmath=sse -msse2
-- BUILD_INFO+= Pentium4
--}
--
--contains(CONFIG_OPTS, p3 ){
-- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
-- QMAKE_CXXFLAGS_RELEASE += -march=pentium3 -mfpmath=sse -msse
-- BUILD_INFO+= Pentium3
--}
--
--contains(CONFIG_OPTS, xp ){
-- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
-- QMAKE_CXXFLAGS_RELEASE += -march=athlon-xp -mfpmath=sse -msse
-- BUILD_INFO+= Athlon-XP
--}
-
- ##################
- # Optimisation insanity
diff --git a/graphics/evolvotron/files/patch-evolvotron_match::evolvotron_match.cpp b/graphics/evolvotron/files/patch-evolvotron_match::evolvotron_match.cpp
deleted file mode 100644
index 5bb0a07d75f5..000000000000
--- a/graphics/evolvotron/files/patch-evolvotron_match::evolvotron_match.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- evolvotron_match/evolvotron_match.cpp.orig Mon Jul 12 02:05:44 2004
-+++ evolvotron_match/evolvotron_match.cpp Thu Dec 9 20:07:52 2004
-@@ -187,13 +187,15 @@
- {
- do
- {
-- new_imagefn=std::auto_ptr<const MutatableImage>(new MutatableImage(mutation_parameters,true,true,false));
-+ std::auto_ptr<const MutatableImage> tmp(new MutatableImage(mutation_parameters,true,true,false));
-+ new_imagefn=tmp;
- }
- while (new_imagefn->is_constant());
- }
- else
- {
-- new_imagefn=std::auto_ptr<const MutatableImage>(best_imagefn->mutated(mutation_parameters));
-+ std::auto_ptr<const MutatableImage> tmp(best_imagefn->mutated(mutation_parameters));
-+ new_imagefn=tmp;
- }
-
-
diff --git a/graphics/evolvotron/files/patch-gcc4 b/graphics/evolvotron/files/patch-gcc4
deleted file mode 100644
index 63b0d335b067..000000000000
--- a/graphics/evolvotron/files/patch-gcc4
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Nru evolvotron.vanilla/libevolvotron/function_node.h evolvotron/libevolvotron/function_node.h
---- libevolvotron/function_node.h 2006-09-03 17:42:30.000000000 +0200
-+++ libevolvotron/function_node.h 2006-09-03 17:46:11.000000000 +0200
-@@ -133,7 +133,7 @@
- static const std::vector<FunctionNode*> stubargs(const MutationParameters& parameters,uint n,bool exciting=false);
-
- //! Return a suitable starting value for a node's iteration count (assuming it's iterative).
-- static const uint FunctionNode::stubiterations(const MutationParameters& parameters);
-+ static const uint stubiterations(const MutationParameters& parameters);
-
- //! Constructor given an array of params and args and an iteration count.
- /*! These MUST be provided; there are no alterative constructors.
-diff -Nru evolvotron.vanilla/libevolvotron/mutation_parameters.h evolvotron/libevolvotron/mutation_parameters.h
---- libevolvotron/mutation_parameters.h 2006-09-03 17:42:30.000000000 +0200
-+++ libevolvotron/mutation_parameters.h 2006-09-03 17:43:19.000000000 +0200
-@@ -266,7 +266,7 @@
- //! This returns a new random bit of tree.
- /*! Setting the "exciting" flag avoids the most basic node types, but only at the top level of the stub tree.
- */
-- FunctionNode*const MutationParameters::random_function_stub(bool exciting) const;
-+ FunctionNode*const random_function_stub(bool exciting) const;
-
- void change_function_weighting(const FunctionRegistration* fn,float w);
-
-@@ -277,7 +277,7 @@
- protected:
-
- //! Return a random function appropriately biased by current settings
-- FunctionNode*const MutationParameters::random_function() const;
-+ FunctionNode*const random_function() const;
-
- //! Return a random function registration, appropriately biased by current settings
- const FunctionRegistration*const random_weighted_function_registration() const;
diff --git a/graphics/evolvotron/pkg-plist b/graphics/evolvotron/pkg-plist
index 0bba7c7dc5d6..15872ef8ec3b 100644
--- a/graphics/evolvotron/pkg-plist
+++ b/graphics/evolvotron/pkg-plist
@@ -1,6 +1,7 @@
bin/evolvotron
-bin/evolvotron_match
bin/evolvotron_mutate
bin/evolvotron_render
+lib/libevolvotron.a
+lib/libfunction.a
%%PORTDOCS%%%%DOCSDIR%%/evolvotron.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%