aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2017-01-09 14:19:18 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2017-01-09 14:19:18 +0000
commitdc0387b84d016f15875f8a9627310008528ffc13 (patch)
tree4fac41dbbb740e634423d72f7894874250a841c5
parent536931e190ccc8d2f7fe5222ad9ff486d58b34d5 (diff)
Add net/py-suds-jurko, Lightweight SOAP client (jurko's fork)
As it conflicts with net/py-suds because of installing the same files, add CONFLICTS_INSTALL to both py-suds-jurko and net/py-suds and bump PORTREVISION for the latter. PR: 215877 Submitted by: Alexander Nusov
Notes
Notes: svn path=/head/; revision=430950
-rw-r--r--net/Makefile1
-rw-r--r--net/py-suds-jurko/Makefile22
-rw-r--r--net/py-suds-jurko/distinfo3
-rw-r--r--net/py-suds-jurko/pkg-descr3
-rw-r--r--net/py-suds/Makefile4
5 files changed, 32 insertions, 1 deletions
diff --git a/net/Makefile b/net/Makefile
index e8dbfd492b3f..460665846069 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1046,6 +1046,7 @@
SUBDIR += py-speedtest-cli
SUBDIR += py-sshuttle
SUBDIR += py-suds
+ SUBDIR += py-suds-jurko
SUBDIR += py-terminado
SUBDIR += py-tofu
SUBDIR += py-tweepy
diff --git a/net/py-suds-jurko/Makefile b/net/py-suds-jurko/Makefile
new file mode 100644
index 000000000000..a5f0ee7761a1
--- /dev/null
+++ b/net/py-suds-jurko/Makefile
@@ -0,0 +1,22 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= suds-jurko
+PORTVERSION= 0.6
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= Lightweight SOAP client (jurko's fork)
+
+LICENSE= LGPL3
+
+NO_ARCH= yes
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}suds-[0-9]*
+
+USES= python tar:bz2
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-suds-jurko/distinfo b/net/py-suds-jurko/distinfo
new file mode 100644
index 000000000000..0a74db41156a
--- /dev/null
+++ b/net/py-suds-jurko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481385855
+SHA256 (suds-jurko-0.6.tar.bz2) = 29edb72fd21e3044093d86f33c66cf847c5aaab26d64cb90e69e528ef014e57f
+SIZE (suds-jurko-0.6.tar.bz2) = 143985
diff --git a/net/py-suds-jurko/pkg-descr b/net/py-suds-jurko/pkg-descr
new file mode 100644
index 000000000000..369e49cf42f1
--- /dev/null
+++ b/net/py-suds-jurko/pkg-descr
@@ -0,0 +1,3 @@
+Lightweight SOAP client written in Python (jurko's fork).
+
+WWW: http://pypi.python.org/pypi/suds-jurko
diff --git a/net/py-suds/Makefile b/net/py-suds/Makefile
index d972898e697b..b67f3b3f012b 100644
--- a/net/py-suds/Makefile
+++ b/net/py-suds/Makefile
@@ -3,7 +3,7 @@
PORTNAME= suds
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,6 +13,8 @@ COMMENT= SOAP implementation
LICENSE= LGPL3
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}suds-jurko-*
+
USES= python:2
USE_PYTHON= autoplist distutils