aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-06-17 21:32:32 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-06-17 21:32:32 +0000
commitdc044fd8e7cb6049c9289cd48aea1c507562db20 (patch)
treea7aa2a7d1a889bcb68ad7220c409995a994808b8
parentd8d1209c77b810ea33afeee2d99415b52608ee27 (diff)
downloadports-dc044fd8e7cb6049c9289cd48aea1c507562db20.tar.gz
ports-dc044fd8e7cb6049c9289cd48aea1c507562db20.zip
Notes
-rw-r--r--games/tenebrae/Makefile33
-rw-r--r--games/tenebrae/files/patch-cd_linux.c (renamed from games/tenebrae/files/patch-cd__linux.c)4
-rw-r--r--games/tenebrae/files/patch-common.c8
-rw-r--r--games/tenebrae/files/patch-common.h4
-rw-r--r--games/tenebrae/files/patch-gl__vidlinuxglx.c10
-rw-r--r--games/tenebrae/files/patch-gl_common.c (renamed from games/tenebrae/files/patch-gl__common.c)4
-rw-r--r--games/tenebrae/files/patch-gl_vidlinuxglx.c19
-rw-r--r--games/tenebrae/files/patch-glquake.h7
-rw-r--r--games/tenebrae/files/patch-linux__Makefile.i386linux (renamed from games/tenebrae/files/patch-linux_Makefile.i386linux)58
-rw-r--r--games/tenebrae/files/patch-net.h4
-rw-r--r--games/tenebrae/files/patch-quakeasm.h11
-rw-r--r--games/tenebrae/files/patch-quakedef.h14
-rw-r--r--games/tenebrae/files/patch-snd__linux.c11
-rw-r--r--games/tenebrae/files/patch-snd__sdl.c15
-rw-r--r--games/tenebrae/files/patch-snd_sdl.c24
-rw-r--r--games/tenebrae/files/patch-sys_dosa.s15
-rw-r--r--games/tenebrae/files/patch-sys_linux.c11
-rw-r--r--games/tenebrae/files/patch-sys_uxfindfirst.c (renamed from games/tenebrae/files/patch-sys__uxfindfirst.c)4
-rw-r--r--games/tenebrae/pkg-message15
-rw-r--r--games/tenebrae/pkg-plist4
20 files changed, 185 insertions, 90 deletions
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index d2bb940aea7c..ecccc0e83500 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -19,33 +19,32 @@ COMMENT= Quake 1 source port with advanced graphics
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_ZIP= yes
+USE_DOS2UNIX= yes
USE_GMAKE= yes
USE_GL= yes
USE_SDL= yes
-ONLY_FOR_ARCHS= i386
-DATADIR= ${Q1DIR}
+OPTIONS= X86_ASM "Enable use of x86 assembly code" on
WRKSRC= ${WRKDIR}/${PORTNAME}_0
BUILD_WRKSRC= ${WRKSRC}/linux
-MAKE_ENV= DATADIR="${DATADIR}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
- SDL_CONFIG="${SDL_CONFIG}"
+MAKEFILE= Makefile.i386linux
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
-.include "${.CURDIR}/../quake-data/Makefile.include"
+.include <bsd.port.pre.mk>
-pre-patch:
- @${REINPLACE_CMD} -e "s|$$(${PRINTF} '\r')||g" `${FIND} ${WRKSRC} -type f`
+.if !defined(WITHOUT_X86_ASM)
+MAKE_ENV+= USE_ASM=1
+.endif
pre-build:
- @${LN} -sf ${WRKSRC}/linux/Makefile.i386linux ${WRKSRC}/linux/Makefile
+ @cd ${BUILD_WRKSRC} && ${LN} -sf Makefile.i386linux Makefile
do-install:
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/debugi386.glibc/bin/${PORTNAME}.run \
- ${PREFIX}/bin/${PORTNAME}
- @${MKDIR} ${DATADIR}
- @${MKDIR} ${DATADIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Pak0.pak ${DATADIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/bin/${PORTNAME} \
+ ${PREFIX}/bin
+ @${MKDIR} ${Q1DIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}/Pak0.pak ${Q1DIR}/${PORTNAME}
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${TR} -d '\r' <${WRKDIR}/Tenebrae_Readme.txt \
@@ -53,6 +52,10 @@ do-install:
.endif
post-install:
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include "${.CURDIR}/../quake-data/Makefile.include"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/tenebrae/files/patch-cd__linux.c b/games/tenebrae/files/patch-cd_linux.c
index 4ac54dea2985..ac2d85b32dbb 100644
--- a/games/tenebrae/files/patch-cd__linux.c
+++ b/games/tenebrae/files/patch-cd_linux.c
@@ -1,5 +1,5 @@
---- cd_linux.c.orig Sun Mar 14 12:11:16 2004
-+++ cd_linux.c Sun Mar 14 12:24:07 2004
+--- ./cd_linux.c.orig Sat Jun 10 12:08:13 2006
++++ ./cd_linux.c Sat Jun 10 12:08:13 2006
@@ -31,7 +31,7 @@
#include <time.h>
#include <errno.h>
diff --git a/games/tenebrae/files/patch-common.c b/games/tenebrae/files/patch-common.c
index 4da54a7ef122..facc89061cb8 100644
--- a/games/tenebrae/files/patch-common.c
+++ b/games/tenebrae/files/patch-common.c
@@ -1,11 +1,13 @@
---- common.c.orig Sun Mar 14 13:16:07 2004
-+++ common.c Sun Mar 14 13:17:40 2004
-@@ -2221,6 +2221,8 @@
+--- ./common.c.orig Sat Jun 10 12:08:13 2006
++++ ./common.c Sat Jun 10 12:08:13 2006
+@@ -2221,7 +2221,10 @@
if ((userdir[j-1] == '\\') || (userdir[j-1] == '/'))
userdir[j-1] = 0;
}
+
+ strncpy (com_prefdir, userdir, j);
COM_AddGameFS (userdir);
++ Sys_mkdir(com_gamedir);
#endif
+
diff --git a/games/tenebrae/files/patch-common.h b/games/tenebrae/files/patch-common.h
index 901bb81aeba5..71db3b3f11d7 100644
--- a/games/tenebrae/files/patch-common.h
+++ b/games/tenebrae/files/patch-common.h
@@ -1,5 +1,5 @@
---- common.h.orig Sun Mar 14 13:19:04 2004
-+++ common.h Sun Mar 14 13:19:50 2004
+--- ./common.h.orig Sat Jun 10 12:08:13 2006
++++ ./common.h Sat Jun 10 12:08:13 2006
@@ -169,6 +169,10 @@
extern char com_gamedir[MAX_OSPATH];
diff --git a/games/tenebrae/files/patch-gl__vidlinuxglx.c b/games/tenebrae/files/patch-gl__vidlinuxglx.c
deleted file mode 100644
index 1a20b1d8d242..000000000000
--- a/games/tenebrae/files/patch-gl__vidlinuxglx.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- gl_vidlinuxglx.c.orig Sun Mar 14 12:27:06 2004
-+++ gl_vidlinuxglx.c Sun Mar 14 12:27:21 2004
-@@ -20,7 +20,6 @@
- #include <termios.h>
- #include <sys/ioctl.h>
- #include <sys/stat.h>
--#include <sys/vt.h>
- #include <stdarg.h>
- #include <stdio.h>
- #include <signal.h>
diff --git a/games/tenebrae/files/patch-gl__common.c b/games/tenebrae/files/patch-gl_common.c
index 9dbb358d94b2..6b594dd712af 100644
--- a/games/tenebrae/files/patch-gl__common.c
+++ b/games/tenebrae/files/patch-gl_common.c
@@ -1,5 +1,5 @@
---- gl_common.c.orig Sun Mar 14 12:33:12 2004
-+++ gl_common.c Sun Mar 14 12:35:26 2004
+--- ./gl_common.c.orig Sat Jun 10 12:08:13 2006
++++ ./gl_common.c Sat Jun 10 12:08:13 2006
@@ -248,11 +248,11 @@
if (!strstr(gl_extensions, "GL_ARB_texture_env_dot3")) {
Sys_Error ("ARB_texture_env_dot3 not found.\nProbably your 3d-card is not supported.\n");
diff --git a/games/tenebrae/files/patch-gl_vidlinuxglx.c b/games/tenebrae/files/patch-gl_vidlinuxglx.c
new file mode 100644
index 000000000000..f98a7cbefac9
--- /dev/null
+++ b/games/tenebrae/files/patch-gl_vidlinuxglx.c
@@ -0,0 +1,19 @@
+--- ./gl_vidlinuxglx.c.orig Sat Jun 10 12:08:13 2006
++++ ./gl_vidlinuxglx.c Sat Jun 10 12:08:13 2006
+@@ -20,7 +20,6 @@
+ #include <termios.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+-#include <sys/vt.h>
+ #include <stdarg.h>
+ #include <stdio.h>
+ #include <signal.h>
+@@ -339,8 +338,6 @@
+ {
+ mx += ((int)event.xmotion.x - mwx) * 2;
+ my += ((int)event.xmotion.y - mwy) * 2;
+- mwx = event.xmotion.x;
+- mwy = event.xmotion.y;
+
+ if (mx || my)
+ dowarp = true;
diff --git a/games/tenebrae/files/patch-glquake.h b/games/tenebrae/files/patch-glquake.h
index 97250817e1a2..d081bebb63e8 100644
--- a/games/tenebrae/files/patch-glquake.h
+++ b/games/tenebrae/files/patch-glquake.h
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- glquake.h.orig
-+++ glquake.h
+--- ./glquake.h.orig Sat Jun 10 12:08:13 2006
++++ ./glquake.h Sat Jun 10 12:08:13 2006
@@ -419,8 +419,8 @@
void R_TranslatePlayerSkin (int playernum);
void GL_Bind (int texnum);
diff --git a/games/tenebrae/files/patch-linux_Makefile.i386linux b/games/tenebrae/files/patch-linux__Makefile.i386linux
index 071a4b3608dc..73e7e693508a 100644
--- a/games/tenebrae/files/patch-linux_Makefile.i386linux
+++ b/games/tenebrae/files/patch-linux__Makefile.i386linux
@@ -1,14 +1,15 @@
---- linux/Makefile.i386linux.orig Sun Mar 14 15:07:08 2004
-+++ linux/Makefile.i386linux Sun Mar 14 17:54:02 2004
-@@ -18,30 +18,30 @@
+--- ./linux/Makefile.i386linux.orig Sat Jun 10 12:08:13 2006
++++ ./linux/Makefile.i386linux Sat Jun 10 12:12:17 2006
+@@ -18,56 +18,60 @@
MOUNT_DIR = ../
-MASTER_DIR = /usr/local/share/games/quake
-+MASTER_DIR = ${DATADIR}
++MASTER_DIR = ${Q1DIR}
BUILD_DEBUG_DIR = debug$(ARCH)$(GLIBC)
- BUILD_RELEASE_DIR = release$(ARCH)$(GLIBC)
+-BUILD_RELEASE_DIR = release$(ARCH)$(GLIBC)
++BUILD_RELEASE_DIR = release
-LEX = /usr/bin/flex -i -Cfr
-CC = /usr/bin/gcc
@@ -16,7 +17,7 @@
+#CC = /usr/bin/gcc
-X11_LIBS = -L/usr/X11R6/lib -lpthread -lX11 -lXext -lXxf86dga -lXxf86vm
-+X11_LIBS = -L${X11BASE}/lib ${PTHREAD_LIBS} -lX11 -lXext -lXxf86dga -lXxf86vm
++X11_LIBS = -L${X11BASE}/lib -lX11 -lXext -lXxf86dga -lXxf86vm
# to enable OpenGL code in source
-OPENGL_CFLAGS = -D__glx__ -DGLQUAKE
@@ -37,11 +38,28 @@
-fomit-frame-pointer -fexpensive-optimizations
DEBUG_CFLAGS = $(BASE_CFLAGS) -g
-LDFLAGS = -lm -ldl $(X11_LIBS) $(OPENGL_LIBS) $(PNG_LIBS) $(OPENAL_LIBS)
-+LDFLAGS = -lm $(X11_LIBS) $(OPENGL_LIBS) $(PNG_LIBS) $(OPENAL_LIBS) `${SDL_CONFIG} --libs`
++LDFLAGS += -lm $(X11_LIBS) $(OPENGL_LIBS) $(PNG_LIBS) $(OPENAL_LIBS) `${SDL_CONFIG} --libs`
DO_GL_CC = $(CC) $(CFLAGS) -o $@ -c $<
DO_GL_AS = $(CC) $(CFLAGS) -DELF -x assembler-with-cpp -o $@ -c $<
-@@ -57,15 +57,15 @@
+ DO_LEX = $(LEX) -o$@ $<
+
++ifdef USE_ASM
++BASE_CFLAGS += -DUSE_ASM
++endif
++
+ #############################################################################
+ # SETUP AND BUILD
+ #############################################################################
+
+-TARGETS=$(BUILDDIR)/bin/tenebrae.run
++TARGETS=$(BUILDDIR)/bin/tenebrae
++
++all: build_release
++
++targets: $(TARGETS)
+
+ build_debug:
@-mkdir -p $(BUILD_DEBUG_DIR) \
$(BUILD_DEBUG_DIR)/bin \
$(BUILD_DEBUG_DIR)/glquake
@@ -53,14 +71,15 @@
$(BUILD_RELEASE_DIR)/bin \
$(BUILD_RELEASE_DIR)/glquake
- $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS="$(RELEASE_CFLAGS)"
-+ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(RELEASE_CFLAGS)"
-
+-
-all: build_debug build_release
-+all: build_debug
-
- targets: $(TARGETS)
+-
+-targets: $(TARGETS)
++ $(MAKE) targets BUILDDIR=$(BUILD_RELEASE_DIR) CFLAGS+="$(RELEASE_CFLAGS)"
-@@ -143,7 +143,7 @@
+ #############################################################################
+ # GLQuake
+@@ -143,7 +147,7 @@
$(BUILDDIR)/glquake/snd_dma.o \
$(BUILDDIR)/glquake/snd_mem.o \
$(BUILDDIR)/glquake/snd_mix.o \
@@ -69,7 +88,16 @@
$(BUILDDIR)/glquake/gl_vidlinuxglx.o \
$(BUILDDIR)/glquake/math.o \
$(BUILDDIR)/glquake/worlda.o \
-@@ -361,7 +361,7 @@
+@@ -154,7 +158,7 @@
+ $(BUILDDIR)/glquake/te_scripts.o
+
+
+-$(BUILDDIR)/bin/tenebrae.run : $(GLQUAKE_OBJS)
++$(BUILDDIR)/bin/tenebrae : $(GLQUAKE_OBJS)
+ $(CC) $(CFLAGS) -o $@ $(GLQUAKE_OBJS) $(LDFLAGS)
+
+ $(BUILDDIR)/glquake/cl_demo.o : $(MOUNT_DIR)/cl_demo.c
+@@ -361,7 +365,7 @@
$(BUILDDIR)/glquake/snd_mix.o : $(MOUNT_DIR)/snd_mix.c
$(DO_GL_CC)
diff --git a/games/tenebrae/files/patch-net.h b/games/tenebrae/files/patch-net.h
index 9f2e41d67fd7..55290a9d1fff 100644
--- a/games/tenebrae/files/patch-net.h
+++ b/games/tenebrae/files/patch-net.h
@@ -1,5 +1,5 @@
---- net.h.orig Wed Mar 17 10:25:22 2004
-+++ net.h Wed Mar 17 10:25:37 2004
+--- ./net.h.orig Sat Jun 10 12:08:13 2006
++++ ./net.h Sat Jun 10 12:08:13 2006
@@ -239,7 +239,7 @@
extern int hostCacheCount;
extern hostcache_t hostcache[HOSTCACHESIZE];
diff --git a/games/tenebrae/files/patch-quakeasm.h b/games/tenebrae/files/patch-quakeasm.h
new file mode 100644
index 000000000000..f3bdf43f3b24
--- /dev/null
+++ b/games/tenebrae/files/patch-quakeasm.h
@@ -0,0 +1,11 @@
+--- ./quakeasm.h.orig Sat Jun 10 12:08:13 2006
++++ ./quakeasm.h Sat Jun 10 12:08:13 2006
+@@ -31,7 +31,7 @@
+
+ #endif
+
+-#ifdef __i386__
++#if defined(__i386__) && defined(USE_ASM)
+ #define id386 1
+ #else
+ #define id386 0
diff --git a/games/tenebrae/files/patch-quakedef.h b/games/tenebrae/files/patch-quakedef.h
new file mode 100644
index 000000000000..63e957213790
--- /dev/null
+++ b/games/tenebrae/files/patch-quakedef.h
@@ -0,0 +1,14 @@
+--- ./quakedef.h.orig Sat Jun 10 12:08:13 2006
++++ ./quakedef.h Sat Jun 10 12:08:13 2006
+@@ -74,11 +74,6 @@
+
+ #endif
+
+-//PENTA: win32 we use assembler
+-#if defined(_WIN32) || defined __glx__
+-#define USE_ASM 1
+-#endif
+-
+ #if defined(__i386__) && defined(USE_ASM)
+ #define id386 1
+ #else
diff --git a/games/tenebrae/files/patch-snd__linux.c b/games/tenebrae/files/patch-snd__linux.c
deleted file mode 100644
index 610506a3ab8d..000000000000
--- a/games/tenebrae/files/patch-snd__linux.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- snd_linux.c.orig Sun Mar 14 12:25:10 2004
-+++ snd_linux.c Sun Mar 14 12:25:46 2004
-@@ -25,7 +25,7 @@
- #include <sys/mman.h>
- #include <sys/shm.h>
- #include <sys/wait.h>
--#include <linux/soundcard.h>
-+#include <sys/soundcard.h>
- #include <stdio.h>
- #include "quakedef.h"
-
diff --git a/games/tenebrae/files/patch-snd__sdl.c b/games/tenebrae/files/patch-snd__sdl.c
deleted file mode 100644
index c247885e4112..000000000000
--- a/games/tenebrae/files/patch-snd__sdl.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- snd_sdl.c.orig Sun Mar 14 17:59:19 2004
-+++ snd_sdl.c Sun Mar 14 17:59:35 2004
-@@ -119,3 +119,12 @@
- }
- }
-
-+/*
-+==============
-+SNDDMA_Submit
-+Send sound to device if buffer isn't really the dma buffer
-+===============
-+*/
-+void SNDDMA_Submit(void)
-+{
-+}
diff --git a/games/tenebrae/files/patch-snd_sdl.c b/games/tenebrae/files/patch-snd_sdl.c
new file mode 100644
index 000000000000..454dd5ce2969
--- /dev/null
+++ b/games/tenebrae/files/patch-snd_sdl.c
@@ -0,0 +1,24 @@
+--- ./snd_sdl.c.orig Sat Jun 10 12:08:13 2006
++++ ./snd_sdl.c Sat Jun 10 12:08:13 2006
+@@ -94,7 +94,7 @@
+ shm = &the_shm;
+ shm->splitbuffer = 0;
+ shm->samplebits = (obtained.format & 0xFF);
+- shm->speed = obtained.freq;
++ shm->speed = desired.freq;
+ shm->channels = obtained.channels;
+ shm->samples = obtained.samples*shm->channels;
+ shm->samplepos = 0;
+@@ -119,3 +119,12 @@
+ }
+ }
+
++/*
++==============
++SNDDMA_Submit
++Send sound to device if buffer isn't really the dma buffer
++===============
++*/
++void SNDDMA_Submit(void)
++{
++}
diff --git a/games/tenebrae/files/patch-sys_dosa.s b/games/tenebrae/files/patch-sys_dosa.s
new file mode 100644
index 000000000000..e22d80c2012e
--- /dev/null
+++ b/games/tenebrae/files/patch-sys_dosa.s
@@ -0,0 +1,15 @@
+--- ./sys_dosa.s.orig Sat Jun 10 12:08:13 2006
++++ ./sys_dosa.s Sat Jun 10 12:08:13 2006
+@@ -5,6 +5,7 @@
+ #include "asm_i386.h"
+ #include "quakeasm.h"
+
++#if id386
+
+ .data
+
+@@ -93,3 +94,4 @@
+
+ ret
+
++#endif
diff --git a/games/tenebrae/files/patch-sys_linux.c b/games/tenebrae/files/patch-sys_linux.c
new file mode 100644
index 000000000000..5bf74ff89970
--- /dev/null
+++ b/games/tenebrae/files/patch-sys_linux.c
@@ -0,0 +1,11 @@
+--- ./sys_linux.c.orig Sat Jun 10 12:08:13 2006
++++ ./sys_linux.c Sat Jun 10 12:08:13 2006
+@@ -27,7 +27,7 @@
+ // user preference directory
+
+ #if defined (USERPREF_DIR)
+-char *prefdir= ".quake";
++char *prefdir= ".tenebrae";
+ #endif
+
+ #if defined (BASEDIR)
diff --git a/games/tenebrae/files/patch-sys__uxfindfirst.c b/games/tenebrae/files/patch-sys_uxfindfirst.c
index 47f1d7e655bc..0241db267614 100644
--- a/games/tenebrae/files/patch-sys__uxfindfirst.c
+++ b/games/tenebrae/files/patch-sys_uxfindfirst.c
@@ -1,5 +1,5 @@
---- sys_uxfindfirst.c.orig Sun Mar 14 15:00:09 2004
-+++ sys_uxfindfirst.c Sun Mar 14 15:06:52 2004
+--- ./sys_uxfindfirst.c.orig Sat Jun 10 12:08:13 2006
++++ ./sys_uxfindfirst.c Sat Jun 10 12:08:13 2006
@@ -36,7 +36,7 @@
#include "quakedef.h"
#include <errno.h>
diff --git a/games/tenebrae/pkg-message b/games/tenebrae/pkg-message
index 221a6b001e21..b2eb2dbf7ae5 100644
--- a/games/tenebrae/pkg-message
+++ b/games/tenebrae/pkg-message
@@ -1,4 +1,11 @@
-*******************************************************************************
-* Tenebrae Quake requires data files (id1 directory) from original game.
-* Before running Tenebrae install them using games/quake-data port.
-*******************************************************************************
+==============================================================================
+
+Tenebrae has been installed.
+
+If you hace sound problems try running it with the parameter
+"-sndspeed <speed>", where "<speed>" could be 22050 or 44100 for example.
+
+If you have rendering problems with water try to set the variable "r_novis" to
+the value "1".
+
+==============================================================================
diff --git a/games/tenebrae/pkg-plist b/games/tenebrae/pkg-plist
index 1f21a5776912..f7fbd1aeaf8d 100644
--- a/games/tenebrae/pkg-plist
+++ b/games/tenebrae/pkg-plist
@@ -1,5 +1,5 @@
bin/tenebrae
-%%DATADIR%%/tenebrae/Pak0.pak
-@dirrm %%DATADIR%%/tenebrae
+%%Q1DIR%%/tenebrae/Pak0.pak
+@dirrm %%Q1DIR%%/tenebrae
%%PORTDOCS%%%%DOCSDIR%%/Tenebrae_Readme.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%