aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-02-29 19:21:35 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-02-29 19:21:35 +0000
commitdc5443f06a48dd4c1ee5997305dd91e26e0c3050 (patch)
tree40e09f3291e1572460f927b1fd4759587a7f0248
parent574ff149949d6030494912db4d6620cdac1cf047 (diff)
sysutils/duplicity-devel: Update to 0.8.11
Changelog: https://launchpad.net/duplicity/+milestone/0.8.11 Simplify port removing setup.py patch, which was removing all testing references. Now is necessary remove missing files from TMPPLIST. These files are removed in the setup.py install target, between building and installing.
Notes
Notes: svn path=/head/; revision=527455
-rw-r--r--sysutils/duplicity-devel/Makefile10
-rw-r--r--sysutils/duplicity-devel/distinfo6
-rw-r--r--sysutils/duplicity-devel/files/patch-setup.py95
3 files changed, 10 insertions, 101 deletions
diff --git a/sysutils/duplicity-devel/Makefile b/sysutils/duplicity-devel/Makefile
index c914101de6c8..3fff2dbe1a14 100644
--- a/sysutils/duplicity-devel/Makefile
+++ b/sysutils/duplicity-devel/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= duplicity
-PORTVERSION= 0.8.10
-DISTVERSIONSUFFIX= fin1558
-PORTREVISION= 2
+PORTVERSION= 0.8.11
+DISTVERSIONSUFFIX= .1596
CATEGORIES= sysutils
MASTER_SITES= https://code.launchpad.net/duplicity/0.8-series/${PORTVERSION}/+download/
PKGNAMESUFFIX= -devel
@@ -34,6 +33,8 @@ SHEBANG_FILES= bin/duplicity bin/rdiffdir
PORTDOCS= CHANGELOG COPYING README README-REPO README-LOG
+POST_PLIST= trim-duplicity-testing
+
OPTIONS_DEFINE= B2 DOCS FTP FTPS GDOCS NLS S3
OPTIONS_GROUP= GPG
OPTIONS_SINGLE= GPG
@@ -91,4 +92,7 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|g} ${STAGEDIR}${DOCSDIR}
+trim-duplicity-testing:
+ @${REINPLACE_CMD} '/\/testing\//d' ${TMPPLIST}
+
.include <bsd.port.mk>
diff --git a/sysutils/duplicity-devel/distinfo b/sysutils/duplicity-devel/distinfo
index 9e0c9b3d336a..f85e8f2ca229 100644
--- a/sysutils/duplicity-devel/distinfo
+++ b/sysutils/duplicity-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580137004
-SHA256 (duplicity-0.8.10fin1558.tar.gz) = b08295b7e8d321dd3459465d28fb190c9653d849be7ab13b1f9d09d6b6aa578d
-SIZE (duplicity-0.8.10fin1558.tar.gz) = 1870098
+TIMESTAMP = 1582992837
+SHA256 (duplicity-0.8.11.1596.tar.gz) = 09826a6e5706db1fc9a2c5624fc7f13c0ec1289111676eb9b323b0c69757aae1
+SIZE (duplicity-0.8.11.1596.tar.gz) = 1872223
diff --git a/sysutils/duplicity-devel/files/patch-setup.py b/sysutils/duplicity-devel/files/patch-setup.py
deleted file mode 100644
index 2abbf865a433..000000000000
--- a/sysutils/duplicity-devel/files/patch-setup.py
+++ /dev/null
@@ -1,95 +0,0 @@
---- setup.py.orig 2019-07-25 14:48:21 UTC
-+++ setup.py
-@@ -23,7 +23,6 @@
- import sys
- import os
- from setuptools import setup, Extension
--from setuptools.command.test import test
- from setuptools.command.install import install
- from setuptools.command.sdist import sdist
- from distutils.command.build_scripts import build_scripts
-@@ -50,12 +49,6 @@ if os.name == u'posix':
- data_files = [(u'share/man/man1',
- [u'bin/duplicity.1',
- u'bin/rdiffdir.1']),
-- (u'share/doc/duplicity-%s' % version_string,
-- [u'COPYING',
-- u'README',
-- u'README-REPO',
-- u'README-LOG',
-- u'CHANGELOG']),
- ]
-
- top_dir = os.path.dirname(os.path.abspath(__file__))
-@@ -79,47 +72,9 @@ else:
- ext_modules = []
-
-
--class TestCommand(test):
--
-- def run(self):
-- # Make sure all modules are ready
-- build_cmd = self.get_finalized_command(u"build_py")
-- build_cmd.run()
-- # And make sure our scripts are ready
-- build_scripts_cmd = self.get_finalized_command(u"build_scripts")
-- build_scripts_cmd.run()
--
-- # make symlinks for test data
-- if build_cmd.build_lib != top_dir:
-- for path in [u'testfiles.tar.gz', u'gnupg']:
-- src = os.path.join(top_dir, u'testing', path)
-- target = os.path.join(build_cmd.build_lib, u'testing', path)
-- try:
-- os.symlink(src, target)
-- except Exception:
-- pass
--
-- os.environ[u'PATH'] = u"%s:%s" % (
-- os.path.abspath(build_scripts_cmd.build_dir),
-- os.environ.get(u'PATH'))
--
-- test.run(self)
--
--
- class InstallCommand(install):
-
- def run(self):
-- # Normally, install will call build(). But we want to delete the
-- # testing dir between building and installing. So we manually build
-- # and mark ourselves to skip building when we run() for real.
-- self.run_command(u'build')
-- self.skip_build = True
--
-- # This should always be true, but just to make sure!
-- if self.build_lib != top_dir:
-- testing_dir = os.path.join(self.build_lib, u'testing')
-- os.system(u"rm -rf %s" % testing_dir)
--
- install.run(self)
-
-
-@@ -186,21 +141,14 @@ setup(name=u"duplicity",
- url=u"http://duplicity.nongnu.org/index.html",
- packages=[u'duplicity',
- u'duplicity.backends',
-- u'duplicity.backends.pyrax_identity',
-- u'testing',
-- u'testing.functional',
-- u'testing.overrides',
-- u'testing.unit'],
-+ u'duplicity.backends.pyrax_identity'],
- package_dir={u"duplicity": u"duplicity",
- u"duplicity.backends": u"duplicity/backends", },
- ext_modules=ext_modules,
- scripts=[u'bin/rdiffdir', u'bin/duplicity'],
- data_files=data_files,
- install_requires=[u'fasteners', u'future'],
-- tests_require=[u'pytest', u'pytest-runner', u'fasteners', u'future', u'mock', u'pexpect'],
-- test_suite=u'testing',
-- cmdclass={u'test': TestCommand,
-- u'install': InstallCommand,
-+ cmdclass={u'install': InstallCommand,
- u'sdist': SDistCommand,
- u'build_scripts': BSCommand},
- classifiers=[u"Programming Language :: Python :: 2",