aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2015-11-17 17:35:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2015-11-17 17:35:31 +0000
commitdceac2dff9434f6107a22d3d79e5d5900e8b3450 (patch)
tree7784d4e09406a60045ed9f3e350d452b11ea08f9
parent914ed8f5e42e10f74ae30fbde68b533a7d482001 (diff)
downloadports-dceac2dff9434f6107a22d3d79e5d5900e8b3450.tar.gz
ports-dceac2dff9434f6107a22d3d79e5d5900e8b3450.zip
Notes
-rw-r--r--net/tshark-lite/Makefile1
-rw-r--r--net/tshark/Makefile4
-rw-r--r--net/wireshark-lite/Makefile3
-rw-r--r--net/wireshark/Makefile8
4 files changed, 9 insertions, 7 deletions
diff --git a/net/tshark-lite/Makefile b/net/tshark-lite/Makefile
index 5d192b7a77a8..b341e6bfd03a 100644
--- a/net/tshark-lite/Makefile
+++ b/net/tshark-lite/Makefile
@@ -2,7 +2,6 @@
# $FreeBSD$
LITE= yes
-PKGNAMESUFFIX= -lite
MASTERDIR= ${.CURDIR}/../tshark
COMMENT= Powerful network analyzer/capture tool (lite package)
diff --git a/net/tshark/Makefile b/net/tshark/Makefile
index 5fbd4bf007e5..8d9c2152558f 100644
--- a/net/tshark/Makefile
+++ b/net/tshark/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= tshark
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTERDIR= ${.CURDIR}/../wireshark
-OPTIONS_EXCLUDE= X11 GTK3 QT5
+OPTIONS_EXCLUDE= GTK2 GTK3 QT5
.include "${MASTERDIR}/Makefile"
diff --git a/net/wireshark-lite/Makefile b/net/wireshark-lite/Makefile
index 5962382ad194..860765679df6 100644
--- a/net/wireshark-lite/Makefile
+++ b/net/wireshark-lite/Makefile
@@ -2,11 +2,8 @@
# $FreeBSD$
LITE= yes
-PKGNAMESUFFIX= -lite
MASTERDIR= ${.CURDIR}/../wireshark
COMMENT= Powerful network analyzer/capture tool (lite package)
-OPTIONS_EXCLUDE= LUA RTP SNMP ADNS CARES GEOIP
-
.include "${MASTERDIR}/Makefile"
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index fbb90113ccd8..a68c8e997129 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= wireshark
PORTVERSION= 1.12.8
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
@@ -13,6 +13,7 @@ MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.yz.yamagata-u.ac.jp/pub/network/security/wireshark/src/ \
ftp://ftp.yz.yamagata-u.ac.jp/pub/network/security/wireshark/src/ \
http://wireshark.zing.org/download/src/
+DISTNAME= ${DATADIR_NAME}-${PORTVERSION}
MAINTAINER= marcus@FreeBSD.org
COMMENT?= Powerful network analyzer/capture tool
@@ -22,6 +23,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS?= wireshark-qt5-[0-9]*
+DATADIR_NAME= wireshark
+DATADIR= ${PREFIX}/share/${DATADIR_NAME}
+
GNU_CONFIGURE= yes
USES= alias cpe gmake libtool perl5 pkgconfig python:build tar:bzip2
USE_PERL5= build
@@ -39,9 +43,11 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION}
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
reordercap captype
.if defined(LITE)
+PKGNAMESUFFIX= -lite
PLIST_SUB+= ${x:tu}="@comment $x not installed" \
${x:tu}_MAN="@comment $x not installed "
CONFIGURE_ARGS+= --enable-$x=no
+OPTIONS_EXCLUDE+= RTP SNMP GEOIP LUA ADNS CARES
.else
PLIST_SUB+= ${x:tu}=bin/$x \
${x:tu}_MAN=""