aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 21:58:59 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 21:58:59 +0000
commitdd46e5cccaacbd51b3bbcf35c2de7103807d58d7 (patch)
treed8084516dc80c7b479e4c7732acd38936218e625
parentaaf137da80ada2738b6f5f0aea39b6df968c5a82 (diff)
downloadports-dd46e5cccaacbd51b3bbcf35c2de7103807d58d7.tar.gz
ports-dd46e5cccaacbd51b3bbcf35c2de7103807d58d7.zip
Notes
-rw-r--r--print/abcm2ps/Makefile4
-rw-r--r--print/fpdf/Makefile4
-rw-r--r--print/gl2ps/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/print/abcm2ps/Makefile b/print/abcm2ps/Makefile
index f50d7c58b833..e5ad42c7ec20 100644
--- a/print/abcm2ps/Makefile
+++ b/print/abcm2ps/Makefile
@@ -20,13 +20,13 @@ PLIST_FILES= bin/abcm2ps %%DATADIR%%/fbook.fmt %%DATADIR%%/fonts.fmt \
%%DATADIR%%/tight.fmt %%DATADIR%%/musicfont.fmt
PLIST_DIRS= %%DATADIR%%
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/abcm2ps ${STAGEDIR}${PREFIX}/bin/
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.fmt ${STAGEDIR}${DATADIR}/
-.if !defined(NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
-.endif
.include <bsd.port.mk>
diff --git a/print/fpdf/Makefile b/print/fpdf/Makefile
index 39512a4f0fef..d2d48a231a3a 100644
--- a/print/fpdf/Makefile
+++ b/print/fpdf/Makefile
@@ -28,6 +28,8 @@ PLIST_SUB= FPDF_DIR=${FPDF_DIR}
EXT2CNV= afm css htm php txt
DOCS= FAQ.htm changelog.htm doc fpdf.css install.txt license.txt tutorial
+OPTIONS_DEFINE= DOCS
+
do-fetch:
@if [ ! -f ${DISTDIR}/${DISTFILES} ]; then \
${FETCH_CMD} ${FETCH_BEFORE_ARGS} \
@@ -38,10 +40,8 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${FPDF_DIR}
${INSTALL_DATA} ${WRKSRC}/fpdf.php ${STAGEDIR}${PREFIX}/${FPDF_DIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "font makefont" ${STAGEDIR}${PREFIX}/${FPDF_DIR}/)
-.if !defined(NOPORTDOCS)
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${DOCS}" ${STAGEDIR}${DOCSDIR}/)
-.endif
post-install:
@${ECHO_MSG}
diff --git a/print/gl2ps/Makefile b/print/gl2ps/Makefile
index 9ac6917a9cf3..5201c3bd63b0 100644
--- a/print/gl2ps/Makefile
+++ b/print/gl2ps/Makefile
@@ -15,6 +15,8 @@ USE_XORG= x11 xmu xi
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-source
+OPTIONS_DEFINE= DOCS
+
pre-build:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
@@ -33,9 +35,7 @@ do-install:
s|%%LOCALBASE%%|${LOCALBASE}|g' \
<${FILESDIR}/Makefile.ex >${STAGEDIR}${EXAMPLESDIR}/Makefile
-.ifndef (NOPORTDOCS)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/gl2ps.pdf ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>