aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-01-16 03:14:54 +0000
committerDan Langille <dvl@FreeBSD.org>2017-01-16 03:14:54 +0000
commitde5844a4cf946ba22d272a8894543c8c3199b771 (patch)
treece8359e66c4782bb6d134d6e1db03da40a909a85
parentf713c02ed6d82d44393d9e5941300f07913cc9ce (diff)
downloadports-de5844a4cf946ba22d272a8894543c8c3199b771.tar.gz
ports-de5844a4cf946ba22d272a8894543c8c3199b771.zip
Add patches missing from previous commit.
Add note to pkg-message about my.cnf Add not to UPGRADING about my.cnf Bump PORTREVISION Submitted by: Larry Rosenman <ler@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=431614
-rw-r--r--UPDATING10
-rw-r--r--net-mgmt/librenms/Makefile2
-rw-r--r--net-mgmt/librenms/files/patch-includes-common.php16
-rw-r--r--net-mgmt/librenms/files/patch-validate.php52
-rw-r--r--net-mgmt/librenms/files/pkg-message.in6
5 files changed, 85 insertions, 1 deletions
diff --git a/UPDATING b/UPDATING
index 5ccac173d125..40308bcb10d5 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,16 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20170115:
+ AFFECTS: users of net-mgmt/librenms
+ AUTHOR: dvl@FreeBSD.org
+
+ The following is recommended for /var/db/mysql/my.cnf
+
+ [mysqld]
+ innodb_file_per_table=1
+ sql-mode=""
+
20170109:
AFFECTS: users of lang/ruby22
AUTHOR: swills@FreeBSD.org
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index 4618001f9665..70d2133b0284 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -4,7 +4,7 @@
PORTNAME= librenms
PORTVERSION= 1.23
PORTEPOCH= 1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
USE_GITHUB= yes
diff --git a/net-mgmt/librenms/files/patch-includes-common.php b/net-mgmt/librenms/files/patch-includes-common.php
new file mode 100644
index 000000000000..1e4b51814018
--- /dev/null
+++ b/net-mgmt/librenms/files/patch-includes-common.php
@@ -0,0 +1,16 @@
+--- includes/common.php.orig 2017-01-15 20:50:30.075142000 +0000
++++ includes/common.php 2017-01-15 20:42:35.634055000 +0000
+@@ -1110,10 +1110,10 @@
+ curl_setopt($api, CURLOPT_RETURNTRANSFER, 1);
+ $output['github'] = json_decode(curl_exec($api), true);
+ }
+- list($local_sha, $local_date) = explode('|', rtrim(`git show --pretty='%H|%ct' -s HEAD`));
+- $output['local_sha'] = $local_sha;
++# list($local_sha, $local_date) = explode('|', rtrim(`git show --pretty='%H|%ct' -s HEAD`));
++ $output['local_sha'] = '%%PORTVERSION%%';
+ $output['local_date'] = $local_date;
+- $output['local_branch'] = rtrim(`git rev-parse --abbrev-ref HEAD`);
++# $output['local_branch'] = rtrim(`git rev-parse --abbrev-ref HEAD`);
+
+ $output['db_schema'] = dbFetchCell('SELECT version FROM dbSchema');
+ $output['php_ver'] = phpversion();
diff --git a/net-mgmt/librenms/files/patch-validate.php b/net-mgmt/librenms/files/patch-validate.php
new file mode 100644
index 000000000000..5f7ff26beec5
--- /dev/null
+++ b/net-mgmt/librenms/files/patch-validate.php
@@ -0,0 +1,52 @@
+--- validate.php.orig 2017-01-15 20:10:36.344602000 +0000
++++ validate.php 2017-01-15 20:04:36.094612000 +0000
+@@ -103,10 +103,10 @@
+ print_fail('You need to run this script as root' . (isset($config['user']) ? ' or '.$config['user'] : ''));
+ }
+
+-if ($config['update_channel'] == 'master' && $cur_sha != $versions['github']['sha']) {
+- $commit_date = new DateTime('@'.$versions['local_date'], new DateTimeZone(date_default_timezone_get()));
+- print_warn("Your install is out of date, last update: " . $commit_date->format('r'));
+-}
++#if ($config['update_channel'] == 'master' && $cur_sha != $versions['github']['sha']) {
++# $commit_date = new DateTime('@'.$versions['local_date'], new DateTimeZone(date_default_timezone_get()));
++# print_warn("Your install is out of date, last update: " . $commit_date->format('r'));
++#}
+
+ // Check php modules we use to make sure they are loaded
+ $extensions = array('pcre','curl','session','snmp','mcrypt');
+@@ -250,20 +250,20 @@
+ print_list($devices, "\t %s\n");
+ }
+
+-if ($versions['local_branch'] != 'master') {
+- print_warn("Your local git branch is not master, this will prevent automatic updates.");
+-}
+-
+-// check for modified files
+-$modifiedcmd = 'git diff --name-only --exit-code';
+-if ($username === 'root') {
+- $modifiedcmd = 'su '.$config['user'].' -c "'.$modifiedcmd.'"';
+-}
+-exec($modifiedcmd, $cmdoutput, $code);
+-if ($code !== 0 && !empty($cmdoutput)) {
+- print_warn("Your local git contains modified files, this could prevent automatic updates.\nModified files:");
+- print_list($cmdoutput, "\t %s\n");
+-}
++#if ($versions['local_branch'] != 'master') {
++# print_warn("Your local git branch is not master, this will prevent automatic updates.");
++#}
++#
++#// check for modified files
++#$modifiedcmd = 'git diff --name-only --exit-code';
++#if ($username === 'root') {
++# $modifiedcmd = 'su '.$config['user'].' -c "'.$modifiedcmd.'"';
++#}
++#exec($modifiedcmd, $cmdoutput, $code);
++#if ($code !== 0 && !empty($cmdoutput)) {
++# print_warn("Your local git contains modified files, this could prevent automatic updates.\nModified files:");
++# print_list($cmdoutput, "\t %s\n");
++#}
+
+ // Modules test
+ $modules = explode(',', $options['m']);
diff --git a/net-mgmt/librenms/files/pkg-message.in b/net-mgmt/librenms/files/pkg-message.in
index 45df7f0abed5..1f5ca59094f6 100644
--- a/net-mgmt/librenms/files/pkg-message.in
+++ b/net-mgmt/librenms/files/pkg-message.in
@@ -1,4 +1,10 @@
=== Configuration details ===
+The following is recommended for /var/db/mysql/my.cnf
+
+[mysqld]
+innodb_file_per_table=1
+sql-mode=""
+
You can mostly follow the guide at:
http://docs.librenms.org/