aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-03 13:42:20 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-03 13:42:20 +0000
commitdf7ab5150a40a13d7333171548efb200aa9041bb (patch)
tree8263ea28bac6744fd3fc24ad17a05584eba47f5d
parentf0947e3ecc5026a4a6fafee1bf4deb521adbc7c0 (diff)
downloadports-df7ab5150a40a13d7333171548efb200aa9041bb.tar.gz
ports-df7ab5150a40a13d7333171548efb200aa9041bb.zip
Notes
-rw-r--r--games/spider/Makefile8
-rw-r--r--games/spider/files/patch-Imakefile6
-rw-r--r--games/spider/files/patch-globals.h83
-rw-r--r--games/spider/files/patch-main.c11
-rw-r--r--games/spider/files/patch-movelog.c18
-rw-r--r--games/spider/files/patch-spider.c11
-rw-r--r--games/spider/files/patch-spider.man6
7 files changed, 124 insertions, 19 deletions
diff --git a/games/spider/Makefile b/games/spider/Makefile
index a05bc6417bf6..1190a024b755 100644
--- a/games/spider/Makefile
+++ b/games/spider/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spider
PORTVERSION= 1.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SUNSITE/games/solitaires
DISTNAME= ${PORTNAME}
@@ -11,6 +11,12 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Challenging double decked solitaire game
+LICENSE= Spider
+LICENSE_GROUPS= BSD
+LICENSE_NAME= Spider license
+LICENSE_FILE= ${WRKSRC}/copyright.h
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
USES= imake tar:Z xorg
USE_XORG= x11 xext xaw xmu xt sm ice xpm
INSTALL_TARGET= install install.doc
diff --git a/games/spider/files/patch-Imakefile b/games/spider/files/patch-Imakefile
index 74689bc2d961..27aaf677e6f9 100644
--- a/games/spider/files/patch-Imakefile
+++ b/games/spider/files/patch-Imakefile
@@ -1,5 +1,5 @@
---- Imakefile.orig Sat Sep 28 19:46:02 1991
-+++ Imakefile Wed Oct 15 15:15:06 2003
+--- Imakefile.orig 1991-09-28 17:46:02 UTC
++++ Imakefile
@@ -1,6 +1,6 @@
-/**/# Run imake -DUseInstalled -I/usr/lib/X11/config to make a Makefile.
-/**/# This is an R5 style Imakefile, so will need the R5 config files to
@@ -39,7 +39,7 @@
XVTOP = $(XVIEWHOME)
XVLIBSRC = $(XVTOP)/lib
# if UseInstalled
-@@ -253,7 +253,7 @@
+@@ -253,7 +253,7 @@ MakeDirectories(install.man, $(MANDIR))
ComplexProgramTarget($(TARGET))
#ifdef SparcArchitecture
diff --git a/games/spider/files/patch-globals.h b/games/spider/files/patch-globals.h
index 203be244bd95..057cf884f52b 100644
--- a/games/spider/files/patch-globals.h
+++ b/games/spider/files/patch-globals.h
@@ -1,13 +1,84 @@
---- globals.h.orig 1991-09-28 17:46:20.000000000 +0000
-+++ globals.h 2011-07-01 03:25:27.000000000 +0000
-@@ -96,6 +96,10 @@
+--- globals.h.orig 1991-09-28 17:46:20 UTC
++++ globals.h
+@@ -10,40 +10,47 @@
+ *
+ */
+
++#ifdef IN_MAIN
++#define EXTERN
++#warning EXTERN
++#else
++#define EXTERN extern
++#endif
++
+ /*
+ * spider global variables
+ */
+-Display *dpy;
+-int screen;
+-Window table;
++EXTERN Display *dpy;
++EXTERN int screen;
++EXTERN Window table;
+ #ifdef KITLESS
+ Window message_win;
+ XFontStruct *message_font;
+ #endif /* KITLESS */
+-Pixmap greenmap;
+-Pixmap redmap;
+-Pixmap logomap;
++EXTERN Pixmap greenmap;
++EXTERN Pixmap redmap;
++EXTERN Pixmap logomap;
+
+-unsigned long blackpixel;
+-unsigned long whitepixel;
+-unsigned long borderpixel;
+-unsigned long greenpixel;
++EXTERN unsigned long blackpixel;
++EXTERN unsigned long whitepixel;
++EXTERN unsigned long borderpixel;
++EXTERN unsigned long greenpixel;
+
+-Bool is_color;
++EXTERN Bool is_color;
+
+-CardList deck;
+-CardList stack[NUM_STACKS]; /* tableau */
+-CardList piles[NUM_PILES]; /* full suits */
++EXTERN CardList deck;
++EXTERN CardList stack[NUM_STACKS]; /* tableau */
++EXTERN CardList piles[NUM_PILES]; /* full suits */
+
+-int table_height;
+-int table_width;
++EXTERN int table_height;
++EXTERN int table_width;
+
+-int deck_index;
++extern int deck_index;
+
+-int draw_count;
++EXTERN int draw_count;
+
+-Bool restart;
+-int deal_number;
++EXTERN Bool restart;
++EXTERN int deal_number;
+
+ extern char *version;
+ extern char *build_date;
+@@ -96,6 +103,10 @@ void do_expand();
Bool can_get_help_files();
#endif
+-extern char *malloc();
+-extern char *calloc();
+-extern char *realloc();
+#ifndef __FreeBSD__
- extern char *malloc();
- extern char *calloc();
- extern char *realloc();
++EXTERN char *malloc();
++EXTERN char *calloc();
++EXTERN char *realloc();
+#else
+#include <stdlib.h>
+#endif
diff --git a/games/spider/files/patch-main.c b/games/spider/files/patch-main.c
new file mode 100644
index 000000000000..086c40abb690
--- /dev/null
+++ b/games/spider/files/patch-main.c
@@ -0,0 +1,11 @@
+--- main.c.orig 1991-09-28 17:46:54 UTC
++++ main.c
+@@ -14,6 +14,8 @@
+ * Spider solitaire
+ */
+
++#define IN_MAIN
++
+ #include "defs.h"
+ #include "globals.h"
+
diff --git a/games/spider/files/patch-movelog.c b/games/spider/files/patch-movelog.c
index 344fc54ca5f1..9758c781944c 100644
--- a/games/spider/files/patch-movelog.c
+++ b/games/spider/files/patch-movelog.c
@@ -1,12 +1,18 @@
---- movelog.c.orig Tue May 29 18:49:36 2007
-+++ movelog.c Tue May 29 18:52:19 2007
-@@ -33,6 +33,9 @@
+--- movelog.c.orig 1991-09-28 17:46:17 UTC
++++ movelog.c
+@@ -28,10 +28,13 @@ static int move_index = 0;
+ static int *move_cache = NULL;
+ static int cache_size = 0;
- extern int cheat_count;
+-int deck_cache[NUM_CARDS];
+-int deck_index = 0;
++int deck_cache[NUM_CARDS];
++int deck_index = 0;
+ extern int cheat_count;
++
+static int card_to_int(CardPtr card);
+static int restore_game(char *str, char *str2);
-+
+
make_deck_cache()
{
- CardPtr tmp;
diff --git a/games/spider/files/patch-spider.c b/games/spider/files/patch-spider.c
new file mode 100644
index 000000000000..55a243a7aa05
--- /dev/null
+++ b/games/spider/files/patch-spider.c
@@ -0,0 +1,11 @@
+--- spider.c.orig 1991-09-28 17:46:12 UTC
++++ spider.c
+@@ -14,6 +14,8 @@
+ * Spider card logic
+ */
+
++#define IN_MAIN
++
+ #include "defs.h"
+ #include "globals.h"
+ #include <ctype.h>
diff --git a/games/spider/files/patch-spider.man b/games/spider/files/patch-spider.man
index 6eb8eb30797f..3572cd18096c 100644
--- a/games/spider/files/patch-spider.man
+++ b/games/spider/files/patch-spider.man
@@ -1,6 +1,6 @@
---- spider.man.orig Sun Sep 29 02:46:06 1991
-+++ spider.man Wed Jan 18 00:00:00 2000
-@@ -53,7 +53,7 @@
+--- spider.man.orig 1991-09-28 17:46:06 UTC
++++ spider.man
+@@ -53,7 +53,7 @@ is "true".
Specifies the time (in microseconds) to pause between each move when
showing a Replay. The default is 200.
.TP 8