aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-11-19 23:17:35 +0000
committerJohn Marino <marino@FreeBSD.org>2016-11-19 23:17:35 +0000
commite0063ba1b3957e993ca9b92bb7167fd2ad870999 (patch)
treeb418c6c7a5887c4b049a25a3768a41722bdf1a18
parent7694c2c69332a6b3e8a9ea98510d164b2ce161cc (diff)
downloadports-e0063ba1b3957e993ca9b92bb7167fd2ad870999.tar.gz
ports-e0063ba1b3957e993ca9b92bb7167fd2ad870999.zip
Notes
-rw-r--r--editors/the/Makefile88
1 files changed, 46 insertions, 42 deletions
diff --git a/editors/the/Makefile b/editors/the/Makefile
index 2f0969e06d27..e1f453ba2c9c 100644
--- a/editors/the/Makefile
+++ b/editors/the/Makefile
@@ -3,7 +3,7 @@
PORTNAME= the
PORTVERSION= 3.3.r4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= http://downloads.sourceforge.net/hessling-editor/
DISTNAME= THE-${PORTVERSION:S/.r/RC/}
@@ -15,49 +15,54 @@ LICENSE= GPLv2
BROKEN_powerpc= fails to configure
-USES= ncurses
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-ncurses \
- --with-rexxincdir=${LOCALBASE}/include \
+CONFIGURE_ARGS= --with-rexxincdir=${LOCALBASE}/include \
--with-rexxlibdir=${LOCALBASE}/lib
ALL_TARGET= all html
+CPPFLAGS+= -I${LOCALBASE}/include
-OPTIONS_DEFINE= XAW3D XCURSES REXX_IMC
-XAW3D_DESC= Enable Xaw3D
-XCURSES_DESC= Build XCurses (X11) version
-REXX_REGINA_DESC= Enable Rexx interpreter
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MXAW3D}
-CONFIGURE_ARGS+=--with-xaw3d
-LIB_DEPENDS+= libxaw3d.so:x11-toolkits/Xaw3d
-.endif
-
-.if ${PORT_OPTIONS:MXCURSES}
-CONFIGURE_ARGS+=--with-xcurses \
- --with-cursesincdir=${LOCALBASE}/include \
- --with-curseslibdir=${LOCALBASE}/lib
-BUILD_DEPENDS+= pdcurses:devel/pdcurses
-LIB_DEPENDS+= libxcurses.so:devel/pdcurses
-PLIST_SUB= XCURSES="" NCURSES="@comment "
-.else
-PLIST_SUB= XCURSES="@comment " NCURSES=""
-.endif
-
-.if ${PORT_OPTIONS:MREXX_IMC}
-BUILD_DEPENDS+= rexx:lang/rexx-imc
-RUN_DEPENDS+= rexx:lang/rexx-imc
-CONFIGURE_ARGS+= --with-rexx=rexximc
-.else
-BUILD_DEPENDS+= regina:lang/rexx-regina
-RUN_DEPENDS+= regina:lang/rexx-regina
-CONFIGURE_ARGS+= --with-rexx=regina
-.endif
+OPTIONS_DEFINE= XAW3D
+OPTIONS_SINGLE= Display Rexx
+OPTIONS_SINGLE_Display= NCURSES XCURSES
+OPTIONS_SINGLE_Rexx= REXX_IMC REGINA
+OPTIONS_DEFAULT= NCURSES REGINA
+OPTIONS_SUB= yes
+
+XAW3D_DESC= Enable Xaw3D
+NCURSES_DESC= Build standard NCurses version
+XCURSES_DESC= Build XCurses (X11) version
+REXX_IMC_DESC= Use Rexx/imc interpreter
+REGINA_DESC= Use Regina Rexx interpreter
+
+XAW3D_CONFIGURE_WITH= xaw3d
+XAW3D_BUILD_DEPENDS= ${LOCALBASE}/lib/libXaw3d.a:x11-toolkits/Xaw3d
+
+NCURSES_USES= ncurses
+NCURSES_CONFIGURE_ON= --with-ncurses \
+ --with-cursesincdir=${NCURSESINC} \
+ --with-curseslibdir=${NCURSESLIB}
+
+XCURSES_LIB_DEPENDS= libXCurses.so:devel/pdcurses
+XCURSES_CONFIGURE_ON= --with-xcurses \
+ --with-cursesincdir=${LOCALBASE}/include \
+ --with-curseslibdir=${LOCALBASE}/lib
+XCURSES_CFLAGS= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/xcurses
+
+REXX_IMC_CONFIGURE_ON= --with-rexx=rexximc
+REXX_IMC_BUILD_DEPENDS= rexx:lang/rexx-imc
+REXX_IMC_RUN_DEPENDS= rexx:lang/rexx-imc
+REXX_IMC_BROKEN= fails to build with REXX_IMC option
+
+REGINA_CONFIGURE_ON= --with-rexx=regina
+REGINA_BUILD_DEPENDS= regina:lang/rexx-regina
+REGINA_RUN_DEPENDS= regina:lang/rexx-regina
post-extract:
${REINPLACE_CMD} -e 's|(datadir)/THE|(datadir)/the|g' \
- -e 's|/share/THE|/share/the|g' ${WRKSRC}/Makefile.in
+ -e 's|/share/THE|/share/the|g' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's|ltermcap|lncurses|g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '/FUNCTION_KEY/d' ${WRKSRC}/the.c
pre-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -65,13 +70,12 @@ pre-install:
${INSTALL_DATA} ${WRKSRC}/the64.gif ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/the64.png ${STAGEDIR}${DOCSDIR}
-post-install:
-.if ${PORT_OPTIONS:MXCURSES}
+do-install-XCURSES-on:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xthe
${LN} -sf xthe ${STAGEDIR}${PREFIX}/bin/the
-.else
+
+do-install-NCURSES-on:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/nthe
${LN} -sf nthe ${STAGEDIR}${PREFIX}/bin/the
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>