aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-04-25 10:33:56 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-04-25 10:33:56 +0000
commite00a6b1ba11af6499487be4d9c7f00e86a3ffee8 (patch)
tree19ca3999f04685fe110ec3d2e40f02595907f053
parent0872f9aefdef1dcc6e629160349a910a4654fa2b (diff)
downloadports-e00a6b1ba11af6499487be4d9c7f00e86a3ffee8.tar.gz
ports-e00a6b1ba11af6499487be4d9c7f00e86a3ffee8.zip
databases/pecl-redis: Update and split into new port
This update consists of two parts which updates current port and creates a new port with the old version as there are breaking changes in the new version. PR: 227396 Submitted by: Daniel Ylitalo <daniel@blodan.se> (maintainer) Differential Revision: https://reviews.freebsd.org/D15146
Notes
Notes: svn path=/head/; revision=468272
-rw-r--r--UPDATING8
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-redis/Makefile4
-rw-r--r--databases/pecl-redis/distinfo6
-rw-r--r--databases/pecl-redis3/Makefile25
-rw-r--r--databases/pecl-redis3/distinfo3
-rw-r--r--databases/pecl-redis3/pkg-descr5
7 files changed, 48 insertions, 4 deletions
diff --git a/UPDATING b/UPDATING
index c425dc3f174a..4be5f685d39d 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20180425:
+ AFFECTS: users of databases/pecl-redis
+ AUTHOR: daniel@blodan.se
+
+ pecl-redis 4.0.0 breaks backwards compatibility, users
+ not aware if you are using the changed functionality or not
+ should swap to databases/pecl-redis3
+
20180417:
AFFECTS: users of dns/dnscrypt-proxy2
AUTHOR: egypcio@googlemail.com
diff --git a/databases/Makefile b/databases/Makefile
index e07e7cfeed9c..a6efe0c09fc9 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -561,6 +561,7 @@
SUBDIR += pecl-mongodb
SUBDIR += pecl-pdo_user
SUBDIR += pecl-redis
+ SUBDIR += pecl-redis3
SUBDIR += pecl-rrd
SUBDIR += pecl-rrd1
SUBDIR += pecl-tokyo_tyrant
diff --git a/databases/pecl-redis/Makefile b/databases/pecl-redis/Makefile
index 551b0ac3a480..c95e049e05f2 100644
--- a/databases/pecl-redis/Makefile
+++ b/databases/pecl-redis/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= redis
-PORTVERSION= 3.1.6
+PORTVERSION= 4.0.0
CATEGORIES= databases
MAINTAINER= daniel@blodan.se
@@ -10,6 +10,8 @@ COMMENT= Extension to access Redis
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/COPYING
+CONFLICTS_INSTALL= pecl-redis3
+
USES= php:pecl
USE_PHP= session:build
diff --git a/databases/pecl-redis/distinfo b/databases/pecl-redis/distinfo
index 2571833fdb24..87d037ab556b 100644
--- a/databases/pecl-redis/distinfo
+++ b/databases/pecl-redis/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515603372
-SHA256 (PECL/redis-3.1.6.tgz) = b229274cdc14c22efc41fefa00db4dc5bb32a997d6811278662a043a76aa2600
-SIZE (PECL/redis-3.1.6.tgz) = 199920
+TIMESTAMP = 1523299384
+SHA256 (PECL/redis-4.0.0.tgz) = c8a969cca131efa9e583c11e6522953a9165b804dbc5d2cba8875323ab22cfc1
+SIZE (PECL/redis-4.0.0.tgz) = 212340
diff --git a/databases/pecl-redis3/Makefile b/databases/pecl-redis3/Makefile
new file mode 100644
index 000000000000..4a8217d7b086
--- /dev/null
+++ b/databases/pecl-redis3/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= redis
+PORTVERSION= 3.1.6
+CATEGORIES= databases
+PKGNAMESUFFIX= 3
+
+MAINTAINER= daniel@blodan.se
+COMMENT= Extension to access Redis
+
+LICENSE= PHP301
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS_INSTALL= pecl-redis
+
+USES= php:pecl
+USE_PHP= session:build
+
+OPTIONS_DEFINE= IGBINARY
+IGBINARY_DESC= Build with Igbinary serializer
+
+IGBINARY_CONFIGURE_ENABLE= redis-igbinary
+IGBINARY_USE= php=igbinary:build
+
+.include <bsd.port.mk>
diff --git a/databases/pecl-redis3/distinfo b/databases/pecl-redis3/distinfo
new file mode 100644
index 000000000000..2571833fdb24
--- /dev/null
+++ b/databases/pecl-redis3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515603372
+SHA256 (PECL/redis-3.1.6.tgz) = b229274cdc14c22efc41fefa00db4dc5bb32a997d6811278662a043a76aa2600
+SIZE (PECL/redis-3.1.6.tgz) = 199920
diff --git a/databases/pecl-redis3/pkg-descr b/databases/pecl-redis3/pkg-descr
new file mode 100644
index 000000000000..a23d5e2c08cf
--- /dev/null
+++ b/databases/pecl-redis3/pkg-descr
@@ -0,0 +1,5 @@
+This extension provides an API for communicating with Redis database,
+a persistent key-value database with built-in net interface written
+in ANSI-C for Posix systems.
+
+WWW: https://pecl.php.net/package/redis