aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 09:51:36 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-11 09:51:36 +0000
commite04596d72eed49b08af4f018be6a29a86e7dca5f (patch)
tree0a9655f722e7d7d6ba93044e8f28d02393883bf3
parentc37688e9a02127e47c98de989f2df1c57767650e (diff)
downloadports-e04596d72eed49b08af4f018be6a29a86e7dca5f.tar.gz
ports-e04596d72eed49b08af4f018be6a29a86e7dca5f.zip
Notes
-rw-r--r--accessibility/at-spi2-atk/Makefile2
-rw-r--r--accessibility/at-spi2-core/Makefile2
-rw-r--r--accessibility/dasher/Makefile17
-rw-r--r--accessibility/dasher/pkg-plist1
-rw-r--r--accessibility/eflite/Makefile14
-rw-r--r--accessibility/gnopernicus/Makefile2
-rw-r--r--accessibility/gok/Makefile4
-rw-r--r--accessibility/orca/Makefile2
8 files changed, 14 insertions, 30 deletions
diff --git a/accessibility/at-spi2-atk/Makefile b/accessibility/at-spi2-atk/Makefile
index 7d08c3d98bd3..6490c64bebbc 100644
--- a/accessibility/at-spi2-atk/Makefile
+++ b/accessibility/at-spi2-atk/Makefile
@@ -14,7 +14,7 @@ COMMENT= Assisted Technology Provider module for GTK+
LICENSE= LGPL21
BUILD_DEPENDS= at-spi2-core>=2.8.0:${PORTSDIR}/accessibility/at-spi2-core
-LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
RUN_DEPENDS= at-spi2-core>=2.8.0:${PORTSDIR}/accessibility/at-spi2-core
PORTSCOUT= limitw:1,even
diff --git a/accessibility/at-spi2-core/Makefile b/accessibility/at-spi2-core/Makefile
index 92d3ccebe535..e5bab56a3151 100644
--- a/accessibility/at-spi2-core/Makefile
+++ b/accessibility/at-spi2-core/Makefile
@@ -13,7 +13,7 @@ COMMENT= Assistive Technology Service Provider Interface
LICENSE= LGPL21
-LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
PORTSCOUT= limitw:1,even
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 107805c07813..e22822999145 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -14,15 +14,13 @@ MAINTAINER= lewiz@compsoc.man.ac.uk
COMMENT= Information efficient text-entry interface
BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg
+LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg
RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
-NO_STAGE= yes
USE_BZIP2= yes
-USES= gettext gmake pkgconfig
-USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
+USES= gettext gmake pathfix pkgconfig
+USE_GNOME= gnomeprefix intlhack gnomehier libgnomeui atspi \
libwnck gnomedocutils
-WANT_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
@@ -30,14 +28,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= dasher.schemas
-MAN1= dasher.1
-.include <bsd.port.pre.mk>
-
-#.if ${HAVE_GNOME:Mgnomespeech}!=""
-#USE_GNOME+= gnomespeech
-#CONFIGURE_ARGS+=--enable-speech
-#.endif
CONFIGURE_ARGS+= --disable-speech
post-patch:
@@ -47,4 +38,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|__gnu_cxx::lldiv|lldiv|' \
${WRKSRC}/Src/DasherCore/DasherViewSquare.cpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index d85bc375304f..4a953829f4d2 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -1,4 +1,5 @@
bin/dasher
+man/man1/dasher.1.gz
share/applications/dasher.desktop
%%DATADIR%%/alphabet.AfaanOromo.xml
%%DATADIR%%/alphabet.Armenian.xml
diff --git a/accessibility/eflite/Makefile b/accessibility/eflite/Makefile
index db78b197da01..a9d3dbe44a07 100644
--- a/accessibility/eflite/Makefile
+++ b/accessibility/eflite/Makefile
@@ -12,7 +12,6 @@ COMMENT= Speech server for Festival Lite used by yasr and Emacspeak
BUILD_DEPENDS= flite:${PORTSDIR}/audio/flite
RUN_DEPENDS= flite:${PORTSDIR}/audio/flite
-NO_STAGE= yes
USES= gmake
GNU_CONFIGURE= yes
ALL_TARGET= eflite
@@ -47,15 +46,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|/etc/es\.conf|${PREFIX}/etc/es.conf|;s|sockname|socketfile|g' ${WRKSRC}/INSTALL
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
-.endif
- ${INSTALL_DATA} ${FILESDIR}/es.conf.sample ${PREFIX}/etc
- @if [ ! -f ${PREFIX}/etc/es.conf ]; then \
- ${CP} -p ${PREFIX}/etc/es.conf.sample ${PREFIX}/etc/es.conf ; \
- fi
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/es.conf.sample ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.mk>
diff --git a/accessibility/gnopernicus/Makefile b/accessibility/gnopernicus/Makefile
index 7d72460d9135..84937ba7476b 100644
--- a/accessibility/gnopernicus/Makefile
+++ b/accessibility/gnopernicus/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Collection of accessibility apps for GNOME 2
-LIB_DEPENDS= gnome-mag.2:${PORTSDIR}/accessibility/gnome-mag
+LIB_DEPENDS= libgnome-mag.so:${PORTSDIR}/accessibility/gnome-mag
NO_STAGE= yes
USE_BZIP2= yes
diff --git a/accessibility/gok/Makefile b/accessibility/gok/Makefile
index e319cbd918c4..b14207062ffc 100644
--- a/accessibility/gok/Makefile
+++ b/accessibility/gok/Makefile
@@ -13,8 +13,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME On-Screen Keyboard (GOK)
-LIB_DEPENDS= canberra-gtk.0:${PORTSDIR}/audio/libcanberra \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libcanberra-gtk.so:${PORTSDIR}/audio/libcanberra \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
NO_STAGE= yes
USE_BZIP2= yes
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index 1fc8fae5d14c..0d55dea67dc1 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -15,7 +15,7 @@ COMMENT= Scriptable screen reader
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/pyatspi/__init__.py:${PORTSDIR}/accessibility/at-spi \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
-LIB_DEPENDS= gnome-mag.2:${PORTSDIR}/accessibility/gnome-mag
+LIB_DEPENDS= libgnome-mag.so:${PORTSDIR}/accessibility/gnome-mag
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/pyatspi/__init__.py:${PORTSDIR}/accessibility/at-spi \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg