aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-02-03 23:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-02-03 23:46:51 +0000
commite0d30ba47d11444ab6e3572393b730b1290f51a8 (patch)
tree15665d75283e6749ada3123687608c30fca64abb
parent2dd52c170a6caee93d2f5600c74a53e1896b4578 (diff)
downloadports-e0d30ba47d11444ab6e3572393b730b1290f51a8.tar.gz
ports-e0d30ba47d11444ab6e3572393b730b1290f51a8.zip
Notes
-rw-r--r--games/allacrost/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/games/allacrost/Makefile b/games/allacrost/Makefile
index 8cb9f019d9ed..d35ed1a6f33c 100644
--- a/games/allacrost/Makefile
+++ b/games/allacrost/Makefile
@@ -37,11 +37,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= MANUAL
-OPTIONS= EDITOR "Enable editor" off
+OPTIONS_DEFINE= EDITOR DOCS
+EDITOR_DESC= Enable editor
.include <bsd.port.options.mk>
-.if defined(WITH_EDITOR)
+.if ${PORT_OPTIONS:MEDITOR}
QT_NONSTANDARD= yes
USE_QT4+= corelib gui opengl moc_build qt3support
CONFIGURE_ARGS+=--enable-editor=yes
@@ -61,7 +62,7 @@ post-patch:
@${REINPLACE_CMD} -e '/qt4_incdirs/ s|".*"|"${QT_INCDIR}"|; \
/qt4_libdirs/ s|".*"|"${QT_LIBDIR}"|; /test/ s|==|=|' \
${WRKSRC}/configure
-.if defined(WITH_EDITOR)
+.if ${PORT_OPTIONS:MEDITOR}
@${REINPLACE_CMD} -e '/^INCLUDES = / s|=|= -I${QT_INCDIR}/QtGui \
-I${QT_INCDIR}/QtOpenGL -I${QT_INCDIR}/Qt3Support \
-I${QT_INCDIR}/QtCore -I${QT_INCDIR}|' \
@@ -69,7 +70,7 @@ post-patch:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}