aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-04-24 20:36:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-04-24 20:36:39 +0000
commite1042f502747f062d730fcb925bc3347b3cdce5b (patch)
treef27973ff7f5a6599ad5cc077b8b3eb14bd4b8723
parent2f1603335e1122a1aa76f5c7785896e315c891ea (diff)
downloadports-e1042f502747f062d730fcb925bc3347b3cdce5b.tar.gz
ports-e1042f502747f062d730fcb925bc3347b3cdce5b.zip
Notes
-rw-r--r--math/grace/Makefile12
-rw-r--r--math/grace/distinfo6
-rw-r--r--math/grace/files/patch-aa14
-rw-r--r--math/grace/pkg-plist285
4 files changed, 163 insertions, 154 deletions
diff --git a/math/grace/Makefile b/math/grace/Makefile
index c9a2f58f58d4..e546e874ea3e 100644
--- a/math/grace/Makefile
+++ b/math/grace/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= grace
-PORTVERSION= 5.1.20
-PORTREVISION= 2
+PORTVERSION= 5.1.21
CATEGORIES= math print
#
MASTER_SITES= ftp://plasma-gate.weizmann.ac.il/pub/grace/src/stable/ \
@@ -27,30 +26,29 @@ LIB_DEPENDS= Xbae:${PORTSDIR}/x11-toolkits/xbae \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
t1:${PORTSDIR}/devel/t1lib \
- XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml \
+ XmHTML.1:${PORTSDIR}/x11-toolkits/xmhtml\
pdf.8:${PORTSDIR}/print/pdflib
MAN1= convcal.1 grace.1 xmgrace.1 gracebat.1 grconvert.1
-USE_X_PREFIX= YES
USE_GMAKE= YES
USE_MOTIF= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS= \
--with-extra-incpath=${X11BASE}/include/X11:${LOCALBASE}/include \
--with-extra-ldpath=${LOCALBASE}/lib --without-bundled_xbae \
- --enable-grace-home=${X11BASE}/lib/X11/grace
+ --enable-grace-home=${DATADIR}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
ALL_TARGET= # empty
INSTALL_TARGET= install links
-post-patch:
+pre-configure:
@${REINPLACE_CMD} -e "s%-lXm %${MOTIFLIB} %" ${WRKSRC}/configure
post-install:
.if !defined(NOPORTDOCS)
if [ ! -e ${DOCSDIR} ]; then \
- ${LN} -s ${X11BASE}/lib/X11/grace/doc ${DOCSDIR}; \
+ ${LN} -s ${DATADIR}/doc ${DOCSDIR}; \
fi
.endif
diff --git a/math/grace/distinfo b/math/grace/distinfo
index f6982867d3aa..0ad209f00377 100644
--- a/math/grace/distinfo
+++ b/math/grace/distinfo
@@ -1,3 +1,3 @@
-MD5 (grace-5.1.20.tar.gz) = 37bdb28b9e30b8e5061ed3f8e0ab9168
-SHA256 (grace-5.1.20.tar.gz) = 8524d54505bf634b038c054850ff71eed119dc96f3d5e3706b4e4ff4b07d4b13
-SIZE (grace-5.1.20.tar.gz) = 2458543
+MD5 (grace-5.1.21.tar.gz) = db02dee3c68179c41452e652bd469bb9
+SHA256 (grace-5.1.21.tar.gz) = 30e4b5d86f4b966428aac5d8c5d0468bcf28226eea9e00d9eb4886f4ab094b00
+SIZE (grace-5.1.21.tar.gz) = 2474115
diff --git a/math/grace/files/patch-aa b/math/grace/files/patch-aa
index 891a0a321fd6..71e9b196a5d8 100644
--- a/math/grace/files/patch-aa
+++ b/math/grace/files/patch-aa
@@ -1,5 +1,5 @@
---- configure.orig Sat Nov 26 23:13:06 2005
-+++ configure Mon Dec 12 21:25:36 2005
+--- configure.orig Fri Feb 16 23:44:49 2007
++++ configure Tue Apr 24 21:04:24 2007
@@ -8184,7 +8184,7 @@
# It thinks the first close brace ends the variable substitution.
test -z "$INSTALL_PROGRAM" && INSTALL_PROGRAM='${INSTALL}'
@@ -9,3 +9,13 @@
test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
+@@ -15181,7 +15181,8 @@
+ int main(void) {
+ char *vlib;
+ vlib = nc_inq_libvers();
+- if (strcmp(vlib, "3.0") < 0) {
++ // FreeBSD: only check the major == 3
++ if (vlib[1] != '3') {
+ exit(1);
+ }
+ exit(0);
diff --git a/math/grace/pkg-plist b/math/grace/pkg-plist
index 3bb4bb89e262..30192a48e6b3 100644
--- a/math/grace/pkg-plist
+++ b/math/grace/pkg-plist
@@ -2,147 +2,148 @@ bin/grace
bin/gracebat
bin/xmgrace
include/grace_np.h
-lib/X11/grace/auxiliary/README
-lib/X11/grace/auxiliary/convcal.c
-lib/X11/grace/auxiliary/magic.grace
-lib/X11/grace/bin/convcal
-lib/X11/grace/bin/fdf2fit
-lib/X11/grace/bin/gracebat
-lib/X11/grace/bin/grconvert
-lib/X11/grace/bin/xmgrace
-lib/X11/grace/doc/10.1.dat
-lib/X11/grace/doc/10a.dat
-lib/X11/grace/doc/10b.dat
-lib/X11/grace/doc/10c.dat
-lib/X11/grace/doc/2.1.dat
-lib/X11/grace/doc/3.dat
-lib/X11/grace/doc/7.1.2.agr
-lib/X11/grace/doc/7.1.3.agr
-lib/X11/grace/doc/8.2.dat
-lib/X11/grace/doc/CHANGES.html
-lib/X11/grace/doc/FAQ.dvi
-lib/X11/grace/doc/FAQ.html
-lib/X11/grace/doc/GPL.html
-lib/X11/grace/doc/Tutorial.dvi
-lib/X11/grace/doc/Tutorial.html
-lib/X11/grace/doc/UsersGuide.dvi
-lib/X11/grace/doc/UsersGuide.html
-lib/X11/grace/doc/convcal.1
-lib/X11/grace/doc/grace.1
-lib/X11/grace/doc/gracebat.1
-lib/X11/grace/doc/grconvert.1
-lib/X11/grace/doc/mygraph.png
-lib/X11/grace/doc/nohelp.html
-lib/X11/grace/doc/philosophical-gnu-sm.jpg
-lib/X11/grace/doc/shiftdata.sh
-lib/X11/grace/doc/xmgrace.1
-lib/X11/grace/examples/altaxis.par
-lib/X11/grace/examples/arrows.agr
-lib/X11/grace/examples/au.agr
-lib/X11/grace/examples/axes.agr
-lib/X11/grace/examples/bar.agr
-lib/X11/grace/examples/boxplot.agr
-lib/X11/grace/examples/brw.dat
-lib/X11/grace/examples/chartebar.agr
-lib/X11/grace/examples/charts.agr
-lib/X11/grace/examples/co2.agr
-lib/X11/grace/examples/co2.par
-lib/X11/grace/examples/dotest
-lib/X11/grace/examples/explain.agr
-lib/X11/grace/examples/fills.agr
-lib/X11/grace/examples/graphs.par
-lib/X11/grace/examples/hilo.agr
-lib/X11/grace/examples/log.dat
-lib/X11/grace/examples/log2.agr
-lib/X11/grace/examples/logistic.agr
-lib/X11/grace/examples/logistic.fit
-lib/X11/grace/examples/logit.agr
-lib/X11/grace/examples/logtest.par
-lib/X11/grace/examples/manygraphs.agr
-lib/X11/grace/examples/mlo.dat
-lib/X11/grace/examples/motif.agr
-lib/X11/grace/examples/pie.agr
-lib/X11/grace/examples/polar.agr
-lib/X11/grace/examples/props.agr
-lib/X11/grace/examples/reciprocal.agr
-lib/X11/grace/examples/regions.par
-lib/X11/grace/examples/spectrum.agr
-lib/X11/grace/examples/stackedb.agr
-lib/X11/grace/examples/symslines.agr
-lib/X11/grace/examples/terr.agr
-lib/X11/grace/examples/test.com
-lib/X11/grace/examples/test.dat
-lib/X11/grace/examples/test1.par
-lib/X11/grace/examples/test2.agr
-lib/X11/grace/examples/tfonts.agr
-lib/X11/grace/examples/tforms.par
-lib/X11/grace/examples/times.agr
-lib/X11/grace/examples/tinset.agr
-lib/X11/grace/examples/tlog.agr
-lib/X11/grace/examples/tmc.c
-lib/X11/grace/examples/tstack.agr
-lib/X11/grace/examples/txttrans.agr
-lib/X11/grace/examples/txyr.agr
-lib/X11/grace/examples/typeset.agr
-lib/X11/grace/examples/vmap.agr
-lib/X11/grace/examples/xycolor.agr
-lib/X11/grace/examples/xysize.agr
-lib/X11/grace/examples/xyz.agr
-lib/X11/grace/fonts/FontDataBase
-lib/X11/grace/fonts/enc/CP1251.enc
-lib/X11/grace/fonts/enc/IsoLatin1.enc
-lib/X11/grace/fonts/enc/IsoLatin2.enc
-lib/X11/grace/fonts/enc/IsoLatin7.enc
-lib/X11/grace/fonts/enc/IsoLatin9.enc
-lib/X11/grace/fonts/enc/KOI8-R.enc
-lib/X11/grace/fonts/enc/KOI8-U.enc
-lib/X11/grace/fonts/enc/MacRoman.enc
-lib/X11/grace/fonts/enc/PDFDoc.enc
-lib/X11/grace/fonts/enc/PSLatin1.enc
-lib/X11/grace/fonts/enc/WinAnsi.enc
-lib/X11/grace/fonts/type1/d050000l.afm
-lib/X11/grace/fonts/type1/d050000l.pfb
-lib/X11/grace/fonts/type1/n019003l.afm
-lib/X11/grace/fonts/type1/n019003l.pfb
-lib/X11/grace/fonts/type1/n019004l.afm
-lib/X11/grace/fonts/type1/n019004l.pfb
-lib/X11/grace/fonts/type1/n019023l.afm
-lib/X11/grace/fonts/type1/n019023l.pfb
-lib/X11/grace/fonts/type1/n019024l.afm
-lib/X11/grace/fonts/type1/n019024l.pfb
-lib/X11/grace/fonts/type1/n021003l.afm
-lib/X11/grace/fonts/type1/n021003l.pfb
-lib/X11/grace/fonts/type1/n021004l.afm
-lib/X11/grace/fonts/type1/n021004l.pfb
-lib/X11/grace/fonts/type1/n021023l.afm
-lib/X11/grace/fonts/type1/n021023l.pfb
-lib/X11/grace/fonts/type1/n021024l.afm
-lib/X11/grace/fonts/type1/n021024l.pfb
-lib/X11/grace/fonts/type1/n022003l.afm
-lib/X11/grace/fonts/type1/n022003l.pfb
-lib/X11/grace/fonts/type1/n022004l.afm
-lib/X11/grace/fonts/type1/n022004l.pfb
-lib/X11/grace/fonts/type1/n022023l.afm
-lib/X11/grace/fonts/type1/n022023l.pfb
-lib/X11/grace/fonts/type1/n022024l.afm
-lib/X11/grace/fonts/type1/n022024l.pfb
-lib/X11/grace/fonts/type1/s050000l.afm
-lib/X11/grace/fonts/type1/s050000l.pfb
-lib/X11/grace/gracerc
-lib/X11/grace/gracerc.user
-lib/X11/grace/include/grace_np.h
-lib/X11/grace/lib/libgrace_np.a
-lib/X11/grace/templates/Default.agr
+%%DATADIR%%/auxiliary/README
+%%DATADIR%%/auxiliary/convcal.c
+%%DATADIR%%/auxiliary/magic.grace
+%%DATADIR%%/bin/convcal
+%%DATADIR%%/bin/fdf2fit
+%%DATADIR%%/bin/gracebat
+%%DATADIR%%/bin/grconvert
+%%DATADIR%%/bin/xmgrace
+%%DATADIR%%/doc/10.1.dat
+%%DATADIR%%/doc/10a.dat
+%%DATADIR%%/doc/10b.dat
+%%DATADIR%%/doc/10c.dat
+%%DATADIR%%/doc/2.1.dat
+%%DATADIR%%/doc/3.dat
+%%DATADIR%%/doc/7.1.2.agr
+%%DATADIR%%/doc/7.1.3.agr
+%%DATADIR%%/doc/8.2.dat
+%%DATADIR%%/doc/CHANGES.html
+%%DATADIR%%/doc/FAQ.dvi
+%%DATADIR%%/doc/FAQ.html
+%%DATADIR%%/doc/GPL.html
+%%DATADIR%%/doc/Tutorial.dvi
+%%DATADIR%%/doc/Tutorial.html
+%%DATADIR%%/doc/UsersGuide.dvi
+%%DATADIR%%/doc/UsersGuide.html
+%%DATADIR%%/doc/convcal.1
+%%DATADIR%%/doc/grace.1
+%%DATADIR%%/doc/gracebat.1
+%%DATADIR%%/doc/grconvert.1
+%%DATADIR%%/doc/mygraph.png
+%%DATADIR%%/doc/nohelp.html
+%%DATADIR%%/doc/philosophical-gnu-sm.jpg
+%%DATADIR%%/doc/shiftdata.sh
+%%DATADIR%%/doc/xmgrace.1
+%%DATADIR%%/examples/altaxis.par
+%%DATADIR%%/examples/arrows.agr
+%%DATADIR%%/examples/au.agr
+%%DATADIR%%/examples/axes.agr
+%%DATADIR%%/examples/bar.agr
+%%DATADIR%%/examples/boxplot.agr
+%%DATADIR%%/examples/brw.dat
+%%DATADIR%%/examples/chartebar.agr
+%%DATADIR%%/examples/charts.agr
+%%DATADIR%%/examples/co2.agr
+%%DATADIR%%/examples/co2.par
+%%DATADIR%%/examples/dotest
+%%DATADIR%%/examples/explain.agr
+%%DATADIR%%/examples/fills.agr
+%%DATADIR%%/examples/graphs.par
+%%DATADIR%%/examples/hilo.agr
+%%DATADIR%%/examples/log.dat
+%%DATADIR%%/examples/log2.agr
+%%DATADIR%%/examples/log2log.agr
+%%DATADIR%%/examples/logistic.agr
+%%DATADIR%%/examples/logistic.fit
+%%DATADIR%%/examples/logit.agr
+%%DATADIR%%/examples/logtest.par
+%%DATADIR%%/examples/manygraphs.agr
+%%DATADIR%%/examples/mlo.dat
+%%DATADIR%%/examples/motif.agr
+%%DATADIR%%/examples/pie.agr
+%%DATADIR%%/examples/polar.agr
+%%DATADIR%%/examples/props.agr
+%%DATADIR%%/examples/reciprocal.agr
+%%DATADIR%%/examples/regions.par
+%%DATADIR%%/examples/spectrum.agr
+%%DATADIR%%/examples/stackedb.agr
+%%DATADIR%%/examples/symslines.agr
+%%DATADIR%%/examples/terr.agr
+%%DATADIR%%/examples/test.com
+%%DATADIR%%/examples/test.dat
+%%DATADIR%%/examples/test1.par
+%%DATADIR%%/examples/test2.agr
+%%DATADIR%%/examples/tfonts.agr
+%%DATADIR%%/examples/tforms.par
+%%DATADIR%%/examples/times.agr
+%%DATADIR%%/examples/tinset.agr
+%%DATADIR%%/examples/tlog.agr
+%%DATADIR%%/examples/tmc.c
+%%DATADIR%%/examples/tstack.agr
+%%DATADIR%%/examples/txttrans.agr
+%%DATADIR%%/examples/txyr.agr
+%%DATADIR%%/examples/typeset.agr
+%%DATADIR%%/examples/vmap.agr
+%%DATADIR%%/examples/xycolor.agr
+%%DATADIR%%/examples/xysize.agr
+%%DATADIR%%/examples/xyz.agr
+%%DATADIR%%/fonts/FontDataBase
+%%DATADIR%%/fonts/enc/CP1251.enc
+%%DATADIR%%/fonts/enc/IsoLatin1.enc
+%%DATADIR%%/fonts/enc/IsoLatin2.enc
+%%DATADIR%%/fonts/enc/IsoLatin7.enc
+%%DATADIR%%/fonts/enc/IsoLatin9.enc
+%%DATADIR%%/fonts/enc/KOI8-R.enc
+%%DATADIR%%/fonts/enc/KOI8-U.enc
+%%DATADIR%%/fonts/enc/MacRoman.enc
+%%DATADIR%%/fonts/enc/PDFDoc.enc
+%%DATADIR%%/fonts/enc/PSLatin1.enc
+%%DATADIR%%/fonts/enc/WinAnsi.enc
+%%DATADIR%%/fonts/type1/d050000l.afm
+%%DATADIR%%/fonts/type1/d050000l.pfb
+%%DATADIR%%/fonts/type1/n019003l.afm
+%%DATADIR%%/fonts/type1/n019003l.pfb
+%%DATADIR%%/fonts/type1/n019004l.afm
+%%DATADIR%%/fonts/type1/n019004l.pfb
+%%DATADIR%%/fonts/type1/n019023l.afm
+%%DATADIR%%/fonts/type1/n019023l.pfb
+%%DATADIR%%/fonts/type1/n019024l.afm
+%%DATADIR%%/fonts/type1/n019024l.pfb
+%%DATADIR%%/fonts/type1/n021003l.afm
+%%DATADIR%%/fonts/type1/n021003l.pfb
+%%DATADIR%%/fonts/type1/n021004l.afm
+%%DATADIR%%/fonts/type1/n021004l.pfb
+%%DATADIR%%/fonts/type1/n021023l.afm
+%%DATADIR%%/fonts/type1/n021023l.pfb
+%%DATADIR%%/fonts/type1/n021024l.afm
+%%DATADIR%%/fonts/type1/n021024l.pfb
+%%DATADIR%%/fonts/type1/n022003l.afm
+%%DATADIR%%/fonts/type1/n022003l.pfb
+%%DATADIR%%/fonts/type1/n022004l.afm
+%%DATADIR%%/fonts/type1/n022004l.pfb
+%%DATADIR%%/fonts/type1/n022023l.afm
+%%DATADIR%%/fonts/type1/n022023l.pfb
+%%DATADIR%%/fonts/type1/n022024l.afm
+%%DATADIR%%/fonts/type1/n022024l.pfb
+%%DATADIR%%/fonts/type1/s050000l.afm
+%%DATADIR%%/fonts/type1/s050000l.pfb
+%%DATADIR%%/gracerc
+%%DATADIR%%/gracerc.user
+%%DATADIR%%/include/grace_np.h
+%%DATADIR%%/lib/libgrace_np.a
+%%DATADIR%%/templates/Default.agr
lib/libgrace_np.a
-@dirrm lib/X11/grace/auxiliary
-@dirrm lib/X11/grace/bin
-@dirrm lib/X11/grace/doc
-@dirrm lib/X11/grace/examples
-@dirrm lib/X11/grace/fonts/enc
-@dirrm lib/X11/grace/fonts/type1
-@dirrm lib/X11/grace/fonts
-@dirrm lib/X11/grace/include
-@dirrm lib/X11/grace/lib
-@dirrm lib/X11/grace/templates
-@dirrm lib/X11/grace
+@dirrm %%DATADIR%%/auxiliary
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%/examples
+@dirrm %%DATADIR%%/fonts/enc
+@dirrm %%DATADIR%%/fonts/type1
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/include
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%
%%PORTDOCS%%%%DOCSDIR%%